Přehled dotazů v Power BI Desktop

S Power BI Desktop se můžete připojit ke světu dat, vytvářet působivé a základní sestavy a sdílet své úsilí s ostatními – kteří pak mohou stavět na vaší práci a rozšiřovat své aktivity v oblasti business intelligence.

Zobrazení Power BI Desktopu

Power BI Desktop má tři zobrazení:

  • Zobrazení sestav – Můžete využít dotazů, které si vytvoříte, pro tvorbu poutavých vizualizací a uspořádat je podle svých představ na více stránkách, které pak můžete sdílet s ostatními.
  • Zobrazení tabulky – Podívejte se na data v sestavě v podobě datového modelu, kde můžete přidávat opatření, vytvářet nové sloupce a spravovat relace.
  • Zobrazení modelu – Získejte grafické znázornění relací vytvořených v datovém modelu a podle potřeby je spravujte nebo upravte.

K těmto zobrazením se dostanete tak, že vyberete jednu ze tří ikon na levé straně Power BI Desktopu. Na následujícím obrázku je vybráno Zobrazení sestavy, což je indikováno žlutým pruhem vedle ikony.

Snímek obrazovky Power BI Desktopu s vybraným zobrazením sestavy

Součástí Power BI Desktopu je také Editor Power Query. Pomocí Editor Power Query se připojte k jednomu nebo mnoha zdrojům dat, tvarujte a transformujte data tak, aby vyhovovala vašim potřebám, a pak tento model načtěte do Power BI Desktopu.

Tento článek obsahuje přehled práce s daty v Editor Power Query, ale najdete další informace. Na konci tohoto článku najdete odkazy na podrobné pokyny k podporovaným datovým typům. Najdete zde také pokyny k připojení k datům, formování dat, vytváření relací a o tom, jak začít.

Nejdřív se ale seznámíme s Editor Power Query.

Editor Power Query

Do Editoru Power Query se dostanete tak, že na kartě Domů v Power BI Desktopu vyberete Transformovat data.

Snímek obrazovky Power BI Desktopu se zvýrazněnou ikonou transformovaných dat

Bez datových připojení se Editor Power Query zobrazí jako prázdné podokno připravené pro data.

Snímek obrazovky Power BI Desktopu s Editor Power Query bez datových připojení

Po načtení dotazu se pohled v Editoru Power Query stává zajímavější. Pokud se připojíte k webovému zdroji dat pomocí tlačítka Nový zdroj v levém horním rohu, Editor Power Query načte informace o datech, které pak můžete začít tvarovat.

Takto vypadá Editor Power Query po navázání datového připojení:

  • Na panelu nástrojů je nyní aktivováno mnoho tlačítek pro interakci s daty v dotazu.

  • V levém podokně jsou dotazy uvedené a dostupné pro výběr, zobrazení a tvarování.

  • V prostředním podokně se zobrazí data z vybraného dotazu a jsou k dispozici pro tvarování.

  • Zobrazí se podokno Nastavení dotazu se seznamem vlastností dotazu a použitými kroky.

    Snímek obrazovky Power BI Desktopu s podoknem Nastavení dotazů v Editor Power Query

Tyto čtyři oblasti jsou vysvětleny později: pás karet, podokno Dotazy, zobrazení tabulky a podokno Nastavení dotazu.

Pás karet dotazu

Pás karet v Power Query Editoru se skládá ze šesti karet: Domů, Transformace, Přidat sloupec, Zobrazení, Nástroje a Nápověda.

Karta Domů obsahuje běžné operace dotazu.

Snímek obrazovky Power BI Desktopu s pásem karet Editoru Power Query

Pokud se chcete připojit k datům a zahájit proces sestavování dotazů, vyberte Nový zdroj. Zobrazí se nabídka s nejběžnějšími zdroji dat.

Snímek obrazovky Power BI Desktopu s tlačítkem Nový zdroj

Další informace o dostupných zdrojích dat najdete v tématu Zdroje dat. Informace o připojování k datům, včetně příkladů a kroků, najdete v tématu Připojení k datům.

Karta Transformace poskytuje přístup k běžným úkolům transformace dat, například:

  • Přidání nebo odebrání sloupců
  • Změna datových typů
  • Rozdělení sloupců
  • Další úlohy řízené daty

Snímek obrazovky Power BI Desktopu s kartou Transformace

Další informace o transformaci dat, včetně příkladů, najdete v tématu Kurz: Tvarování a kombinování dat v Power BI Desktopu.

Karta Přidat sloupec poskytuje další úkoly spojené s přidáním sloupce, formátováním dat sloupců a přidáním vlastních sloupců. Následující obrázek ukazuje kartu Přidat sloupec.

Snímek obrazovky Power BI Desktopu s kartou Přidat sloupec

Karta Zobrazení na pásu karet slouží k přepínání zobrazení určitých panelů nebo oken. Slouží také k zobrazení Rozšířeného editoru. Na následujícím obrázku je karta Zobrazení .

Snímek obrazovky z Power BI Desktop se záložkou Zobrazení

Je užitečné vědět, že mnoho úloh dostupných na pásu karet je také dostupné tak, že v prostředním podokně kliknete pravým tlačítkem myši na sloupec nebo jiná data.

Levé podokno (Dotazy)

V levém podokně nebo podokně Dotazy se zobrazí počet aktivních dotazů a název dotazu. Když vyberete dotaz z levého podokna, zobrazí se jeho data v prostředním podokně, kde můžete data tvarovat a transformovat tak, aby vyhovovala vašim potřebám. Následující obrázek znázorňuje levé podokno s dotazem.

Snímek obrazovky Power BI Desktopu s dotazy v levém podokně

Prostřední podokno (data)

V prostředním podokně nebo v podokně Data se zobrazí data z vybraného dotazu. V tomto podokně se provádí velká část práce zobrazení dotazu .

Následující obrázek ukazuje dříve vytvořené webové datové připojení. Vybere se sloupec Celkové skóre a jeho záhlaví se zobrazí po kliknutí pravým tlačítkem myši, aby se zobrazily dostupné položky nabídky. Všimněte si, že mnoho z těchto položek v nabídce zobrazené po kliknutí pravým tlačítkem myši je stejné jako tlačítka na kartách pásu karet.

Snímek obrazovky Power BI Desktopu s daty v prostředním podokně

Když vyberete položku nabídky po kliknutí pravým tlačítkem (nebo tlačítko pásu karet), dotaz použije krok na data. Uloží také krok jako součást samotného dotazu. Kroky se zaznamenávají v podokně Nastavení dotazů v sekvenčním pořadí, jak je popsáno v další části.

Pravé podokno (Nastavení dotazů)

V pravém podokně nebo v podokně Nastavení dotazů se zobrazují všechny kroky přidružené k dotazu. Například na následujícím obrázku odráží část Použitý postup v podokně Nastavení dotazu skutečnost, že jsme právě změnili typ sloupce Celkové skóre.

Snímek obrazovky Power BI Desktopu s nastavením dotazů v pravém podokně

Vzhledem k tomu, že se na dotaz použije další kroky tvarování, jsou zachyceny v části Použitý postup .

Je důležité vědět, že se podkladová data nemění . Místo toho Editor Power Query upravit a tvarovat zobrazení dat. Také formuje a upravuje zobrazení všech interakcí s podkladovými daty, která se vyskytují na základě pohledem tvarovaným a upraveným Editorem Power Query.

V podokně Nastavení dotazů můžete kroky přejmenovat, odstranit kroky nebo změnit pořadí kroků podle potřeby. Uděláte to tak, že kliknete pravým tlačítkem myši na krok v části Použitý postup a vyberete z nabídky, která se zobrazí. Všechny kroky dotazu se provádějí v pořadí, v jakém se zobrazí v podokně Použitý postup .

Snímek obrazovky Power BI Desktopu zobrazující vlastnosti nastavení dotazů a filtry použitých kroků

Rozšířený editor

V Rozšířený editor uvidíte kód, který Editor Power Query vytváří s každým krokem. Umožňuje také vytvořit vlastní kód v jazyce vzorců Power Query M. Pokud chcete spustit rozšířený editor, vyberte Na pásu karet možnost Zobrazit a pak vyberte Rozšířený editor. Zobrazí se okno s kódem vygenerovaným pro vybraný dotaz.
Snímek obrazovky Power BI Desktopu s dialogovým oknem Rozšířený editor

Kód můžete přímo upravit v okně Rozšířený editor. Okno zavřete tak, že vyberete tlačítko Hotovo nebo Zrušit .

Ukládání práce

Pokud je váš dotaz tam, kde ho chcete, vyberte v nabídce Soubor Editor Power Query zavřít a použít. Tato akce použije změny a zavře editor.
Snímek obrazovky Power BI Desktopu s možností Zavřít a použít na kartě Soubor

V průběhu práce poskytuje Power BI Desktop dialogové okno pro zobrazení jeho stavu.
Snímek obrazovky Power BI Desktopu zobrazující potvrzovací dialogové okno Použité změny dotazu

Až budete připraveni, může Power BI Desktop vaši práci uložit ve formě souboru .pbix .

Pokud chcete uložit práci, vyberte Možnost Uložit soubor>(nebo jako), jak je znázorněno na následujícím obrázku. Snímek obrazovky Power BI Desktopu s kartou Editor Power Query Soubor Zvýrazněná možnost Uložit a uložit jako.

S Power BI Desktopem můžete dělat nejrůznější věci. Další informace o svých možnostech najdete v následujících zdrojích informací: