Exchange 2019 installation Failed hybrid environment

jennylee 86 Reputation points

I have an on-prem exch 2016 hybrid (on server 2012 r2 standard). All mailboxes are on O365. I'm setting up a new exch 2019 (server 2019 standard) so I can then get rid of 2016. It gets stuck on Step 8/12 Mailbox service. The system mailboxes are all there, but the homeMDB attribute, has the 2016 server DB in it.

Do I need to change it?

It appears every time I try to reinstall it, that it creates another DB.

I ran all the initial setups:

\Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareSchema

,\setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAD /OrganizationName

.\Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAllDomains

Any ideas?

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,481 questions
Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,985 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,446 questions
0 comments No comments
{count} votes

Accepted answer
  1. Amit Singh 4,866 Reputation points

    In my research, it may be related to the discovery system mailbox. So please check if it exists in "Users" OU.
    If existing, please check the attribute "homeMDB", and ensure that it has a valid value the same as another system mailbox.

    Or run "Get-Mailbox -Filter { RecipientTypeDetails -eq "DiscoveryMailbox"} | fl name, database" to see if it returns any error.

    If anything is wrong, you could try to delete this system database and recreate it by running "Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAD", then re-run the setup wizard and check if the issue persists.
    You could refer to this similar case and this blog, Setup a New Exchange 2019 Server.

    0 comments No comments

5 additional answers

Sort by: Most helpful
  1. jennylee 86 Reputation points

    Currently working on this. I guess I'm confused as to if it matters if the exch 2016 DB is in the homeMDB or the new 2019 exch. I thought they could work together until I decommissioned exch 2016. It seems I have all the system mailboxes but when I run your command I get errors. I'm going to delete them and re-run /PrepareAD. I'm assuming it will create them for the exch 2019. I would eventually like to get rid of any on prem, but I believe that is still not supported by MS.

    0 comments No comments

  2. jennylee 86 Reputation points

    I keep working through different errors then restarting the setup. It seems its fighting with what is already there from the Exch 2016.
    This is my new error

    It looks like I have to go to ADSI edit to CN=protocols then CN=SMTP Receive Connectors, then not sure which one I am to modify. Any help?

    0 comments No comments

  3. KyleXu-MSFT 26,236 Reputation points


    Based on the error information, this issue occurs when create receive connector for 25 and 2525 port. You could log in Exchange admin center to disable them and try again. If you still cannot install successfully, you could try to delete them and reinstall Exchange server.

    About system mailboxes, you could migrate them from Exchange 2016 database to Exchange 2019 database after creating Exchange 2019. Do not modify the homeMDB value directly.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  4. jennylee 86 Reputation points

    or the first error, I went in and deleted all the system mailboxes and re-ran the prepare AD. Created all new system accounts with nothing in homeMDB so that took care of that error then I got more

    The 2nd error listed above, I went into ADSI and under CN=smtp receive connectors - deleted both receive connectors for server I was working on, then re-ran setup ( every time I re-ran to fix an error, I had to keep going in and doing this as well as the regedits to be able to run setup again.)
    couple more errors but finally got it to finish.

    I guess the 2 answers were partially helpful but the first one was more relevant and I can only accept one answer...apparently.
    Thanks so much for the responses.

    0 comments No comments