VM is stuck in starting state, cannot access or redeploy

Francois A 0 Reputation points
2023-09-06T07:30:07.8333333+00:00

I am trying to start multiple VMs on Azure, both Windows and Ubuntu Linux (16.04)

All VM start but one Ubuntu Linux shows a "running" status on Azure Portal but is unavailable as host not up, I cannot connect using ssh, even the serial console on Azure shows nothing and is time outing. Other Ubuntu VMs are fine but this particular one.

Health Events message is "This virtual machine is starting as requested by an authorized user or process. It will be online shortly. " but the VM is not accessible after multiple days. I cannot open a ticket to Microsoft support because the diagnostics see the VM as "running" while it is not running.

I tried to redeploy it with no result.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
5,924 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Olga Osinskaya - MSFT 4,316 Reputation points Microsoft Employee
    2023-09-06T17:58:07.26+00:00

    Hello Francois A,

    Welcome to MS Q&A forum.

    I am sorry to hear you are not able to SSH to your VM.

    First, you need to isolate if this one is OS level (OS is not fully booted, kernel panic as example, or firewall, etc.) or Networking issue when your SSH request is being restricted over NSG, local network, etc.

    You can navigate to the Boot Diagnostic on the virtual machine blade in the Azure portal to find the current booting state of OS.

    In addition, you can stop VM from the Azure Portal and start again to move it to a new hardware if suspect your server maybe affected by platform level issues.

    Reference:

    Troubleshoot Azure VM connectivity problems

    Troubleshoot Azure Linux virtual machine boot errors

    Hope above answers your questions and concerns.


    Let us know if you need additional assistance. If the answer was helpful, please accept it and complete the quality survey so that others can find a solution.

    Sincerely,
    Olga Os

    0 comments No comments

  2. Francois A 0 Reputation points
    2023-09-07T12:44:08.69+00:00

    Hello Olga.

    Thank you for your reply.

    I already stopped and started this VM multiple times, even tried to redeploy and reapply it to no avail. Even the Serial console is timing out. I cannot see starting logs or kernel panic. I just started this VM in Azure portal, it took more than 1 hour for the portal to show it as "started" with errors showing in notifications :

    Failed to start virtual machine '<redacted>'. Error: ajaxExtended call failed

    Still not possible to access serial console from the portal.

    I had hopes 2 days ago as I tried to redeploy the VM and it failed with the following message :

    "We're sorry, your virtual machine isn't available and it is being redeployed due to an unexpected failure on the host server. Azure has begun the auto-recovery process and is currently starting the virtual machine on a different host. No additional action is required from you at this time."

    But 2 days later I am still in the same situation.

    I just enabled "Guest Monitoring" diagnostics but the extension agent cannot be installed on the VM as the host OS is not running. I am at loss here because I am pretty sure the host is not starting at all but the portal is showing a "started" status despite the OS not even starting. Also opening a ticket to support is not possible as the portal checks for availability and returns only green checks.

    I was able to open a support ticket today so I will continue this with Azure support.

    Thanks!