Cannot create Front foor in Azure B2C tenant

Umar Farooq 0 Reputation points


I have a main Azure subscription in which I have created a new B2C tenant. I am following the MSFT document to create custom domain in the B2C tenant and a front door.

The problem I am facing is when I go the marketplace and choose Create front door it is asking me to Start Free Trial/Pay as you go.

I can confirm that my B2C tenant is tied to the main subscription. So why it is asking me create free trial?

I am lost.

Any help would be appreciated.


Azure Front Door
Azure Front Door
An Azure service that provides a cloud content delivery network with threat protection.
598 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,890 questions
{count} votes

1 answer

Sort by: Most helpful
  1. James Hamil 22,431 Reputation points Microsoft Employee

    Hi @Umar Farooq , what document are you following for this? I can follow it and see where the issue is. It might be asking you to start a free trial or pay-as-you-go because you have either exhausted your Azure free account credits, or you are using services that are not included in the free account.

    If this isn't the case, then your subscription might not be associated with your tenant. To check this, you can follow these steps:

    1. Sign in to the Azure portal using your Microsoft account.
    2. In the left-hand menu, select "Azure Active Directory".
    3. Under "Manage", select "Properties".
    4. Look for the "Directory ID" field and copy the value.
    5. In the left-hand menu, select "Subscriptions".
    6. Look for the subscription that you are using to create the Front Door and select it.
    7. Under "Overview", look for the "Subscription ID" field and copy the value.
    8. In the left-hand menu, select "Resource groups".
    9. Look for the resource group that you want to use for the Front Door and select it.
    10. Under "Settings", select "Access control (IAM)".
    11. Look for the "Role assignments" tab and select it.
    12. Look for the "Add" button and select it.
    13. Under "Add role assignment", select "Owner" as the role.
    14. Under "Select", paste the value of the "Directory ID" field that you copied earlier.
    15. Look for the "Save" button and select it.

    Please let me know if you have any questions and I can help you further.

    If this answer helps you please mark "Accept Answer" so other users can reference it.

    Thank you,