Azure Switch Directory not working

Aidin Azimi 30 Reputation points
2023-12-01T08:03:34.7266667+00:00

Dear Support,

I do have access to multiple Tenants (Directories).

Every time I want to switch the directory, I will be switched back to the default directory.

Most of the time I have to either Sign off and sign in again, hopefully after few tries it will work. Other times I have to add the other directory to my favorite and remove the default one from favorites to make it work.

It seems to be a big issue and it causes too much time to be wasted while using Azure with multiple Directories.

Best,

Aidin Azimi

P.S. you dont have any tags for the Directory or Tenant.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,565 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Marilee Turscak-MSFT 36,336 Reputation points Microsoft Employee
    2023-12-01T23:14:08.7566667+00:00

    Hi @Aidin Azimi ,

    Thanks for your post! You will be redirected to the default directory if you have one chosen as the default. If you are having trouble switching directories through the portal setting or due to browser caching, you can redirect manually to the correct directory by navigating to the tenant URL:

    https://portal.azure.com/yourtenant.onmicrosoft.com
    

    Otherwise your directory settings will route you to either the "last visited" directory" or whichever tenant you have selected as the Startup directory. User's image

    If you would like to leave any feedback to improve the experience you can do so in feedback.azure: https://feedback.azure.com/

    If the information helped you, please Accept the answer. This will help us and improve searchability for others in the community who may be researching similar questions. Otherwise, let me know if you have further questions.


  2. Marilee Turscak-MSFT 36,336 Reputation points Microsoft Employee
    2023-12-07T23:39:15.23+00:00

    @Aidin Azimi ,

    If your account is using OTP, you need to sign in using a link that includes the tenant context.

    In the case of a verified domain you would need to use:

    https://myapps.microsoft.com/<verifieddomain>.onmicrosoft.com

    Otherwise you can use:

    https://myapps.microsoft.com/?tenantid=<tenantid>

    https://learn.microsoft.com/en-us/entra/external-id/one-time-passcode#sign-in-endpoints

    If this doesn't work I would also recommend choosing a different startup directory in the settings or using "Restore Default settings" under "My Information", and trying to access from a different device.

    Let me know if you still face this issue.

    0 comments No comments