Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
Use the App settings as PORT 3000 instead of WEBSITES_PORT.
This browser is no longer supported.
Upgrade to Microsoft Edge to take advantage of the latest features, security updates, and technical support.
I have deployed an App Service via Github Workers with node.js now i have the problem, that the node.js Application is running, but the Ports is not exposing. Can everyone give me an advice or is it possible to deactivate HTTP pings? Logs: 2020-11-19T16:19:27.439Z INFO - Initiating warmup request to container X for site X 2020-11-19T16:19:43.733Z INFO - Waiting for response to warmup request for container X. Elapsed time = 16.2938836 sec 2020-11-19T16:23:27.969Z ERROR - Container Xf for site X did not start within expected time limit. Elapsed time = 240.5298169 sec 2020-11-19T16:23:27.970Z ERROR - Container X didn't respond to HTTP pings on port: 8080, failing site start. See container logs for debugging. 2020-11-19T16:23:27.980Z INFO - Stopping site X because it failed during startup. Kind regards, Noah
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
Use the App settings as PORT 3000 instead of WEBSITES_PORT.
I had the same problem with the Keystone 6 (node.js) application. I've tried to deploy it using the Azure web app as code and as a docker container but with the same result: container X didn't respond to HTTP pings. Changing configuration settings PORT and WEBSITES_PORT, as well as EXPOSE in a Dockerfile gave nothing.
Finally, I solved the problem by deploying the application as a container using the pm2 as a server wrapper instead of starting the application with npm as recommended by Microsoft https://learn.microsoft.com/en-us/azure/app-service/configure-language-nodejs?pivots=platform-linux#configure-nodejs-server
pm2-runtime --delay 30 'npm start'
Hope that it helps.
I am having the same issue trying to deploy a Python Flask app that is using port 5000.
For me what ended up working was simply restarting the web application. Not re-deploying but restarting
Also make sure DEBUG=TRUE for some reason in your settings file
I do have the same issue with standard Spring Boot Application.
Any solutions?