SharePoint 2019 On-prem User Profiles not populating from AD.

Keith Vollero 116 Reputation points
2020-12-10T19:44:24.9+00:00

I've created an on-prem SP 2019 installation. Everything seems to be working except the User Profile Synchronization. I know there's a valid connection, because when I set up the Synchronization Connection, the 'Populate Containers' box pulls in the accounts and I see the names of all my users. But I run the full import and nothing seems to happen. Profiles are not imported. I get an error in the ULS log, 'Object reference not set to an instance of an object.'

Here's the strange part - Using a normal user account, I open the SharePoint site, and click my name (upper right-hand corner), then 'About me'. SharePoint creates my OneDrive/MySite. THEN my account appears in the Profile! It even has the info from the AD. But running the Profile Sync does nothing.

Trying to solve the problem, I have -
• Re-created the UP Service app from scratch several times.
• Re-created the AD connection.
• Ensured that the account used has Replicating Directory permissions.
• Ensured that the App Pool is running.
• Done the IISRESET at every step of the way.

What am I missing?

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,843 questions
{count} votes

Accepted answer
  1. Keith Vollero 116 Reputation points
    2020-12-24T18:24:29.953+00:00

    The problem has been solved.
    After writing the last message about the Timer Job, I started poking around IIS. I investigated all the Service jobs that might be involved with the User Profile sync. All seemed to be in order, but for good measure, I stopped, then restarted, all of those.

    And suddenly, the import ran, pulling in all the Profiles.
    I think it might have been the User Profile Service itself, but could have been any, or a combination.


6 additional answers

Sort by: Most helpful
  1. JoyZ 18,046 Reputation points
    2020-12-11T07:24:27.53+00:00

    Hi @Keith Vollero ,

    Whether the profiles not imported means that "Number of User Profiles" is not correct?

    47322-image.png

    Per my research, please try as following:

    1)Select all objects again by clicking in the parent's OU checkbox and saved the changes.

    47294-test.jpg

    2)Try to select another sync option 'Enable External Identity Manager' and saved. Then came back and select 'Use SharePoint Active Directory Import' setting and save.

    This step cleans up the UPS databases from old data that could be causing trouble.

    Remember to disable the Mysite cleanup timer job before working on this.

    More information:

    https://social.technet.microsoft.com/Forums/office/en-US/84ba9181-d02d-46e0-afb1-25ee0597064d/user-profile-service-is-not-updating-from-ad-after-crawl?forum=SP2016


    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Keith Vollero 116 Reputation points
    2020-12-16T15:05:19.427+00:00

    Thank you for the confirmation on 'Select All'. It seemed quirky.
    As to the other question, it isn't the Timer Job that's the problem. The Profile Import won't run even when I try to start it from Central Admin, using the Service Application interface

    48730-capture.jpg:


  3. Keith Vollero 116 Reputation points
    2020-12-22T16:20:52.947+00:00

    Julie,

    The Sync Status is idle, that's the problem, it STAYS idle, even when I run the Sync job. Either one, Full or Incremental, the job just doesn't run. Checking the Timer job shows that the job hasn't run. When I click 'Run' from the Timer job, it still does not run.
    50468-image.png

    In the ULS log, I see this:
    StartImport :: Starting profile full import.

    UserProfileApplication.DumpSynchronizationStatusToFile: Unexpected exception: System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.Office.Server.Administration.UserProfileApplication.DumpSynchronizationStatusToFile().

    0 comments No comments

  4. Andrew Bulle 1 Reputation point
    2022-12-14T18:42:28.33+00:00

    Hi Did you ever fix this ?

    0 comments No comments