Visio 2019 Standard - "Enable Live Dynamics" is greyed out

BBS-MW 6 Reputation points
2021-01-21T16:33:32.687+00:00

I have a user that all of a sudden found that the Live Dynamics was not working on his Visio 2019 Standard (build 16.0.13530.20376) - the latest version as of this morning's date I should note. One of his co-worker's hopped on Chat with Microsoft who basically suggested doing a re-installation of Visio . The user stated that his computer 2 days after this problem was occurring updated itself taking a couple of hours (it updated to 20H2). In a nutshell I've tried all of the steps below and none of them yielded a positive result. The only conclusion I can draw currently is that Visio requires something that is no longer present on the system and that part is refusing to activate. The PC meets the system requirements for Visio , so this must be some other lesser or non-published requirement possibly (or a bug in Visio perhaps)? - As the item is greyed out I'm leaning more to the first hypothesis rather than the latter.

Here's what I've done today:

  • verified the user was in the local administrator's group
  • signed on as a different user that had admin rights, which created a new profile on this computer - the problem still exists there --> note: this is with a fresh profile on this computer.
  • disabled hardware graphics accelleration - no change (re-enabled)
  • tried to do an online repair of visio - no change
  • turned on the setting to put all keys into the registry, then found the registry key for this function (see: https://admx.help/?Category=Office2013&Policy=visio15.Office.Microsoft.Policies.Windows::L_Enablelivedynamics) changed the value to 1 from zero and relaunched visio - no change, checked the registry (still a '1', closed visio - still a '1') - reopened, still disabled
  • Removed visio (then rebooted) and re-installed from the .img file it was originally installed from in 2019 (I believe the build showed as 1808 10730.20102) - no change
  • removed the graphics driver and reverted back to the basic driver - no change
  • ran windows updates to apply the latest driver for this device directly from microsoft (which back-dated the driver version a bit, that's good as I wanted to try a less current vidio driver to see if that helps) - no change
  • found a link (https://answers.microsoft.com/en-us/msoffice/forum/all/visio-pro-dynamic-grid-not-working/bc797b57-9fd1-4a49-98b9-e07d72cf8694?page=2) that mentions about going to the print window, page setup , page size tab and check "let visio expand the page as needed" - but that was already checked.

So to re-nutshell this - repairing / reinstalling , forcing the setting like group policy would (by registry key) - nothing makes the program comply with the instruction to enable that function. I've looked around to see what the pre-requisites for that function are but it doesn't appear to be published.

Anybody from Microsoft have any ideas why this function in your software refuses to activate even when the registry setting is turned on for this (and all of the steps above having been done) ?

Thanks

Visio Management
Visio Management
Visio: A family of Microsoft products used to create diagrams and vector graphics.Management: The act or process of organizing, handling, directing or controlling something.
249 questions
0 comments No comments
{count} vote

6 answers

Sort by: Most helpful
  1. Erin Ding-MSFT 4,456 Reputation points
    2021-01-22T06:05:51.973+00:00

    @BBS-MW

    Based on your description, I have two questions as below.

    1. Are other functions greyed out?
    2. Are you using Remote Desktop?
      This setting is not available under certain circumstances, such as when accessing Visio over Remote Desktop.
      59393-1.png

    Please open Visio in safe mode to eliminate interference from add-ins and startup items to check this issue.

    • Right-click the Start button (lower-left corner) in Windows, and click Run.
    • Type visio /safe, and click OK.

    Any updates, please let me know.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. BBS-MW 6 Reputation points
    2021-01-22T15:49:07.437+00:00

    Thank you for responding :)

    1. No - the other options are not greyed out, just the "Enable Live Dynamics" option
    2. No - the session is directly on the PC and is not being done over any remote access technologies

    The fellow in question is out today so I'll have to follow up with him Monday the 25th.

    Thank you for getting back to me. Please allow me some time to follow up with your other point.

    0 comments No comments

  3. BBS-MW 6 Reputation points
    2021-01-25T15:28:56.603+00:00

    When I ran 'visio /safe' all of the option categories in the options menu were greyed out except "Customize Ribbon" and "Quick Access Toolbar". I repeated that same step as another user on that computer and got the same result.

    0 comments No comments

  4. Nick Mellor 1 Reputation point
    2021-04-07T08:39:17.75+00:00

    did you find a solution?

    0 comments No comments

  5. BBS-MW 6 Reputation points
    2021-04-08T13:53:02.953+00:00

    Unfortunately no, so that user's just been having to live with it.

    I was told by an O365 support person when I contacted them about a different Visio problem in the past that certain problems they just cannot fix. I was told I'd just have to post to the forums because the developers allegedly monitor these. So that's what I was doing here. I think that's just a Microsoft panacea for problems that they have little interest in pursuing a resolution for.

    0 comments No comments