KB4601318 fails to update, fails at 24% Windows Server 2016

Kevin S 96 Reputation points
2021-02-11T00:15:10.047+00:00

Hello,

I have 3 virtual servers that have this exact same issue where when I try to update KB4601318, it stalls at 24%. The servers are 2016 servers, I have disabled anti-virus, I have rebooted, followed instructions on this blog, added RAM and enabled and disabled firewall. I have updated 15 other servers in my environment successfully, running the same antivirus software, same kind of setup. The servers all have 2 or 4 processors, 8 GB or 16 GB of RAM and at least 200+ GB of available disk space. No errors in the event viewer that I can see.

I've let the update run on these machines for 2 hours and what happens is that it will install KB890830 and KB4601392 on all of these machines but not KB4601318 on any of them. It gets stuck at 24% and then eventually stops and reads "KB4601318 is available" "Updates are ready" and Download button is enabled. If I click it, it goes through the exact same cycle where it stalls at 24% again.

Any assistance would be appreciated.

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management updated to data storage.
2,321 questions
{count} votes

Accepted answer
  1. Zabaga, Robert (King of Prussia) 141 Reputation points
    2021-02-11T17:26:11.25+00:00

    I've successfully ran the KB on 2 machines at this point. Pretty much the steps other people listed. I can do on a few VMs but dozens or hundreds across an organization would not work for this....too resource intensive for 1 admin!

    -Download the update from Microsoft Catalog (.msu file)

    -Stop Windows Update Service. For me it didn't stop so I had to set the service to Disabled then go to a command prompt and run "sc queryex wuauserv" then do a "taskkill /f /PID xxxx" (where xxxx is the PID listed from the prior query command).

    Delete or rename the C:\Windows\SoftwareDistribution\ folder

    Now run the .msu update file. A few times I got a pop-up about a stub file error. What is that? Anyway, I waited a minute and ran the .msu again and it unpacked and ran successfully.

    Set Windows Update back to manual

    Reboot. KB installed.

    1 person found this answer helpful.
    0 comments No comments

33 additional answers

Sort by: Most helpful
  1. RAKKABI, SAID 11 Reputation points
    2021-02-12T15:27:56.467+00:00

    This a know issue due to SSU of this month, Microsoft has remove SSU from his catalog due to this issue:
    https://support.microsoft.com/en-us/topic/february-9-2021-kb4601318-os-build-14393-4225-c5e3de6c-e3e6-ffb5-6197-48b9ce16446e

    2 people found this answer helpful.
    0 comments No comments

  2. Kevin S 96 Reputation points
    2021-02-13T09:46:45.027+00:00

    I FINALLY got it working but it would NOT work automatically, it kept hanging up at 0% for me, which isn't a big deal but I just wanted to relay my experience.

    So I had to perform the exact same manual procedure that so many have posted already :

    1.) First, I downloaded the new SSU (THANK YOU SusanBradleyGESC!!!) https://www.catalog.update.microsoft.com/Search.aspx?q=kb5001078
    2.) Next, I already had the KB4601318 but it's here : https://www.catalog.update.microsoft.com/Search.aspx?q=kb4601318
    3.) Next I opened a command prompt (CMD)
    4.) I performed a NET STOP WUAUSERV (that did not work on two of my servers so I did the following:)
    4a.) SC QUERYEX WUAUSERV (to obtain the PID)
    4b.) TASKKILL /F /PID xxxx (where XXXX is the PID from the command from step 4a)
    5.) RENAME %windir%\SoftwareDistribution SoftwareDistribution.bak
    6.) I ran the new SSU KB5001078 (this run took about 3-5 minutes)
    7.) I immediately ran the Feb security update KB4601318 (this run took about 30-45 minutes)
    8.) Reboot (this takes the normal 10 or 15 minutes)

    I know this probably isn't the outcome most of us would have liked but at least it was able to run. Honestly, if I had to do this on ALL 50 or so of my servers, I would be absolutely LIVID!

    One thing I didn't try (and I should have but I just wanted this to be over and done with already, I mean, I started this at 1 AM and it's almost 5:00 AM and I worked a full 8-5 friggin' day today! Anyway, I'm wondering what would have happened if I would have just renamed the SoftwareDistribution folder and let this month's update run naturally?

    Honestly everyone, for me, I tried a bunch of combinations but, ultimately, I honestly think renaming the ENTIRE SoftwareDistribution folder did the trick for me because stopping and starting the WUAUSERV service, running the download locally, running the new SSU, NONE of that was working for me until I ultimately renamed that folder.

    Just my 2 cents. Big shout out to everyone that threw out their experiences, thank you so much everybody!

    2 people found this answer helpful.

  3. Teemo Tang 11,311 Reputation points
    2021-02-11T01:37:44.353+00:00

    Try to reset Windows Update components
    https://learn.microsoft.com/en-us/windows/deployment/update/windows-update-resources
    Then, manually install KB4601318 again.

    -------------------------------------------------------------------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.
    0 comments No comments

  4. Jellison Donna 6 Reputation points
    2021-02-11T17:54:00.077+00:00

    So is this a issue with 2016 in general or just Azure 2016 servers

    1 person found this answer helpful.