question

mjskier-0269 avatar image
9 Votes"
mjskier-0269 asked ScottCrossen-2675 commented

Microphone for teams on Linux not working

On an HP Zbook studio G5 running Mint 19.1
Plantronics C3320 headset plugged into a USB port (on the laptop, not on the G3 docking station)

The teams_1.2.00.32451_amd64.deb package installs fine, and the test call works as expected.
However when calling a coworker, all he hears is very bad static that gets louder when I speak.
Same problem when input is set to the builtin microphone.

In sound preference:
Device set to Plantronic Blackwire 3220 Series Digital Stereo Duplex (IEC958)
Input connector set to "Digital Input (S/PDIF)

In the Teams Settings->Devices, speaker and microphone are set to Plantronic Blackwire 3220 Series Digital Stereo Duplex (IEC958)

office-teams-linux-itpro
· 11
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Don't EVER run any external applications program with root privileges (sudo) - this is opening a major vulnerability on your system

2 Votes 2 ·

running

sudo pulseaudio -D
sudo teams

works for me on ubuntu 20.04




1 Vote 1 ·
Theis-5156 avatar image Theis-5156 ChristianLaurent-6266 ·

sudo teams worked for me.

0 Votes 0 ·

Hi all, any permanent solution to the microphone this?
Using root does not still work for me, Teams can't use the microphone.

0 Votes 0 ·

surprisingly, microphone input still doesn't work on Fedora 33, in the version 1.50, however it works literally everywhere else.

0 Votes 0 ·

teams detects no audio/video devices on my kubuntu 20.10 desktop
notification sound is heard
no devices are selectable in parameters

version de Microsoft Teams est 1.3.00.25560 (64 bits) .




41114-2020-11-19-14-05-49.png41115-2020-11-19-14-03-47.png41067-2020-11-19-14-02-42.png


0 Votes 0 ·

For me, the "No Device" / "Custom Setup" issue was fixed by increasing the number of inotify workers in /proc/sys/fs/inotify/max_user_watches as teams apparantly requires these to list devices

0 Votes 0 ·
Show more comments
OmarKhalidMSFT avatar image
0 Votes"
OmarKhalidMSFT answered KomarovAlexander-1434 edited

@mjskier-0269 thank you for trying Teams for Linux and for sharing your feedback. It looks like this would require some further investigation. Can you please open a support request from https://admin.microsoft.com so that our support team can troubleshoot and assist you in resolving this issue?

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I would, but I can't... Seems that only admins in my organization can open requests... and they don't use Linux, so why would they?

To add insult to injury, this interface fails to attach a screenshot of the error. (So here is the text: "Your account (xxxxx@xxxxxxxxx.com) doesn’t have permission to view or manage this page in the Microsoft 365 admin center.")

If anyone opened such a request, can you link it here?

As a workaround, audio in Teams does work fine in a browser window, but I can only see one person at a time

1 Vote 1 ·
ed-7551 avatar image
0 Votes"
ed-7551 answered AlesZacharie-4283 commented

I'm seeing the same problem on Mint 18.3 with an old Logitech B500 webcam. Was there any progress or resolution on this issue? Thanks.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Interestingly enough, the problem exists even when I'm using the web browser version of teams (through chrome).

0 Votes 0 ·

After poking around a good bit, I realized I should try a mic in the mic jack. That works without any distortion. (The webcam video works fine, so I can use it for video and the mic jack for audio.) I'm still confused why the Teams test call was clean, but not enough to try to dig further.

@ThierryVilmart-0458, you may want to watch https://docs.microsoft.com/answers/questions/3011/microphone-is-not-working.html or https://docs.microsoft.com/answers/questions/11382/microphone-does-not-work-with-teams-only-on-latitu.html - those seem closer to the problem you're describing. One thing you might try is to restart teams after the microphone is plugged in. I don't recall with certainty, but I think my running instance of teams didn't recognize the microphone when I first plugged it in.

1 Vote 1 ·

Restarting teams worked for me. However, since it does not close completely you may need to do the following :
- go in "Settings > General" and untick the option "On close, keep the application running". It then worked when I restarted teams.

0 Votes 0 ·
ThierryVilmart-0458 avatar image
0 Votes"
ThierryVilmart-0458 answered David-8218 commented

same problem here on debian 10 linux.

teams does not detect the microphone that otherwise is tested to work to record simple files.
the audi and microphone share the same socket.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I had the same problem on Debian 10 with KDE desktop. Sometimes it was working other times not.
I tried to restart the laptop but didn't help. Finally I realized that teams is on autostart in KDE, so I
removed it from autostart and I also configure KDE to start with an empty session on login.
After a restart I got a new empty desktop session and I started teams and it was working
properly. I hope it is stable now.

0 Votes 0 ·
ThierryVilmart-0458 avatar image
0 Votes"
ThierryVilmart-0458 answered LarsLansink-4404 commented

same problem here on debian 10 linux

teams does not detect the microphone.
THe audio and microphone share the same socket.

Otherwise a simple sound file can be created outside of teams so the microphone works.
arecord -l
List of CAPTURE Hardware Devices
card 0: PCH [HDA Intel PCH], device 0: ALC3234 Analog [ALC3234 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC3234 Alt Analog [ALC3234 Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
arecord -f S16_LE -c 2 -r 192000 -d 5 --device="hw:0,0" test.wav

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I have the same issue here with debian 10.

Google Chrome + Teams work flawless.

Teams client, sound works, camera works, microphone does not work (pavucontrol shows "Skype" attached to pulse and recording but Teams settings show now activity)

0 Votes 0 ·
SilviuBerbinschi-2150 avatar image
0 Votes"
SilviuBerbinschi-2150 answered JB-6999 commented

The same issue on Kubuntu 19.10 Any suggestion?

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

It worked for me on 19.10 (dell 7590 laptop) on the first few times after installing the app, I removed the uvcvideo module and it worked, put video back on still working, but I think what broke it for me was deselecting the 'keep teams running when you quit' thing. Because, the app was burning like 30% of the cpu on an I7 just running in the background. After I made the fateful change, I descended into this world of buggy behaviour. It seems to be working with the onboard audio, even as it claims to detect the USB headset. Running as sudo, I get the audio in the headset, but the mic is still the onboard mic, but it claims to detect the USB mic. But then, literally seconds later, it didn't detect the USB mic and correctly informed me I was using the onboard mic. So, there's enough functionality here for me to work with, since my work doesn't acknowledge linux as a matter of corporate policy/laziness, thankful Microsoft has at least got linux on the roadmap.

0 Votes 0 ·
JensHektor-5473 avatar image
0 Votes"
JensHektor-5473 answered

Same on a Lonovo Thinkpad T560 running Fedora Core 31

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

HervSylvain-0658 avatar image
0 Votes"
HervSylvain-0658 answered AlesZacharie-4283 edited

Works well with root user on fedora 31. Not with normal user. Pavucontrol shows chromium a while at startup, not after.

· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Found the answer for fedora 31 : you have to had your user to video and pulse groups.

1 Vote 1 ·

Ubuntu 18.04 here - adding the user to the audio and video groups fixed the issue. (I'm not sure what video group membership is needed for.)

0 Votes 0 ·

My headset-mic works only as normal user with F31, if I connect the headset and set it as default in the Audio Settings of Gnome BEFORE starting Teams . Only then I can use the mic in Teams. Hope that helps someone.

1 Vote 1 ·

That was the problem for me.

An additional step was required to make it work since teams does not completely close when I close the teams window.

I had to go in "Settings > General" and untick the option "On close, keep the application running". It then worked when I restarted teams.

0 Votes 0 ·

Excelente amigo, funcionó ejecutando la aplicación como root desde la consola. Usé en Linux Mint el comando #sudo teams y se ejecutó con Microfono y camara que antes no funcionaba.

0 Votes 0 ·
JensHektor-5473 avatar image
0 Votes"
JensHektor-5473 answered JonathanNeufeld-2349 edited

Grr.

HervSylvain is right. Running Teams as root lets team find the mic. Tststs.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Try adding yourself to the "audio", "video", "pulse" and "pulse-access" Linux groups. I don't have to run Teams as root and I get all the devices enumerated.

0 Votes 0 ·
HervSylvain-0658 avatar image
0 Votes"
HervSylvain-0658 answered JonathanNeufeld-2349 edited

You have to had your user to video and pulse groups. add video pulse fedora

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Adding my user to the video and pulse groups does not solve the issue for me. Seems like this may be a deeper bug that Microsoft is in no hurry to fix.

0 Votes 0 ·
JonathanNeufeld-2349 avatar image JonathanNeufeld-2349 64137d06-f6b8-473b-bba9-0623931a8c74 ·

Try adding to "pulse-access" group as well. You also need to open a new sub-shell for the permissions to take effect (or logout / login again), there's a more elegant way to do that as well but I do not recall right now.

0 Votes 0 ·
Badrobot99 avatar image
0 Votes"
Badrobot99 answered JonathanNeufeld-2349 commented

This sounds like a permission issue on Linux, I would test with root vs standard user to see if the issue is resolved. If so you could then narrow down the difference on the permissions level to correct it.

· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Again, you just have to add your user to pulse and video groups. Maybe it's possible to ad this to the RPM?

2 Votes 2 ·

Bang on @HervSylvain-0658, thanks! I would have not guessed that one ;-) +1 adding the rule to the package

1 Vote 1 ·

It is no solution to add the user to those groups automatically:

  • The installer runs as root, it doesn't know which user(s) to add. Linux is a multiuser OS!

  • More users may be added to the system later. What about them?

  • This gives the users other rights that have nothing to do with Teams. Installing a package must not grant a user's general permissions that affect permissions to use other software than just the software being installed.

A better solution would be to somehow make it work without the user being in these groups; Chrome can do it, too.



0 Votes 0 ·

Zoom Video Conferencing, Discord, OBS Studio, Element all have no issues with audio / video recording / playback on Linux.
This issue is very Microsoft-specific.

0 Votes 0 ·