10 Pro Asks For Company Login After Clean Install in OOBE

St0iK 1 Reputation point
2021-09-02T04:03:19.123+00:00

Hi, I bought a few used 10 Pro Dell desktops and laptops during a liquidation sale from a business to refurbish and resell, but after resetting or clean install if I connect to internet during initial setup (OOBE) it says Welcome to XYZ Company please sing in with your company email address.

Laptops came with 10 Pro so I can't enter a different key during installation.

How can I remove this? A clean install on brand new ssd doesn't change this as the 10 pro key is in the UEFI/BIOS.

If I don't connect to internet during OOBE, I can set up with a local account with no issue, but incase whoever uses it wants to reset it, I don't want to have problems in the future.

If the pc is connected to the company's Azure or something, then I don't want them to be able to lock it or remotely wipe it or do anything else with the device.

I believe the company was bought out so there's nobody there who would be willing to help.

Windows 10 Setup
Windows 10 Setup
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,919 questions
{count} votes

6 answers

Sort by: Most helpful
  1. Eddie Ho 0 Reputation points
    2023-09-29T08:31:37.3833333+00:00

    I had the same problem even with a reformatted (low level format) SSD,brand new SSD etc. I did the following to work around this annoying issue:-

    1. Get a fresh Windows ISO file (download from MS download centre), extract the ISO into a thumb drive
    2. Boot up your machine from the thumb drive
    3. Run the setup following the instructions
    4. When it prompts you to connect to the internet, at the bottom left corner, click on "I have no internet"
    5. Follow the install instructions and you will have a clean install.