Azure function - Portal editing is disabled

Sasa 41 Reputation points
2021-09-05T14:47:23.76+00:00

I can't edit functions on a portal anymore. I just got a message "This function has been edited through an external editor. Portal editing is disabled". I have never used any kind of external editors for this functions. I tried to create new function and have the same issue. Anyone has idea what is up?
129365-chrome-zv903wirmb.png

Azure Functions
Azure Functions
An Azure service that provides an event-driven serverless compute platform.
4,475 questions
{count} vote

Accepted answer
  1. MayankBargali-MSFT 69,841 Reputation points
    2021-09-06T09:24:10.823+00:00

    Update 19/10:
    The initial issue is already fixed but in case if someone has observed the error message in case of consumption or elastic-premium plan then please verify if WEBSITE_CONTENTAZUREFILECONNECTIONSTRING and WEBSITE_CONTENTSHARE setting is missing from the Configuration setting of your function app.
    Please configure these two app settings according to File Shares in your Azure Storage Account.

    The app-setting may not be present in the case when you are using local development.

    141621-image.png

    Update 9/7:
    Team is rolling out the fix and will update the thread once the issue is fixed for Premium V2 function app Dedicated SKU.
    @sasazelic @Pascal The issue is fixed now. I have tested the same at my end. Please verify and let me know if you are still facing the issue.

    Update 9/6:
    @sasazelic Thanks for sharing the details. It looks like not every combintion (SKU, language, operating system) supports the creation of function from azure portal.
    When you click on Create under function blade it will list you the Development environment supported. If you see Develop in portal option in Development environment then only that combination is supported to be created in azure portal. I will get the confirmation from my team and will update the thread.

    129500-image.png

    2 people found this answer helpful.

10 additional answers

Sort by: Most helpful
  1. Reiss Ricketts 16 Reputation points
    2021-10-30T22:45:26.273+00:00

    I'm having the same issue here too. Free account. I do have my login setup in Visual Studio, and the Azure CLI tools. Could that be anything to do with it?

    I don't mind having to use Visual Studio, but it would be helpful to have the portal option.

    145241-image-2021-10-30-234439.png

    3 people found this answer helpful.
    0 comments No comments

  2. Olivier Stas 11 Reputation points
    2021-10-01T17:24:33.537+00:00

    Have the same issue with a free account. First time I create a function, and in the drop down list box, "Develop in portal" is not proposed.

    2 people found this answer helpful.
    0 comments No comments

  3. Surbhi Choubey 21 Reputation points
    2021-10-10T20:03:29.397+00:00

    This issue is not resolved. I am still facing it. What is the fix, please help ASAP

    2 people found this answer helpful.

  4. César Adriel Airaldo 6 Reputation points
    2021-10-18T17:58:33.107+00:00

    I can confirm the problem is not solved. Facing this right now with .Net Core (3.1 and 6), on Windows and Linux.

    1 person found this answer helpful.
    0 comments No comments