Delimiter error in copy activity of ADF

Sameer 21 Reputation points

I am getting a following error while moving data through ADF.

ERROR [22000] Found character '>' instead of field delimiter ',' File

  1. I tried to update the escape character in connection settings, but there is no option to update escape character
  2. I don't want to use Replace by manually adding it to each string column.

Is there any option to tackle this via setting escape character somehow, or dynamically setting it ? Thanks for your help.

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
10,149 questions
{count} votes

Accepted answer
  1. svijay-MSFT 5,226 Reputation points Microsoft Employee

    Hello @Sameer ,

    The issue could be because of the first stage (Source -> staging blob) use csv format and the format serializer failed to escape the escape char in the data eventually causing the data to be invalid.

    You could try the below workaround at your end.

    Manually edit JSON payload of your pipeline, go to properties -> activities -> {your copy activity} -> "typeProperties", add a flag "escapeQuoteEscaping": true


    Please Note : If using SHIR, please make sure the SHIR version must >= 5.5.7762.1 to get this fix

    Hope this will help. Please let us know if any further queries.


    • Please don't forget to click on 130616-image.png or upvote 130671-image.png button whenever the information provided helps you. Original posters help the community find answers faster by identifying the correct answer. Here is how
    • Want a reminder to come back and check responses? Here is how to subscribe to a notification
    • If you are interested in joining the VM program and help shape the future of Q&A: Here is how you can be part of Q&A Volunteer Moderators
    3 people found this answer helpful.
    0 comments No comments

5 additional answers

Sort by: Most helpful
  1. Singh, Anurag 1 Reputation point

    I tried adding "escapeQuoteEscaping":true in my pipeline for copying data from blob to snowflake, but it's not working for me. Even after defining some other escape character such as '^' or '$' or etc. It is still using the '\' as the escape character.
    Quite weird issue from blob to snowflake.

    0 comments No comments

  2. Jyothsna Nagarajugari 1 Reputation point

    Hi Team,

    We are trying to move the data from SFTP to snowflake facing error:
    ErrorCode=UserErrorOdbcOperationFailed,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=ERROR [22000] Found character '1' instead of field delimiter ', I have tried the work around by adding "escapeQuoteEscaping": true but still issue is not resolved.Please suggest

    Note: we are using Auto IR here.

    0 comments No comments

  3. Anil Dangol 1 Reputation point

    I am having the same issue. somehow ADF doesn't respect ESCAPE property of file format.

    0 comments No comments

  4. Sandeep Nidumukkala 1 Reputation point

    i am having the same issue i tried the answer but didnt solved the error . how to clear the error pls help

    0 comments No comments