SCOM 2019 - Groups - Dynamic member formula empty

David Zemdegs 1,586 Reputation points
2022-02-08T23:00:35.207+00:00

Greetings,
I have created a new group and specified a dynamic inclusion rule. When the group has been created and I open its properties, the query formula does not exist. So I pressed the Create\Edit rules button and recreated it. When I click Apply, the formula appears. However when I close and open the Group, the formula disappears again.
Am I missing something?
Thanks
David Z

Operations Manager
Operations Manager
A family of System Center products that provide infrastructure monitoring, help ensure the predictable performance and availability of vital applications, and offer comprehensive monitoring for datacenters and cloud, both private and public.
1,436 questions
0 comments No comments
{count} votes

8 answers

Sort by: Most helpful
  1. AlexZhu-MSFT 5,551 Reputation points Microsoft Vendor
    2022-02-09T06:55:54.567+00:00

    Hi,

    The steps of creating a group is straight forward. Is there any error message when saving the group? If all looks good, if possible, please reboot the management server (as well as the database server) to avoid any pending restart to see if any difference. Or, we can create another simple group to distinguish it relates to the specific group or the scom itself.

    172429-scom-dynamic-group.png

    Regards
    Alex

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. David Zemdegs 1,586 Reputation points
    2022-02-10T00:11:10.277+00:00

    I am not getting any errors at all. I have restarted the servers and the problem remains.
    I am using Windows Computer and a formula that refers to Netbios Name.

    0 comments No comments

  3. AlexZhu-MSFT 5,551 Reputation points Microsoft Vendor
    2022-02-14T02:30:49.977+00:00

    Hi,

    It seems the query is not saved successfully. For test purpose, would you create a new unsealed management pack, create a new group with the same/similar query and save it to the new management pack to see it it works.

    Regards
    Alex

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  4. David Zemdegs 1,586 Reputation points
    2022-02-14T03:01:43.003+00:00

    Creating a new MP did not work either.

    0 comments No comments

  5. AlexZhu-MSFT 5,551 Reputation points Microsoft Vendor
    2022-02-15T08:48:58.497+00:00

    Hi,

    Thank you very much for trying this out. This is really odd. Currently, we may check the following:

    1) is the database file full or authgrowth is setting correctly
    2) is the operations manager the latest version
    10.19.10552.0 KB5005527 2021 October 6 Update Rollup 3 - Hotfix Oct 2021
    3) does the current user have enough permission?

    174310-scom-database-autogrowth04.png

    Regards
    Alex

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments