Connect to Azure VM by RDP: An internal error has occurred

laco 11 Reputation points
2020-09-08T09:43:50.88+00:00

Hi all,
we have the Azure virtual machine:
account: xxxxxxxxx@xxxxxxx.xxx,
account type: Personal account,
subscription: Microsoft Partner Network,
resource group: xxxxxxxxxxx,
virtual machine: xxxxxxxxxxx,
public ip address: xx.xxx.xx.xx:xxxx and
OS: Windows Server 2012 R2 Datacenter.

I downloaded the xxxxxxxxxxx.rdp from Azure portal.

If I clicked on the RDP I had got error:
Remote Desktop Connection: An internal error has occurred.

Do you know cause?

Thank you very much.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
4,612 questions
{count} votes

6 answers

Sort by: Most helpful
  1. Winston 2,756 Reputation points
    2020-09-08T19:34:05.223+00:00

    Hey [@](/users/na/?userId=9ecdf8bb-0000-0003-0000-000000000000),

    Because you are receiving an internal service error when attempting to RDP into your VM. I'd advise you to take a look at this doc here. This doc explains what that error means and offers a solution. Hope this helps!

    If this answer helped you solve your issue, please mark this answer as accepted to help others in the community with similar issues.


  2. Rui Couto 1 Reputation point
    2020-09-14T09:29:46.163+00:00

    Hii !!!

    I am having the same problem

    But it is an intermitent problem, if i try several time sometimes it connect well.

    If i drop the connection again it can take a while, but in a lot of tries, one connect well

    any idea of waht it can be?

    No comments

  3. Manish Jha 236 Reputation points
    2020-09-14T12:22:04.567+00:00

    Have you tried connecting to the VM via SAC

    Please perform these steps

    https://learn.microsoft.com/en-us/azure/virtual-machines/troubleshooting/troubleshoot-rdp-internal-error

    No comments

  4. Andreas Hermansen 1 Reputation point
    2020-09-18T08:59:53.637+00:00

    Hi - had same issue on 3 diffrent machines. I can connect to mine if I connect while it is restarting.

    I did a permanent fix, with these 3 settings. Remove the checkmark in pic1. Change setting in group policy in pic2. And delete the machine keys, pic3. So now i dont have the issue anymore. 25812-take1.png25813-take2.png25777-take3.png

    Br Andreas

    No comments

  5. Sathar Faiq 1 Reputation point
    2021-01-27T19:47:09.683+00:00

    Hi, Even I am facing the same issue and I couldn't find solution for this.
    Can anyone please help me on this ?

    No comments