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Elements are highlighted in Citrix Virtual Apps, but clicking them at runtime doesn't work

This article provides steps to resolve an issue where UI element interactions don't work when running actions in Citrix Virtual Apps, even though the UI elements are properly highlighted and captured.

Symptoms

When you use the UI element picker to interact with Citrix Virtual Apps, you can highlight and capture elements successfully. However, when these captured elements are used in an action (for example, Click Element in Window), the interaction doesn't execute, and no error message is displayed. The Test Selector functionality works as expected.

Cause

The Citrix Workspace High DPI (HIDPI) settings might interfere with Power Automate for desktop interactions. This issue is commonly observed in setups involving multiple monitors.

Resolution

To solve this issue, follow these steps:

  1. Disable the Citrix Workspace HIDPI option:

    1. From the system tray, right-click the Citrix Workspace app icon.
    2. Select Advanced Preferences > High DPI.
    3. In the High DPI settings, select the Let the operating system scale the resolution option.
    4. Select Save and close the Citrix Workspace preferences windows.
  2. Close any active Citrix Desktops or Virtual Apps.

  3. Restart the Citrix Desktops or Virtual Apps.

  4. (Optional) Adjust the desktop scaling of the machine running Power Automate for desktop to 100%. For unattended machines, see Set screen resolution on unattended mode.

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.