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This article helps you resolve issues you might encounter when using the UI element picker in virtual desktops, such as Citrix or Microsoft Remote Desktop Protocol (RDP) environments.
Symptoms
When you hover the mouse cursor over a UI or web element of an application or webpage inside a Citrix or RDP window with the UI element picker enabled, you might see:
The element isn't highlighted.
An error message about enabling the Power Automate agent for virtual desktops.
Enable UI automation in virtual desktop
To automate using UI elements on virtual desktops, ensure the Power Automate agent for virtual desktops is installed and running on the remote machine.
Cause
The communication with the remote agent components doesn't work.
Resolution
Ensure the Power Automate Citrix or RDP plugin is registered.
While the virtual desktop platform (Citrix Desktop, Citrix Virtual Apps, Remote Desktop app, or a remote desktop with Windows RDP communication) is active, run the troubleshooter by navigating to Help > Troubleshooter in Power Automate.
Tip
The troubleshooter can be manually opened via the console and the flow designer, through the dedicated menu under Help > Troubleshooter. It can also be opened via the process file PAD.Troubleshooter.exe, which can be found in the installation folder of Power Automate for desktop.
Run Troubleshoot UI/Web automation issues to view the diagnostics for the communication. If an error appears in the Citrix or RDP section, expand it for more details and solutions.
If the error details indicate "Access is denied," policies on the remote machine prohibit running a specific agent component from the user profile folder. Contact your administrator to allow the executables to run from these directories.
If the troubleshooter indicates that the remote agent isn't running, check if the agent is running in the Citrix or RDP session.
Check the tray icon for the agent icon when the virtual desktop platform is active. If the icon exists, hover over it to confirm it's still running. If it is, right-click the tray icon to open the menu and select Status. The agent's status and the reason for the error will be displayed.
If the agent is confirmed not running and Citrix is in use, ensure that the agent is installed on every Citrix server.
If the agent is running, check the following conditions based on the agent's tray icon status:
A device on the system is not functioning: The Citrix plugin isn't loaded on the host system.
To troubleshoot the issue, run the troubleshooter while the virtual desktop platform is active and check for errors in the UI Automation section.
Citrix Virtual Channel policy enabled: The Virtual channel allow list policy on Citrix is set to Enabled or Default.
The default setting for this policy is Enabled or Default. However, if this policy isn't disabled, the Power Automate agent can't communicate with Power Automate for desktop. To resolve communication issues, work with your Citrix administrator to set the policy to Disabled and ensure Citrix machines are restarted after applying the policy.
Citrix VDA version < 2407: The Virtual channel allow list policy on Citrix is set to Enabled or Default.
The default setting for this policy is Enabled or Default. However, if this policy isn't disabled, the Power Automate agent can't communicate with Power Automate for desktop. To resolve communication issues, work with your Citrix administrator to set the policy to Disabled and ensure Citrix machines are restarted after applying the policy.
Citrix VDA Version >= 2407: The older Virtual channel allow list policy can remain at Default, but a different policy must be set.
Set the Virtual channel allow list for DVC policy with the following values:
C:\Program Files (x86)\Power Automate agent for virtual desktops\PAD.RDP.ControlAgent.exe,Microsoft.Flow.RPA.Desktop.UIAutomation.RDP.DVC.Plugin,PAD\CONTROL
C:\Users\*\AppData\Local\Microsoft\Power Automate Desktop\RDP Automation Agents\*\PAD.RDP.AutomationAgent.exe,Microsoft.Flow.RPA.Desktop.UIAutomation.RDP.DVC.Plugin,PAD\UIA
Ensure Citrix machines are restarted after applying the policy.
More information
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.