Share via


La interfaz de usuario de Power Query

Con Power Query, puede conectarse a muchos orígenes de datos diferentes y transformar los datos en la forma que desee.

En este artículo, aprenderá a crear consultas con Power Query al descubrir:

  • Cómo funciona la experiencia "Obtener datos" en Power Query.
  • Cómo usar y aprovechar la interfaz de usuario de Power Query.
  • Cómo realizar transformaciones comunes, como agrupar y combinar datos.

Si no está familiarizado con Power Query, puede registrarse para obtener una evaluación gratuita de Power BI antes de comenzar. Puede usar flujos de datos de Power BI para probar las experiencias de Power Query Online descritas en este artículo.

Además, puede descargar Power BI Desktop gratis.

Los ejemplos de este artículo usan la fuente OData de Northwind y se conectan a ella.

https://services.odata.org/V4/Northwind/Northwind.svc/

Conexión a una fuente de OData

Nota:

Para obtener más información sobre dónde obtener datos de cada uno de los productos de Microsoft que incluyen Power Query, diríjase a Dónde obtener datos.

Para empezar, busque el conector de fuente de OData desde la experiencia "Obtener datos". Puede buscar OData en la barra de búsqueda de la esquina superior derecha.

Screenshot of the Choose data source page of the Get data experience with the OData connector emphasized.

Una vez seleccionado este conector, la pantalla mostrará la configuración de conexión y las credenciales.

  • En URL, introduzca la dirección URL que dirige a la fuente OData de Northwind que se muestra en la sección anterior.
  • En Puerta de enlace de datos local, déjelo como "ninguna".
  • Para Tipo de autenticación, déjelo como "anónimo".

Haga clic en el botón Siguiente.

Screenshot of the OData Connect to data source page with the Northwind URI entered in the URL section.

A continuación se abrirá el Navegador, donde se seleccionan las tablas a las que desea conectarse desde el origen de datos. Seleccione la tabla Clientes para cargar una vista previa de los datos y, a continuación, seleccione Transformar datos.

Screenshot of the Power Query Navigator page with the Customers table emphasized.

A continuación, el cuadro de diálogo carga los datos de la tabla Clientes en el editor de Power Query.

La experiencia anterior de conectarse a los datos, especificar el método de autenticación y seleccionar el objeto o la tabla específicos a los que conectarse se conoce como la experiencia Obtener datos. Esta experiencia se documenta con más detalle en el artículo Obtener datos.

Nota:

Para más información sobre el conector de fuente de OData, diríjase a fuente de OData.

Experiencia de usuario del editor de Power Query

El editor de Power Query representa la interfaz de usuario de Power Query. En esta interfaz de usuario de Power Query, donde puede agregar o modificar consultas, administrar consultas al agrupar o agregar descripciones a los pasos de consulta, o visualizar las consultas y su estructura con vistas diferentes. La interfaz de usuario de Power Query tiene cinco componentes distintos.

Screenshot of the Power Query user interface with each component outlined and numbered.

  1. Cinta de opciones: la experiencia de navegación de la cinta de opciones, que proporciona varias pestañas para agregar transformaciones, seleccionar opciones para la consulta y acceder a diferentes botones de la cinta de opciones para completar varias tareas.
  2. Panel Consultas: una vista de todas las consultas disponibles.
  3. Vista actual: la vista de trabajo principal, que, de forma predeterminada, muestra una vista previa de los datos de la consulta. También puede habilitar la vista de diagrama junto con la vista previa de datos. Además, puede cambiar entre la vista de esquema y la vista previa de datos a la vez que se mantiene la vista de diagrama.
  4. Configuración de consulta: una vista de la consulta seleccionada actualmente con información relevante, como el nombre de la consulta, los pasos de consulta y varios indicadores.
  5. Barra de estado: una barra que muestra información importante y relevante sobre la consulta, como el tiempo de ejecución, las columnas y filas totales y el estado de procesamiento. Esta barra también contiene botones para cambiar la vista actual.

Nota:

Actualmente, la vista de esquema y de diagrama solo están disponibles en Power Query Online.

Uso del editor de Power Query

En esta sección, comenzará a transformar los datos mediante Power Query. Sin embargo, antes de empezar a trabajar en la transformación de los datos, analizaremos algunos de los paneles de la interfaz de usuario que se pueden expandir o contraer en función de su contexto. Seleccionar los paneles adecuados le permite centrarse en la vista que más le convenga en su caso. También analizaremos las distintas vistas disponibles en la UI de Power Query.

Cinta

La cinta de opciones es el componente donde encontrará la mayoría de las transformaciones y acciones que puede realizar en el editor de Power Query. Tiene varias pestañas, cuyos valores dependen de la integración del producto. Cada una de las pestañas proporciona botones y opciones específicos, algunos de los cuales podrían ser redundantes en toda la experiencia de Power Query. Estos botones y opciones le proporcionan fácil acceso a las transformaciones y acciones que pueda necesitar.

Screenshot of the standard ribbon view on the Home tab of the Power Query user interface.

La interfaz de Power Query responde e intenta ajustar la resolución de pantalla para mostrarle la mejor experiencia. En situaciones en las que desee utilizar una versión compacta de la cinta de opciones, también hay un botón para contraer en la esquina inferior derecha de la cinta de opciones para ayudarle a cambiar dicha cinta a la cinta de opciones compacta.

Screenshot of the compact ribbon view on the Home tab of the Power Query user interface.

Puede devolver la cinta de opciones a su vista de cinta estándar, seleccionando el icono de expansión situado en la esquina inferior derecha de la cinta de opciones.

Paneles para expandir y contraer

Podrá observar que en toda la interfaz de usuario de Power Query hay iconos que le ayudan a contraer o expandir determinadas vistas o secciones. Por ejemplo, hay un icono en la esquina superior derecha del panel Consultas que contrae el panel de consultas cuando se selecciona y lo expande cuando se vuelve a seleccionar.

Screenshot emphasizing the icon on the Queries pane used to collapse and expand the queries pane.

Alternar entre vistas

Además de poder contraer determinados paneles y secciones en la interfaz de usuario de Power Query, también puede cambiar las vistas que se muestran. Para cambiar de vista, diríjase a la pestaña Vista de la cinta de opciones donde encontrará los grupos Vista previa y Diseño, que controlan el aspecto de la interfaz de usuario de Power Query.

Se recomienda probar todas estas opciones para encontrar la vista y el diseño con los que se sienta más cómodo al trabajar. Por ejemplo, seleccione Vista de esquema en la cinta de opciones.

Screenshot emphasizing the Schema view button found inside the View tab in the Power Query ribbon.

El lado derecho de la barra de estado también contiene iconos para las vistas de diagrama, de datos y de esquema. Puede usar estos iconos para cambiar entre vistas. También puede utilizar estos iconos para habilitar o deshabilitar la vista que prefiera.

Screenshot of the Power Query user interface with the queries pane collapsed and the current view switched to schema view and the schema view icon emphasized.

¿Qué es la vista de esquema?

La vista de esquema ofrece una forma rápida y sencilla de interactuar únicamente con los componentes del esquema de la tabla, como los nombres de columna y los tipos de datos. Se recomienda la vista de esquema cuando quiera realizar acciones relacionadas con el esquema. Estas acciones podrían eliminar columnas, cambiar el nombre de las columnas, cambiar los tipos de datos de columnas, reordenar columnas o duplicar columnas.

Nota:

Para obtener más información sobre la vista de esquema, diríjase a Uso de la vista de esquema.

Por ejemplo, en la vista de esquema, seleccione la marca de verificación situada junto a las columnas Orders y CustomerDemographics y, en la cinta de opciones, seleccione la acción Quitar columnas. Esta selección aplica una transformación para quitar estas columnas de los datos.

Screenshot of the Orders and CustomerDemographics columns selected, and the Remove columns option emphasized.

¿Qué es la vista de diagrama?

Ahora puede volver a la vista previa de datos y habilitar la vista del diagrama para usar una perspectiva más visual de los datos y de la consulta.

Screenshot emphasizing the diagram view and data preview view icons.

La vista de diagrama le ayuda a visualizar cómo se estructura la consulta y cómo puede interactuar con otras consultas del proyecto. Cada paso de la consulta tiene un icono distinto para ayudarle a reconocer la transformación que se utilizó. También hay líneas que conectan pasos para ilustrar las dependencias. Dado que la vista previa de datos y la vista de diagrama están habilitadas, la vista de diagrama se muestra sobre la vista previa de datos.

Screenshot of the Power Query workspace showing the diagram view with data preview.

Nota:

Para obtener más información sobre la vista de diagrama, diríjase a Vista de diagrama.

Empezar a transformar los datos

Con la vista de diagrama habilitada, seleccione el signo más. Puede buscar una nueva transformación para agregarla a la consulta. Busque Agrupar por y seleccione la transformación.

Screenshot with a search for a group by in the diagram view.

A continuación, aparecerá el cuadro de diálogo Agrupar por. Puede establecer la operación Agrupar por para agrupar por país y contar el número de filas de clientes por país.

  1. Mantenga seleccionado el botón de radio Básico.
  2. Seleccione País para agrupar por país.
  3. Seleccione Clientes como nuevo nombre de columna y Contar filas como operación.

Screenshot of the basic Group dialog with the customers' data entered.

Seleccione Aceptar para realizar la operación. La vista previa de datos se actualiza para mostrar el número total de clientes por país.

Una forma alternativa de iniciar el cuadro de diálogo Agrupar por sería usar el botón Agrupar por en la cinta de opciones o hacer clic con el botón derecho en la columna País.

Screenshot emphasizing the Group by button in the ribbon and the Group by option in the Country column menu.

Para mayor comodidad, a menudo se puede acceder a las transformaciones en Power Query desde varios lugares, por lo que los usuarios pueden optar por utilizar la experiencia que prefieran.

Añadir una nueva consulta

Ahora que ha obtenido una consulta que proporciona el número de clientes por país, puede agregar contexto a estos datos mediante la búsqueda del número total de proveedores para cada territorio.

En primer lugar, deberá agregar los datos de Proveedores. Seleccione Obtener datos. En Elegir origen de datos, busque OData. Luego, seleccione el conector OData.

Screenshot of the Get data Choose data source page with the OData connector emphasized.

Volverá a aparecer la experiencia de conexión de OData. Escriba la configuración de conexión tal como se describe en Conexión a una fuente de OData para conectarse a la fuente OData de Northwind. En la experiencia Navegador, busque y seleccione la tabla Proveedores.

Screenshot of the Power Query navigator with the Northwind OData suppliers selected.

Seleccione Crear para agregar la nueva consulta al editor de Power Query. Expanda el panel de Consultas, que ahora muestra tanto la consulta de Clientes como la de Proveedores.

Screenshot of the Queries pane emphasizing both the customers and suppliers queries.

Vuelva a abrir el cuadro de diálogo Agrupar por; esta vez, seleccione el botón Agrupar por en la cinta de opciones de la pestaña Transformar.

Screenshot of part of the Transform tab ribbon with Group by emphasized.

En el cuadro de diálogo Agrupar por, establezca la operación Agrupar por para agrupar por país y contar el número de filas de proveedores por país.

  1. Mantenga seleccionado el botón de radio Básico.
  2. Seleccione País para agrupar por país.
  3. Introduzca Proveedores en Nuevo nombre de columna y seleccione Contar filas en Operación.

Screenshot of the basic Group dialog with the suppliers' data entered.

Nota:

Para obtener más información sobre la transformación Agrupar por, diríjase a Agrupación o resumen de filas.

Hacer referencia a consultas

Ahora que tiene una consulta para clientes y una consulta para proveedores, el siguiente objetivo es combinar estas consultas en una. Hay varias formas de hacerlo, incluido el uso de la opción Combinar en la tabla Clientes, duplicar una consulta o hacer referencia a una consulta. En este ejemplo, para crear una referencia debe hacer clic con el botón derecho en la tabla Clientes y seleccionar Referencia, lo que crea de forma eficaz una nueva consulta que hace referencia a la consulta Clientes.

Screenshot of the Customers menu with the Reference option emphasized.

Después de crear esta nueva consulta, cambie el nombre de la consulta a Análisis de país y deshabilite la carga de la tabla Clientes mediante la desmarcación de la opción Habilitar carga de la consulta Proveedores.

Screenshot of the third query name changed to Country Analysis and the Suppliers Enable load option unmarked and emphasized.

Combinación de consultas

En la operación Combinar consultas se combinan dos tablas existentes en función de los valores coincidentes de una o varias columnas. En este ejemplo, el objetivo es unir las tablas Clientes y Proveedores en una tabla solo para los países o regiones que tengan Clientes y Proveedores.

Dentro de la consulta Análisis de país, seleccione la opción Combinar consultas en la pestaña Inicio de la cinta de opciones.

Screenshot of the Power Query workspace with the Country Analysis query selected, and the Merge queries option in the Home tab emphasized.

Aparecerá un cuadro de diálogo nuevo para la operación Merge. A continuación, puede seleccionar la consulta para combinarla con la consulta actual. En la tabla derecha para combinar, seleccione la consulta Proveedores y seleccione el campo País de ambas consultas. Por último, seleccione el tipo de combinación Interna, ya que solo quiere los países o regiones en los que usted tenga Clientes y Proveedores para este análisis.

Screenshot of the Merge queries dialog with the Country column selected in both queries and the Inner join kind selected.

Después de seleccionar el botón Aceptar, se agregará una nueva columna a la consulta Análisis de país que contendrá los datos de la consulta Proveedores. Seleccione el icono situado junto al campo Proveedores, que muestra un menú donde puede seleccionar qué campos desea expandir. Seleccione solo el campo Proveedores y, a continuación, seleccione el botón Aceptar.

Screenshot of the Suppliers column with the Suppliers menu open and only Suppliers selected.

El resultado de esta operación de expansión es una tabla con solo 12 filas. Para cambiar el nombre del campo Proveedores.1 a únicamente Proveedores, haga doble clic en el nombre de campo e introduzca el nuevo nombre.

Screenshot of the renamed Suppliers column.

Nota:

Para más información sobre la característica Combinar consultas, diríjase a Introducción a la opción "Combinar consultas".

Pasos aplicados

Cada transformación que se aplica a la consulta se guarda como paso en la sección Pasos aplicados del panel de configuración de la consulta. Si alguna vez necesita comprobar cómo se transforma la consulta por los pasos del procedimiento, puede seleccionar un paso y obtener una vista previa de cómo se resuelve la consulta en ese punto específico.

También puede hacer clic con el botón derecho en una consulta y seleccionar la opción Propiedades para cambiar el nombre de la consulta o agregar una descripción para la consulta. Por ejemplo, haga clic con el botón derecho en el paso Combinar consultas de la consulta de Análisis de país y cambie el nombre de la consulta a Combinar con Proveedores, así como la descripción a Obtener datos de la consulta Proveedores para los proveedores por país.

Screenshot of the Step properties dialog with the changed name and description filled in.

Después de este cambio, puede mover el puntero sobre el icono de consulta de combinación en la vista de diagrama o mover el puntero sobre el nuevo icono junto al paso del panel Pasos aplicados para leer su descripción.

Screenshot showing where to hover to view the step properties.

Nota:

Para obtener más información sobre los Pasos aplicados, diríjase a Uso de la lista Pasos aplicados.

Antes de pasar a la sección siguiente, deshabilite la Vista de diagrama para usar solo la Vista previa de datos.

Agregar una columna nueva

Con los datos de los clientes y proveedores en una única tabla, ahora puede calcular la proporción entre clientes y proveedores para cada país. Seleccione el último paso de la consulta Análisis de país y, a continuación, seleccione las columnas Clientes y Proveedores. En la pestaña Agregar columna de la cinta de opciones y dentro del grupo Desde número, seleccione Estándar y, a continuación, Dividir (entero) en la lista desplegable.

Screenshot of the Power Query workspace with the Add column tab and Standard selected, and Divide (Integer) option emphasized.

Este cambio creará una nueva columna denominada División de enteros cuyo nombre se puede volver a cambiar a Proporción. Este cambio es el paso final de la consulta y proporciona la relación entre clientes y proveedores para los países o regiones en los que los datos tengan clientes y proveedores.

Generación de perfiles de los datos

Otra característica de Power Query que puede ayudarle a comprender mejor los datos es la Generación de perfiles de datos. Al habilitar las características de creación de perfiles de datos, obtendrá comentarios acerca de los datos dentro de los campos de consulta, como la distribución de valores, la calidad de las columnas y más.

Se recomienda usar esta característica a lo largo del desarrollo de las consultas, pero siempre puede habilitarla y deshabilitarla según le convenga. En la siguiente imagen se muestran todas las herramientas de generación de perfiles de datos habilitadas para la consulta de Análisis de país.

Screenshot of the data profiling information with details for the Ratio column at the bottom.

Nota:

Para obtener más información sobre la Generación de perfiles de datos, diríjase a Uso de las herramientas de generación de perfiles de datos.

El editor avanzado

Si desea ver el código que el editor de Power Query está creando con cada paso o bien crear su propio código de formato, puede utilizar el editor avanzado. Para abrir el editor avanzado, seleccione la pestaña Ver de la cinta de opciones y, a continuación, seleccione Editor avanzado. Aparecerá una ventana que muestra el código de la consulta actual.

Screenshot of the advanced editor, which contains code with no syntax errors.

Puede modificar directamente el código en la ventana Editor avanzado . El editor indica si el código está libre de errores de sintaxis. Para cerrar la ventana, seleccione el botón Listo o el botón Cancelar .

Acceso a la ayuda de Power Query

Hay varios niveles de ayuda a los que se puede acceder en las aplicaciones de Microsoft que usan Power Query. En esta sección se describen estos niveles de ayuda.

Ayuda para Power Query en Excel

Hay un par de maneras de acceder a la información de ayuda de Power Query que se aplica específicamente a Power Query en Excel. Una forma de acceder a la documentación de Excel Power Query en línea es seleccionar Archivo>Ayuda>Ayuda en el editor de Power Query.

Para acceder a la información de ayuda insertada de Power Query en Excel, seleccione la pestaña Ayuda de la cinta de opciones de Excel y, a continuación, escriba Power Query en el cuadro de texto de búsqueda.

Ayuda para Power Query en Power BI Desktop

Hay una pestaña de Ayuda en el editor de Power Query que se ejecuta en Power BI Desktop, pero en la actualidad todas las opciones se dirigen a ubicaciones que proporcionan información de Power BI. Para acceder a esta misma información de Ayuda de Power BI en el editor de Power Query en Power BI Desktop, también puede seleccionar Archivo>Ayuda y, a continuación, seleccionar una de las opciones de ayuda.

Ayuda de Power Query en el servicio Power BI, Power Apps, Customer Insights y Azure Data Factory

La pestaña Ayuda de Power Query en el servicio Power BI, Power Apps, Dynamics 365 Customer Insights y Azure Data Factory contiene vínculos a orígenes importantes de información sobre Power Query.

Screenshot of the help tab with the Power Query documentation, Keyboard shortcuts, Support, Power Query website, Power Query blog, Power Query community, Submit an idea, and Send feedback links.

Las opciones de la pestaña Ayuda incluyen vínculos a:

  • Documentación de Power Query: vínculos a la documentación de Power Query
  • Métodos abreviados de teclado: vínculos al artículo sobre métodos abreviados de teclado en la documentación de Power Query.
  • Soporte técnico: vínculos al sitio web de soporte técnico del producto de Microsoft en el que Power Query se está ejecutando actualmente.
  • Sitio web de Power Query: vínculos al sitio web de Power Query.
  • Blog de Power Query: vínculos al blog de Power Query
  • Comunidad de Power Query: vínculos a la comunidad de Power Query.
  • Enviar una idea: vínculos al sitio web para enviar ideas o sugerencias del producto de Microsoft en el que Power Query se está ejecutando actualmente.
  • Enviar comentarios: abre una ventana en Power Query. La ventana le solicita que valore su experiencia con Power Query y que proporcione información adicional que le gustaría proporcionar.

Nota:

Actualmente, Azure Analysis Services no contiene ningún vínculo de ayuda insertada de Power Query. Sin embargo, puede obtener ayuda para las funciones de Power Query M. Puede encontrar más información en la siguiente sección.

Ayuda para funciones de Power Query M

Además de las funciones de ayuda de Power Query enumeradas en las secciones anteriores, también puede obtener ayuda para funciones de M específicas desde el editor de Power Query. En los pasos siguientes se describe cómo obtener esta ayuda insertada.

  1. Con el editor de Power Query abierto, seleccione el botón Insertar paso ().
  2. En la barra de fórmulas, escriba el nombre de alguna función que desee comprobar.
    1. Si usa Power Query Desktop, introduzca un signo igual, un espacio y el nombre de una función.
    2. Si usa Power Query Online, introduzca el nombre de una función.
  3. Seleccione las propiedades de la función.
    1. Si usa Power Query Desktop, en el panel Configuración de consulta, en Propiedades, seleccione Todas las propiedades.
    2. Si usa Power Query Online, en el panel Configuración de consulta, seleccione Propiedades.

Estos pasos abrirán la información de ayuda insertada para la función seleccionada y le permitirán introducir propiedades individuales usadas por la función.

Screenshot of the Date.AddDays M function description and syntax, along with entry points for each of the function's parameters.

Resumen

En este artículo, ha creado una serie de consultas con Power Query que proporciona un análisis de proporción entre clientes y proveedores a nivel de país de la empresa Northwind.

Ha aprendido los componentes de la interfaz de usuario de Power Query, cómo crear nuevas consultas dentro del Editor de Power Query, hacer referencia a consultas, combinar consultas, comprender la sección Pasos aplicados y agregar nuevas columnas. También ha aprendido a usar las herramientas de generación de perfiles de datos para comprender mejor los datos.

Power Query es una herramienta eficaz que se usa para conectarse a muchos orígenes de datos diferentes y transformar los datos como desee. Los escenarios descritos en este artículo son ejemplos para mostrar cómo puede usar Power Query para transformar datos sin procesar en información empresarial importante que pueda serle de utilidad.