Remarque
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de vous connecter ou de modifier des répertoires.
L’accès à cette page nécessite une autorisation. Vous pouvez essayer de modifier des répertoires.
Avec Power BI Desktop, vous pouvez vous connecter à tout un monde de données, créer des rapports attrayants et fondamentaux, puis les partager avec d’autres utilisateurs, qui peuvent ensuite s’appuyer sur votre travail pour développer leurs talents en matière de décisionnel.
Vues de Power BI Desktop
Power BI Desktop propose trois vues :
- Vue Rapport : utilisez des requêtes que vous avez créées pour générer des visualisations attrayantes, organisées comme vous souhaitez qu’elles apparaissent et avec plusieurs pages, que vous pouvez partager avec d’autres utilisateurs.
- Vue Table : consultez les données de votre rapport au format du modèle de données, où vous pouvez ajouter des mesures, créer de nouvelles colonnes et gérer les relations.
- Vue de modèle : obtenez une représentation graphique des relations définies dans votre modèle de données et les gérer ou les modifier si nécessaire.
Accédez à ces vues en sélectionnant l’une des trois icônes affichées sur le côté gauche de Power BI Desktop. Dans l’image suivante, la vue Rapport est sélectionnée, indiqué par la bande jaune à côté de l’icône.
Power BI Desktop vient aussi avec l’Éditeur Power Query. Utilisez l’Éditeur Power Query pour vous connecter à une ou plusieurs sources de données, modeler et transformer les données en fonction de vos besoins, puis charger ce modèle dans Power BI Desktop.
Cet article fournit une vue d’ensemble de l’utilisation des données dans l’Éditeur Power Query, mais vous pouvez en apprendre plus. À la fin de cet article, vous trouverez des liens vers des instructions détaillées sur les types de données pris en charge. Vous y trouverez également des conseils sur la connexion aux données, la mise en forme des données, la création de relations et comment démarrer.
Mais tout d’abord, nous allons nous familiariser avec l’Éditeur Power Query.
Éditeur Power Query
Power BI Desktop offre deux expériences de Éditeur Power Query :
- Nouvelle expérience de Power Query (préversion) : éditeur repensé avec une navigation simplifiée, une accessibilité améliorée et une expérience de Power Query cohérente dans Power BI Bureau, la modélisation web et d’autres produits Fabric.
- Expérience héritée : fenêtre Éditeur Power Query d’origine.
Dans les deux expériences, vous utilisez Éditeur Power Query pour vous connecter à une ou plusieurs sources de données, mettre en forme et transformer les données pour répondre à vos besoins, puis charger le résultat dans Power BI Desktop. Sélectionnez l’onglet qui correspond à l’expérience que vous utilisez.
Pour connaître les limitations connues, les solutions de contournement et un espace où partager vos commentaires, consultez Limitations connues et solutions de contournement de la nouvelle expérience Power Query.
Note
La nouvelle expérience de Power Query est en préversion.
Prerequisites
Power BI Desktop avec la préversion de la fonctionnalité nouvelle expérience Power Query activée.
Pour activer la nouvelle expérience de Power Query :
- Démarrez Power BI Desktop.
- Accédez aux options de fichier>et aux paramètres>.
- Sélectionnez les fonctionnalités Preview, puis cochez la case nouvelle expérience de Power Query.
- Cliquez sur OK.
La même fonctionnalité d’aperçu permet à la fois la nouvelle expérience Obtenir des données et la nouvelle Éditeur Power Query. Pour revenir à l’éditeur hérité, décochez la case. Vous n'avez pas besoin de redémarrer Power BI Desktop. Pour plus d’informations sur la nouvelle expérience Obtenir des données, consultez Obtenir des données dans Power BI Desktop.
Ouvrir Éditeur Power Query
Pour ouvrir Éditeur Power Query, sélectionnez Transformer les données dans l’onglet Accueil de Power BI Desktop.
Sans connexion de données, l’Éditeur Power Query se présente sous la forme d’un volet vide, prêt à accueillir des données. Une fois qu’une requête est chargée, l’éditeur présente cinq composants distincts. Les nombres du tableau suivant correspondent aux légendes numérotées de la capture d’écran.
| # | Composant | Description |
|---|---|---|
| 1 | Ribbon | L’expérience de navigation du ruban, qui fournit plusieurs onglets pour ajouter des transformations, sélectionner des options pour votre requête et accéder à différents boutons de ruban pour effectuer différentes tâches. |
| 2 | Volet des requêtes | Vue de toutes vos requêtes disponibles. |
| 3 | Affichage actuel | Votre vue de travail principale, qui affiche par défaut un aperçu des données pour votre requête. Vous pouvez également activer la vue diagramme avec l’aperçu des données. Vous pouvez basculer entre la vue de schéma et l’aperçu des données tout en conservant la vue diagramme. |
| 4 | Paramètres de requête | Vue de la requête actuellement sélectionnée avec des informations pertinentes, telles que le nom de la requête, les étapes de requête et divers indicateurs. |
| 5 | Barre d’état | Barre montrant des informations importantes sur votre requête, telles que le temps d’exécution, le nombre total de colonnes et de lignes et l’état de traitement. Cette barre contient également des boutons pour modifier votre affichage actuel. |
Chacun de ces composants est décrit dans les sections suivantes. Pour obtenir une procédure pas à pas complète de l’interface utilisateur Power Query, consultez Utiliser Power Query pour transformer des données.
Le ruban
Le ruban est le composant dans lequel vous trouvez la plupart des transformations et actions que vous pouvez effectuer dans Éditeur Power Query. Les commandes sont regroupées sous les onglets Accueil, Transformation, Ajouter une colonne, Afficher, Outils et Aide . Chaque onglet fournit des boutons et des options spécifiques qui vous permettent d’accéder facilement aux transformations et actions dont vous avez besoin.
L’onglet Accueil contient les tâches de requête courantes, notamment les commandes Obtenir les données que vous utilisez pour vous connecter aux données et commencer le processus de génération de requêtes. Pour plus d’informations sur les sources de données disponibles, consultez Sources de données dans Power BI Desktop. Pour plus d’informations sur l’utilisation des connecteurs, consultez Vue d’ensemble de l’obtention des données.
L’onglet Transformation permet d’accéder aux tâches courantes de transformation de données, telles que l’ajout ou la suppression de colonnes, la modification des types de données et le fractionnement des colonnes. L’onglet Ajouter une colonne fournit davantage de tâches associées à l’ajout d’une colonne, à la mise en forme des données de colonne et à l’ajout de colonnes personnalisées. L’onglet Affichage contrôle les volets et les vues qui s’affichent et ouvre le Éditeur avancé.
L’interface Power Query est réactive et s’ajuste à votre résolution d’écran. Si vous souhaitez une version compacte du ruban, sélectionnez le bouton Réduire en bas à droite du ruban. Pour revenir au ruban standard, sélectionnez l’icône Développer dans le même coin.
La plupart des tâches disponibles à partir du ruban sont également disponibles en cliquant avec le bouton droit sur une colonne ou d’autres données, dans l’affichage actuel. Les transformations peuvent souvent être atteintes à partir de plusieurs emplacements, ce qui vous permet d’utiliser l’expérience que vous préférez.
Pour plus d’informations sur la transformation des données, notamment des exemples, consultez Tutoriel : Mettre en forme et combiner des données dans Power BI Desktop.
Volet Requêtes
Le volet Requêtes affiche toutes vos requêtes disponibles. Lorsque vous sélectionnez une requête, ses données sont affichées dans l’affichage actuel, où vous pouvez mettre en forme et transformer les données en fonction de vos besoins.
Sélectionnez l’icône dans le coin supérieur droit du volet Requêtes pour réduire le volet, puis sélectionnez-la à nouveau pour développer le volet. Des icônes similaires tout au long de l’interface vous permettent de réduire ou d’étendre d’autres vues et sections. Vous pouvez donc vous concentrer sur l’affichage qui vous intéresse le plus.
Pour plus d’informations, consultez le volet Requêtes.
Vue actuelle
L’affichage actuel est votre vue de travail principale. Par défaut, il affiche l’aperçu des données de la requête sélectionnée. Vous effectuez une grande partie des opérations de requête dans cette zone. Sélectionnez un en-tête de colonne ou cliquez dessus avec le bouton droit pour afficher les transformations disponibles pour cette colonne. La plupart de ces éléments sont identiques aux boutons des onglets du ruban.
Lorsque vous sélectionnez une transformation, la requête applique l’étape aux données. Elle enregistre également l’étape dans le cadre de la requête elle-même. Le volet Paramètres de requête enregistre les étapes dans l’ordre séquentiel, comme décrit plus loin dans cet article.
Vous pouvez également activer les outils de profilage des données pour mieux comprendre vos données, notamment la distribution des valeurs et la qualité des colonnes. Activez et désactivez ces outils à partir de l’onglet Affichage à votre convenance. Pour plus d’informations, consultez Utilisation des outils de profilage des données.
Basculer entre les vues
Outre la réduction des volets et des sections, vous pouvez également changer les vues affichées. Accédez à l’onglet Affichage dans le ruban, où vous trouverez les groupes Aperçu et Disposition qui contrôlent l’apparence de l’interface.
Le côté droit de la barre d’état contient également des icônes pour le diagramme, les données et les vues de schéma. Utilisez ces icônes pour changer d’affichage ou pour activer et désactiver l’affichage de votre choix.
Essayez ces options pour trouver la vue et la disposition qui vous conviennent le mieux.
Vue du schéma
La vue schéma offre un moyen rapide et simple d’interagir uniquement avec les composants du schéma de votre table, tels que les noms de colonnes et les types de données. Utilisez la vue schéma lorsque vous souhaitez effectuer des actions liées au schéma, telles que la suppression de colonnes, le changement de nom des colonnes, la modification des types de données de colonne, la réorganisation des colonnes ou la duplication de colonnes.
Lorsque l’affichage du schéma est actif, l’onglet Outils de schéma apparaît dans le ruban avec les actions qui s’appliquent aux colonnes.
Pour plus d’informations, consultez Utilisation de la vue Schéma.
Vue du diagramme
La vue diagramme vous permet de visualiser la structure de votre requête et la façon dont elle peut interagir avec d’autres requêtes dans votre projet. Chaque étape de votre requête a une icône distincte pour vous aider à reconnaître la transformation utilisée, et les lignes connectent les étapes pour illustrer les dépendances.
Lorsque l’aperçu des données et la vue diagramme sont activés, la vue diagramme apparaît en haut de l’aperçu des données. Une fois l’affichage du diagramme activé, sélectionnez le signe plus pour rechercher une nouvelle transformation à ajouter à votre requête.
Pour plus d’informations, consultez la vue Diagramme.
Volet Paramètres de requête
Le volet Paramètres de requête affiche des informations sur la requête actuellement sélectionnée, telles que le nom de la requête, ses étapes et divers indicateurs. Chaque transformation appliquée à votre requête est enregistrée en tant qu’étape dans la section Étapes appliquées .
Si vous devez vérifier comment votre requête est transformée de l’étape à l’étape, sélectionnez une étape pour afficher un aperçu de la résolution de votre requête à ce stade spécifique.
Il est important de savoir que les données sous-jacentes ne sont pas modifiées. À la place, l’Éditeur Power Query ajuste et met en forme sa vue des données.
Vous pouvez renommer des étapes, supprimer des étapes ou réorganiser les étapes comme vous le voyez. Pour ce faire, cliquez avec le bouton droit sur l’étape de la section Étapes appliquées , puis choisissez dans le menu qui s’affiche. Sélectionnez Propriétés pour modifier le nom d’une étape ou y ajouter une description. Toutes les étapes de requête sont effectuées dans l’ordre dans lequel elles apparaissent.
Pour plus d’informations, consultez Utiliser la liste Étapes appliquées.
La barre d’état
La barre d’état apparaît en bas de l’éditeur et affiche des informations importantes sur votre requête, telles que le temps d’exécution, le nombre total de colonnes et de lignes et l’état de traitement. Le côté droit de la barre d’état contient également des icônes que vous pouvez utiliser pour modifier l’affichage actuel.
Barre de formule
La barre de formule affiche l’expression du langage de formule Power Query M pour l’étape sélectionnée. Vous pouvez modifier l’expression directement dans la barre de formule pour ajuster une seule étape ou utiliser la Éditeur avancé pour utiliser le script de requête complet.
Obtenir de l’aide
L’onglet Aide de Éditeur Power Query fournit des liens vers des informations Power BI. Vous pouvez accéder aux mêmes options d’aide en sélectionnant Fichier>Aide.
Éditeur avancé
L’Éditeur avancé vous permet de voir le code que l’Éditeur Power Query crée à chaque étape. Il vous permet également de créer votre propre code dans le langage de formule Power Query M. Pour lancer l’Éditeur avancé, sélectionnez Affichage dans le ruban, puis sélectionnez Éditeur avancé. Une fenêtre s’affiche, montrant le code généré pour la requête sélectionnée.
Vous pouvez modifier le code directement dans la fenêtre Éditeur avancé . Pour fermer la fenêtre, cliquez sur le bouton Terminé ou Annuler .
Le Éditeur avancé est disponible à la fois dans la nouvelle expérience et l’expérience héritée. La capture d’écran précédente montre l’expérience héritée. Certains Éditeur avancé contrôles et options d’affichage diffèrent dans la nouvelle expérience. Pour plus d’informations, consultez Nouvelle expérience Power Query : limitations connues et solutions de contournement.
Enregistrement de votre travail
Quand votre requête se trouve là où vous voulez, sélectionnez Fermer et appliquer dans le menu Fichier de l’Éditeur Power Query. Cette action applique les modifications et ferme l’éditeur.
À chaque étape, Power BI Desktop affiche une boîte de dialogue pour afficher l’état de la progression.
Quand vous êtes prêt, Power BI Desktop peut enregistrer votre travail sous la forme d’un fichier .pbix.
Pour enregistrer votre travail, sélectionnez Fichier>Enregistrer (ou Fichier>Enregistrer sous), comme illustré dans l’image suivante.
Contenu connexe
Power BI Desktop vous permet d’effectuer des tâches très diverses. Pour plus d’informations sur ses fonctionnalités, passez en revue les ressources suivantes :
- Qu’est-ce que Power BI ?
- Utiliser Power Query pour transformer des données
- Nouvelle expérience Power Query : limitations connues et solutions de contournement
- Sources de données dans Power BI Desktop
- Connexion à des sources de données dans Power BI Desktop
- Tutoriel : Mettre en forme et combiner des données avec Power BI Desktop
- Effectuer des tâches de requête courantes dans Power BI Desktop