Partager via


Résoudre des problèmes de connectivité liés à Azure Lab Services

Important

Azure Lab Services va être mis hors service le 28 juin 2027. Pour plus d’informations, consultez le guide de mise hors service.

Cet article offre des conseils sur la résolution de problèmes de connectivité courants liés à Azure Lab Services.

Important

Azure Lab Services est une offre gérée où certaines des ressources de sauvegarde d’un labo ne sont pas accessibles directement. Cela affecte la possibilité d’utiliser d’autres guides de résolution des problèmes Azure VM tels que Résoudre des problèmes de connexions RDP sur une machine virtuelle Azure.

Vitesse de connexion lente

Symptômes

  • Connexion RDP (Remote Desktop Protocol) lente

Causes

  • Machine virtuelle de labo spécifique
  • Utilisation d’un réseau privé virtuel (VPN)
  • Pare-feu sur le réseau
  • Fournisseur de services Internet (ISP) spécifique

Résolution

  • Quantifier la vitesse de connexion RDP

    Vous pouvez utiliser le PsPing d’utilitaire pour mesure le temps de réponse de la machine. Les étapes sont incluses dans le blob Comment veiller à la meilleure expérience RDP pour les utilisateurs de labos

  • Déterminez l’étendue du problème :

    • S’il s’agit d’une machine spécifique
    • S’il existe un VPN en cours d’utilisation
    • S’il est lent sur un réseau spécifique
    • S’il existe un pare-feu sur le réseau
    • S’il est lent avec un ISP spécifique
Machine spécifique

Ajustez les paramètres dans l’expérience client pour réduire le volume de données transmis.

Utilisation d’un réseau privé virtuel (VPN)

Une bonne étape de résolution des problèmes consiste à désactiver le VPN pour voir si la vitesse de connexion s’améliore. S’il s’agit d’un VPN nécessaire, examinez la configuration et les paramètres du VPN pour permettre aux connexions RDP ou SSH d’être des connexions « directes » qui ne sont pas acheminées vers des régions distantes ou routées incorrectement.

Pare-feu ou travail spécifique

Un réseau peut affecter la connectivité à Azure Lab Services d’un réseau au niveau de l’entreprise vers une combinaison Wi-Fi/routeur domestique. Par exemple, il est possible que le routeur domestique d’un étudiant ait des pare-feux intégrés qui bloquent ou limitent les connexions RDP/SSH. Vérifiez s’il existe un pare-feu activé sur le réseau et s’il est configuré pour limiter les connexions RDP/SSH.

Fournisseur de services Internet (ISP) spécifique

Il est courant d’avoir plusieurs ISP auxquels se connecter. Si le ralentissement se situe sur un réseau spécifique et que d’autres options ont été explorées, vous voudrez peut-être contacter votre ISP pour voir s’il a des limiteurs sur des connexions RDP/SSH.

Impossible de se connecter à l’ordinateur distant

Symptômes

  • Les étudiants reçoivent le message « Le Bureau à distance ne peut pas se connecter à l’ordinateur distant ... Vérifiez que l’ordinateur distant est allumé et connecté au réseau et que l’accès à distance est activé »

    Boîte de dialogue modale pour la connexion Bureau à distance qui affiche une erreur indiquant : « Bureau à distance ne peut pas se connecter à l’ordinateur distant... Vérifiez que l’ordinateur distant est activé et connecté au réseau, mais aussi que l’accès à distance est activé »

Causes

  • La machine virtuelle à laquelle les étudiants tentent de se connecter n’est pas en cours d’exécution
  • Il est possible que la machine virtuelle de labo soit encore en cours de démarrage
  • Les paramètres d’inactivité peuvent affecter les connexions de machines virtuelles de labo

Résolution

Ouvrez le portail Lab et vérifiez que la machine virtuelle s’affiche comme étant en cours d’exécution. Si ce n’est pas le cas, l’étudiant peut démarrer la machine virtuelle à partir du portail de son labo. Il peut s’écouler entre 2 et 5 minutes avant que la machine soit entièrement opérationnelle.

Il est possible que l’ajustement des paramètres d’arrêt automatique du labo améliore l’expérience de connexion de l’étudiant. Étant donné que le démarrage et l’arrêt de la machine virtuelle prennent du temps, l’ajustement des paramètres peut diminuer les chances d’un étudiant qui tente de se connecter lors du changement d’état de la machine. Les paramètres d’arrêt automatique font partie d’une stratégie de réduction des coûts, bien qu’il soit nécessaire de les ajuster pour améliorer l’expérience de l’étudiant.

  • Arrêter des machines virtuelles inactives : si la durée est trop courte, il est possible que le temps ne soit pas suffisant entre le moment où l’étudiant démarre la machine et celui où il se connecte, ou si l’étudiant est inactif (apprentissage en classe par exemple), il est possible que la machine virtuelle s’arrête.
  • Arrêter des machines virtuelles lorsque des utilisateurs se déconnectent : si le délai est trop court, vous pouvez rencontrer des problèmes dans lesquels une déconnexion accidentelle démarre l’arrêt. Les étudiants devront redémarrer la machine virtuelle pour se connecter.
  • Arrêter des machines virtuelles lorsque des utilisateurs ne se connectent pas : si les étudiants ne se connectent pas à la machine virtuelle après un certain temps, ou si la durée est trop courte, la machine virtuelle s’arrête. Le calendrier peut affecter les étudiants qui démarrent eux-mêmes la machine virtuelle ou en cas d’utilisation de planifications dans le labo. Le changement du paramètre d’inactivité à une durée plus longue est une option, mais a des implications potentielles sur les coûts. Si des planifications sont utilisées, les machines virtuelles peuvent être démarrées plus près du démarrage de l’heure de classe.

La connexion sortante est restreinte

Symptômes

  • Le réseau peut être un point d’interférence où des pare-feux, commutateurs, routeurs ou d’autres appliances réseau bloquent ou limitent les ports RDP/SSH (3389/22)

Causes

  • Pare-feu local d’un réseau domestique, d’une entreprise, d’une université ou d’une école limitant les connexions RDP/SSH sortantes
  • Les routeurs modernes, en particulier WiFi 6, ont un comportement par défaut pour bloquer ou restreindre les connexions RDP/SSH
  • Système d’exploitation bloquant la connectivité RDP/SSH

Résolution

Envisagez de supprimer la restriction RDP/SSH ou d’ajouter une exemption pour l’adresse IP publique du labo que vous pouvez inclure à la liste d’autorisation pour le pare-feu ou le routeur.

Problème de connexion du labo après de changements par l’administrateur

Symptômes

  • Les étudiants sont les administrateurs de leur machine virtuelle de labo où ils peuvent apporter des modifications au système, notamment la configuration réseau

Causes

  • Mise à jour de l’adresse IP vers une adresse IP statique au lieu d’être spécifiée en tant qu’adresse IP dynamique
  • Désactivation du DCHP (empêchant l’obtention automatique d’une adresse IP)
  • Spécification des serveurs DNS
  • Mise à jour d’autorisations et de groupes d’utilisateurs locaux

Résolution

Vous pouvez configurer un modèle de labo avec un script pour réinitialiser automatiquement la mise en réseau lors de l’arrêt d’une machine. Sinon, les étudiants ou les enseignants doivent réinitialiser la machine virtuelle de labo, ce qui les fait revenir à un état correct.

Si un DNS personnalisé est nécessaire, utilisez Mise en réseau avancée et spécifiez les serveurs DNS personnalisés sur le réseau virtuel.

La machine virtuelle de labo ne peut pas se connecter via un VPN sortant

Symptômes

  • Les étudiants essaient d’utiliser une connexion VPN à partir de la machine virtuelle d’un étudiant et la connexion VPN échoue

Causes

  • Le VPN rencontre des problèmes avec la configuration réseau Azure Lab Services

Résolution

Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure.

Quand vous créez une demande de support Azure, indiquez les informations suivantes dans les détails de la demande pour accélérer la résolution du problème :

  • ID du plan de labo. Sélectionnez le plan de labo dans le portail Azure, puis accédez à la page Propriétés.
  • ID du labo. Sélectionnez le labo dans le portail Azure, puis accédez à la page Propriétés. Vous pouvez également sélectionner l’URL du labo sur le site web Azure Lab Services.
  • Heure approximative à laquelle les problèmes se sont produits.
  • Erreurs listées dans le journal d’activité Azure. Sélectionnez le plan de labo ou le labo dans le portail Azure, puis accédez à la page Journal d’activité. Découvrez comment vous pouvez afficher et télécharger le journal d’activité.

Impossible de se connecter à la machine virtuelle du labo après un déploiement

Symptômes

  • Il est possible que les connexions de la machine ne fonctionnent pas correctement si le labo fait l’objet d’un échec

Causes

  • Le journal d’activité d’Azure constitue la liste d’événements et de résultats la plus complète

Résolution

Vous pouvez filtrer le journal d’activité sur le groupe de ressources dans lequel se trouve le labo. La disponibilité des événements dans le journal peut prendre quelques minutes. Ces journaux des événements peuvent contenir des informations plus détaillées que vous pouvez utiliser pour résoudre des problèmes et que vous devez inclure si vous devez créer un ticket de support.

Impossible de se connecter avec un nom d’utilisateur et un mot de passe

Symptômes

  • Impossible de se connecter à une machine virtuelle de labo avec un nom d’utilisateur et un mot de passe
  • Réception du message d’erreur « Vos informations d’identification n’ont pas fonctionné »

Causes

  • L’étudiant utilise des informations d’identification incorrectes
  • L’étudiant a oublié son mot de passe
  • Mot de passe associé à une image Azure Compute Gallery
  • La machine a été compromise

Résolution

L’étudiant utilise des informations d’identification incorrectes

Confirmez que l’étudiant utilise le nom d’utilisateur et le mot de passe corrects pour leur machine virtuelle de labo. Si le labo a été créé avec l’option « Utiliser le même mot de passe pour toutes les machines virtuelles » activée, le nom d’utilisateur et le mot de passe doivent alors être les mêmes pour tous les étudiants.

L’étudiant a oublié son mot de passe

S’il a un mot de passe personnalisé et qu’il l’a oublié, l’étudiant peut réinitialiser le mot de passe sur la machine à partir du labo. En outre, l’étudiant peut réinitialiser la machine, mais toutes les données utilisateur sont supprimées et ne sont plus récupérables.

Si d’autres étudiants ne peuvent pas se connecter en utilisant le nom d’utilisateur et le mot de passe courants du labo et que ce dernier a été créé en utilisant une image personnalisée existante, il est possible que cela soit provoqué par une limitation connue. La solution de contournement consiste à utiliser le nom d’utilisateur et le mot de passe lorsque l’image a été créée ou à réinitialiser le mot de passe.

La machine a été compromise

Il existe des situations où le mot de passe d’un étudiant est modifié de manière frauduleuse par un acteur malveillant. L’étudiant peut réinitialiser son mot de passe pour avoir de nouveau accès à la machine, mais voici quelques suggestions pour réduire la probabilité que cela se produise :

  • N’utilisez pas de mots de passe courants et décochez la case de l’option pour utiliser le même mot de passe lors de la création du labo. Disposer de mots de passe spécifiques individuels diminue l’étendue en cas de compromission du mot de passe
  • Utiliser des mots de passe forts et les sécuriser
  • Limitez l’accès au lab afin que seuls les étudiants qui se trouvent dans la classe puissent accéder aux ordinateurs. Par défaut, le labo est restreint
Passerelle Bureau à distance

Bien qu’inhabituel, le client de bureau distant utilisé par les étudiants peut avoir une passerelle Bureau à distance configurée. Dans ce cas, ils doivent d’abord entrer leurs identifiants de passerelle (pour s’authentifier auprès de la passerelle) avant de se connecter à la machine virtuelle d’étudiant.

Résoudre des problèmes avec Mise en réseau avancée

Certains scénarios de résolution des problèmes s’appliquent uniquement aux labos avec une mise en réseau avancée.

Groupe de sécurité réseau manquant

Pour un plan de labo configuré avec une mise en réseau avancée, l’une des premières vérifications consiste à confirmer que le sous-réseau du réseau de services de labo dispose d’un groupe de sécurité réseau qui y est connecté. Cela permet aux connexions RDP/SSH d’y être autorisées. Sans groupe de sécurité réseau, toutes les connexions sont bloquées sur les machines virtuelles (machines virtuelles modèles et machines virtuelles d’étudiant).

Utilisation de la résolution des problèmes de RDP des machines virtuelles Azure

Il existe des techniques de résolution des problèmes uniques avec des labs configurés avec une mise en réseau avancée. La mise en réseau avancée permet davantage de résolutions des problèmes en créant une machine virtuelle Azure directement connectée au réseau virtuel auquel le plan de labo est connecté. À l’aide de cette machine virtuelle Azure (en dehors d’Azure Lab Services), vous pouvez utiliser le guide de résolution des problèmes RDP de machine virtuelle Azure, y compris l’utilitaire de résolution des problèmes de connexion dans Azure, pour déterminer si le réseau est configuré correctement.

Les règles NSG bloquent les connexions RDP/SSH

Si vous utilisez la machine virtuelle Azure connectée directement au réseau virtuel (de la section précédente), vous pouvez diagnostiquer la connectivité réseau de la machine virtuelle directement dans le Portail Azure. Vous pouvez effectuer le blocage ou la limitation des connexions RDP/SSH via des règles de sécurité au niveau du sous-réseau avec un groupe de sécurité réseau ou en utilisant Azure Virtual Network Manager. Le moyen le plus simple d’afficher la liste complète des règles s’effectue via les règles de sécurité effectives du réseau de machines virtuelles Azure.

Itinéraire défini par l’utilisateur par défaut (problème de la table de routage)

La mise en réseau avancée permet au réseau d’être personnalisé en fonction des besoins, notamment en modifiant la table de routage. Une table de routage définie par l’utilisateur dirige le trafic vers les destinations appropriées. Il existe une route spéciale, la « route Internet » (0.0.0.0/0), qui dirige le trafic non lié d’une autre adresse locale vers Internet. La mise en réseau avancée Azure Lab Services ne prend pas en charge la mise à jour du « tronçon suivant » pour la route 0.0.0.0/0 vers autre chose qu’Internet. Si vous la remplacez par une adresse IP spécifique (par exemple, vous dirigez le trafic Internet sortant vers un pare-feu ou une autre appliance réseau), la connectivité au labo s’interrompt en introduisant un problème de routage asymétrique. Lorsque vous déboguez des problèmes, vérifiez l’existence d’une table de routage personnalisée et assurez-vous que l’itinéraire par défaut est défini à 0.0.0.0/0 vers Internet.

Suite de la résolution des problèmes

Si vous rencontrez encore des problèmes après avoir suivi ces étapes, il est possible que vous deviez collecter d’autres données pour effectuer une résolution des problèmes plus approfondie. Cela peut inclure des journaux de votre machine virtuelle, des données de trace du réseau ou d’autres informations pertinentes.

Pour toute demande ou assistance, créez une demande de support ou posez une question au support de la communauté Azure.

Quand vous créez une demande de support Azure, indiquez les informations suivantes dans les détails de la demande pour accélérer la résolution du problème :

  • ID du plan de labo. Sélectionnez le plan de labo dans le portail Azure, puis accédez à la page Propriétés.
  • ID du labo. Sélectionnez le labo dans le portail Azure, puis accédez à la page Propriétés. Vous pouvez également sélectionner l’URL du labo sur le site web Azure Lab Services.
  • Heure approximative à laquelle les problèmes se sont produits.
  • Erreurs listées dans le journal d’activité Azure. Sélectionnez le plan de labo ou le labo dans le portail Azure, puis accédez à la page Journal d’activité. Découvrez comment vous pouvez afficher et télécharger le journal d’activité.