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Résoudre les problèmes d’accès conditionnel pour les appareils Android Teams

Symptômes

L’accès conditionnel est une fonctionnalité Microsoft Entra qui permet de s’assurer que les appareils qui accèdent aux ressources d’entreprise sont correctement gérés et sécurisés. Si les stratégies d’accès conditionnel sont appliquées au service Microsoft Teams, les appareils Android qui accèdent à Teams doivent se conformer aux stratégies. Ces appareils incluent les téléphones Teams, les affichages Teams, les écran Teams et les Salles Teams sur Android. Dans le cas contraire, l’accès conditionnel empêche les utilisateurs de se connecter à l’application Teams sur les appareils ou de l’utiliser.

Si ces stratégies sont appliquées, vous pouvez rencontrer un ou plusieurs des problèmes suivants sur les appareils non conformes :

  • Les appareils ne peuvent pas se connecter à Teams, ou ils sont bloqués dans les boucles de connexion.
  • Les appareils se déconnectent automatiquement de Teams de façon aléatoire.
  • Microsoft Teams cesse de répondre (fige).

Cause

Ces problèmes peuvent se produire pour les raisons suivantes :

  • Stratégie d’accès conditionnel non prise en charge ou paramètres de stratégie de conformité des appareils Intune

    Si un appareil est marqué comme non conforme, le service d’émission de jetons Microsoft Entra cesse de renouveler les jetons pour l’objet de l’appareil ou révoque même le jeton. Dans ce cas, l’appareil ne peut pas obtenir de jeton d’authentification mis à jour et il est forcé de se déconnecter.

    Pour vérifier l’état de conformité de vos appareils, utilisez le tableau de bord de conformité des appareils Intune.

  • Paramètre de fréquence de connexion

    Ce paramètre force la réauthentification périodique. Cette action peut entraîner la déconnexion aléatoire des appareils, en fonction du nombre de vos stratégies d’accès conditionnel définies sur différentes fréquences de connexion. Chaque fois que la réauthentification se produit, le jeton est révoqué et un nouvel objet d’appareil est créé sous le compte d’utilisateur. Si le nombre d’objets d’appareil dépasse la limite d’appareil Microsoft Entra ou la limite d’appareil Intune, l’utilisateur ne peut pas se connecter à l’appareil.

  • Les conditions d’utilisation (ToU) et les stratégies d’accès conditionnel MFA, si les deux sont utilisées

    Pour plus d’informations, consultez Problèmes connus liés aux téléphones Teams.

Résolution

Identifiez la cause spécifique du problème en vérifiant plusieurs détails sur l’accès de l’utilisateur concerné à l’application Teams. Pour effectuer les vérifications requises, vous pouvez utiliser une option automatisée ou exécuter les vérifications manuellement à l’aide des étapes fournies.

Contrôles automatisés

L’option automatisée consiste à exécuter le test de connectivité de connexion Salles Microsoft Teams dans l’outil Microsoft Remote Connectivity Analyzer. Cet outil est utilisé pour résoudre les problèmes de connectivité qui affectent Teams. Le test de connectivité effectue des vérifications pour vérifier les autorisations d’un utilisateur spécifique pour se connecter à Teams à l’aide d’un appareil Salles Teams.

Note

  • Un compte d’administrateur général est requis pour exécuter le test de connectivité de connexion Salles Microsoft Teams.
  • L’outil Microsoft Remote Connectivity Analyzer n’est pas disponible pour les environnements GCC et GCC High Microsoft 365 Government.

Pour exécuter le test de connectivité, procédez comme suit :

  1. Ouvrez un navigateur web et accédez au test de connectivité de connexion Salles Microsoft Teams.
  2. Connectez-vous à l’aide des informations d’identification d’un compte d’administrateur général.
  3. Spécifiez le nom d’utilisateur du compte qui ne peut pas accéder à l’application Salles Teams.
  4. Dans le champ Sélection de l’appareil, sélectionnez un type pour l’appareil de l’utilisateur concerné.
  5. Entrez le code de vérification qui s’affiche, puis sélectionnez Vérifier.
  6. Cochez la case pour accepter les conditions d’utilisation, puis sélectionnez Effectuer un test.

Une fois le test terminé, l’écran affiche des détails sur toutes les vérifications effectuées et indique si le test a réussi, échoué ou réussi, mais a affiché quelques avertissements. Sélectionnez le lien fourni pour plus d’informations sur les avertissements et les échecs, et sur la façon de les résoudre.

Vérifications manuelles

Pour vérifier manuellement l’accès utilisateur à l’application Teams, procédez comme suit :

  1. Accédez aux journaux de connexion dans le Portail Azure.

  2. Sélectionnez l’onglet Connexions utilisateur (non interactive).

  3. Sélectionnez Ajouter des filtres pour ajouter les filtres suivants :

    • État : Sélectionnez Échec, puis sélectionnez Appliquer.
    • Application : Entrez Teams, puis sélectionnez Appliquer.

    Capture d’écran des filtres État et Application.

  4. Pour les noms d’utilisateur affectés, recherchez les éléments qui ont les valeurs d’application suivantes :

    • Microsoft Teams
    • Microsoft Teams Service
    • Microsoft Teams – Agent d’administration de l’appareil
  5. Sélectionnez chaque élément pour afficher les détails de la connexion ayant échoué. En règle générale, vous pouvez obtenir plus d’informations à partir des champs suivants sous l’onglet Informations de base :

    • Code d’erreur de connexion
    • Raison de l’échec
    • Informations supplémentaires

    Capture d’écran de la page Informations de base des détails de l’activité de connexion.

  6. Si le code d’erreur de connexion semble lié à la conformité, sélectionnez l’onglet Accès conditionnel, puis recherchez les stratégies qui affichent un résultat d’échec .

    Capture d’écran de la page Accès conditionnel des détails de l’activité de connexion.

  7. Passez en revue les détails de la stratégie.

    Capture d’écran des détails de la stratégie d’accès conditionnel.

Après avoir identifié la stratégie d’accès conditionnel spécifique à l’origine du problème, vous pouvez utiliser des filtres d’appareil pour exclure l’appareil concerné de la stratégie. Les propriétés d’appareil couramment utilisées dans les filtres d’appareil sont le fabricant et le modèle. Elles sont utilisées avec les opérateurs Contains, StartsWith et In .

Note

  • Les filtres d’appareil s’appliquent uniquement aux objets d’appareil, et non aux comptes d’utilisateur.
  • Certains attributs, tels que le modèle et le fabricant, ne peuvent être définis que si les appareils sont inscrits dans Intune. Si vos appareils ne sont pas inscrits dans Intune, utilisez des attributs d’extension.
  • Vérifiez chaque paramètre de stratégie pour les paramètres non pris en charge pour les appareils Teams.

La capture d’écran suivante montre un exemple de filtre d’appareil.

Capture d’écran d’un exemple de filtre d’appareil.

References