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A desktop flow fails with the "The remote desktop wasn't found" error

This article helps you resolve an issue where a flow fails with the "The remote desktop wasn't found" error when using Microsoft Remote Desktop Protocol (RDP) or Citrix automation in Microsoft Power Automate.

Symptoms

A flow using Remote Desktop Protocol (RDP) or Citrix automation that previously ran successfully might start failing with the following error:

The remote desktop wasn't found.

This issue is more common in Citrix Virtual Apps.

Cause 1

The names of the RDP window, Citrix Desktop, or Citrix Virtual Apps might have changed since the original UI elements were captured. Tracking these elements with the old name can fail.

Resolution

To solve this issue:

  1. Ensure the affected RDP window, Citrix Desktop, or Citrix Virtual Apps is active.

  2. Locate the desktop element causing the issue in the UI elements pane in the flow designer. Double-click it to open the selector editor.

    Screenshot of the Power Automate elements section with a Citrix desktop element highlighted.

  3. Select the Repair button and capture the new desktop or app. Review the suggested changes and accept them. For more information, see Repair a selector.

    Screenshot of the Power Automate selector builder window with the Repair button highlighted.

  4. After accepting the changes, select Test to verify the new selector. For more information, see Test a selector.

  5. (Optional) Use the New button to add more fallback selectors for the desktop.

Cause 2

When you use Citrix Virtual Apps with certain applications, especially when interacting with combo box lists, an incorrect target desktop selector might be created using an ordinal value (for example, eq) instead of a more robust selection method.

Resolution

To solve this issue:

  1. Ensure the affected RDP window, Citrix Desktop, or Citrix Virtual Apps is active.

  2. Locate the desktop element causing the issue in the UI elements pane in the flow designer. Double-click it to open the selector editor.

    Screenshot of the Power Automate elements section with a Citrix app element highlighted.

  3. Check if the selector is using an ordinal value (the eq is selected.) If it is, clear the value and save the change.

    Screenshot of the Power Automate selector builder window with an ordinal attribute checkbox cleared.

  4. Select Test to verify the new selector. For more information, see Test a selector.

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.