Többtényezős hitelesítést (MFA) igénylő fiókokkal jelentkezzen be a Visual Studióba

Ebben a cikkben megtanulhatja, hogyan használhatja a Visual Studiót többtényezős hitelesítést (MFA) igénylő fiókokkal.

Miért érdemes engedélyezni az MFA-szabályzatokat?

Ha külső vendégfelhasználókkal dolgozik együtt, érdemes feltételes hozzáféréssel (CA) szabályzatokkal, például többtényezős hitelesítéssel (MFA)védeni az alkalmazásokat és az adatokat.

Ha engedélyezve van, a vendégfelhasználóknak nem csak felhasználónévre és jelszóra van szükségük az erőforrások eléréséhez, és meg kell felelniük a további biztonsági követelményeknek. Az MFA-szabályzatok a bérlői, alkalmazás- vagy egyéni vendégfelhasználói szinten is kikényszeríthetők, ugyanúgy, mint a saját szervezet tagjai számára.

Jegyzet

A Visual Studio 16.6 előtti verziói csökkentett hitelesítési élményt nyújthatnak, ha olyan fiókokkal használják, amelyek engedélyezték a ca-házirendeket, például az MFA-t, és két vagy több bérlőhöz vannak társítva.

Ezek a problémák miatt a Visual Studio példánya naponta többször is kérni fogja az újrahitelesítést. Előfordulhat, hogy újra meg kell adnia a hitelesítő adatait a korábban hitelesített bérlők számára, még ugyanabban a Visual Studio munkamenetben is.

A Visual Studio használata MFA-szabályzatokkal

A Visual Studio 2022 17.11-es-s verziójával a Windows hitelesítési közvetítő az alapértelmezett munkafolyamat a fiókok Visual Studióban való hozzáadásához és újbóli hitelesítéséhez.

A Windows hitelesítési közvetítő Web Account Manager (WAM) használ, és számos előnyt kínál, például a biztonságot, a továbbfejlesztett MFA-támogatást, valamint az operációs rendszerhez és a Visual Studióhoz hozzáadott fiókok zökkenőmentes integrációját. Ha a WAM-et használja hitelesítési mechanizmusként a Visual Studióban, egyszerűbben érheti el a ca-házirendek, például az MFA által biztosított erőforrásokat.

Válassza ki a webes hitelesítési közvetítőt a legördülő listából.

Válassza ki a webes hitelesítési közvetítőt a legördülő listából.

Ha problémákba ütközik a WAMhasználatával kapcsolatban, javasoljuk, használja a System webböngészőt a Visual Studio-fiókok hozzáadásának és újrahitelesítésének alternatívaként.

Figyelmeztetés

Ha nem használja ezt a munkafolyamatot, az csökkentett teljesítményű felhasználói élményt eredményezhet, amely több további hitelesítési kérést eredményez a Visual Studio-fiókok hozzáadásakor vagy újbóli hitelesítésekor.

A Windows hitelesítési közvetítő használata

A WAM használatának megkezdése hitelesítési mechanizmusként a Visual Studióban:

  1. Frissítsen Visual Studio 2022 17.11-es vagy újabb verziójára.

  2. Válasszon ki egy fiókot a WAM párbeszédpanelen, amikor a rendszer kéri. Ha a fiókja nem szerepel a listában, adja hozzá a Fiók hozzáadásahasználatával.

    Fiók hozzáadása a Windows hitelesítési közvetítő munkafolyamatával.

A fiókokat a Fiókbeállítások párbeszédpanelen kezelheti a Visual Studióban.

A Windows Account Manager (WAM) használata hitelesítési mechanizmusként a Visual Studióban a fiókok hozzáadásához és újbóli hitelesítéséhez ajánlott munkafolyamat. Ha azonban a WAM használatával kapcsolatosproblémákba ütközik, válthat a rendszer webböngészőjének használatára.

A rendszerböngésző engedélyezése

Jegyzet

A legjobb élmény érdekében javasoljuk, hogy a munkafolyamat megkezdése előtt törölje a rendszer alapértelmezett webböngésző-adatait. Emellett ha munkahelyi vagy iskolai fiókokkal rendelkezik a Windows 10 Beállítások területen a Access munkahelyi vagy iskolai területen, ellenőrizze, hogy megfelelően vannak-e hitelesítve.

A rendszerböngésző munkafolyamatának engedélyezéséhez nyissa meg a Visual Studio Beállítások párbeszédpaneljét (Eszközök > Beállítások...), válassza a Fiókok lapot, majd a „Fiókok hozzáadása és újrahitelesítése a következő használatával:” legördülő listából válassza a „Rendszerböngésző” lehetőséget.

Válassza ki a rendszer webböngészőt a menüből.

Válassza ki a rendszer webböngészőt a menüből.

További fiókokba való bejelentkezés MFA-szabályzatok szerint

A Profilkártya vagy a Fiókbeállítások párbeszédpanelen (Fájl > fiókbeállítások...)keresztül jelentkezhet be vagy vehet fel fiókokat a Visual Studióba.

Windows-hitelesítési közvetítő

A Windows hitelesítési közvetítő munkafolyamatának engedélyezése után a szokásos módon bejelentkezhet vagy felvehet fiókokat a Visual Studióba. A Web Account Manager (WAM) leegyszerűsíti a bejelentkezést azáltal, hogy lehetővé teszi a felhasználóknak, hogy a Windows által ismert fiókokkal, például a Windows-munkamenetbe bejelentkezett fiókkal jelentkezzenek be.

További fiókok hozzáadása a Visual Studióhoz a Windows hitelesítési közvetítő munkafolyamatával.

rendszerböngésző

A rendszer webböngésző munkafolyamatának engedélyezése után a szokásos módon bejelentkezhet vagy felvehet fiókokat a Visual Studióba.

Új személyre szabási fiók hozzáadása a Visual Studióhoz.

Új személyre szabási fiók hozzáadása a Visual Studióhoz.

Ez a művelet megnyitja a rendszer alapértelmezett webböngészőjét, megkéri, hogy jelentkezzen be a fiókjába, és ellenőrizze a szükséges MFA-szabályzatokat.

A bejelentkezési folyamat során egy további kérést kaphat, amely arra kéri, hogy maradjon bejelentkezve. Ez a kérés valószínűleg a második alkalommal jelenik meg, amikor egy fiók bejelentkezik. A hitelesítő adatok újbóli megadásának minimálisra csökkentése érdekében javasoljuk, hogy válassza az Igen lehetőséget, mivel ez biztosítja a hitelesítő adatok megőrzését a böngésző munkamenetei között.

Maradjon bejelentkezve?

A fejlesztési tevékenységek és az erőforrás-konfiguráció alapján előfordulhat, hogy a rendszer továbbra is kérni fogja a hitelesítő adatok újbóli megadását a munkamenet során. Ez a kérés akkor fordulhat elő, ha új erőforrást ad hozzá, vagy megpróbál hozzáférni egy erőforráshoz anélkül, hogy korábban megfelelt volna a CA/MFA engedélyezési követelményeinek.

Fiók ismételt hitelesítése

Ha probléma merül fel a fiókjával kapcsolatban, Visual Studio kérheti a fiók hitelesítő adatainak újbóli megadását.

Képernyőkép az újrahitelesítést igénylő fiókról.

Képernyőkép az újrahitelesítést igénylő fiókról.

A hitelesítő adatok újbóli megadására kattintva megnyílik a rendszer alapértelmezett webböngészője, és megkísérli automatikusan frissíteni a hitelesítő adatait. Sikertelenség esetén a rendszer arra kéri, hogy jelentkezzen be a fiókjába, és ellenőrizze a szükséges CA/MFA-szabályzatokat.

Ha a fiókja több Azure aktív címtárhoz van társítva, és egy vagy több címtárral kapcsolatos hozzáférési problémába ütközik, a Be kell írnia a hitelesítő adatait párbeszédpanelen megtekintheti az érintett könyvtárakat és a kapcsolódó AADSTS hibakódokat.

Törölheti azon címtárak kijelölését, amelyeket nem szeretne újrahitelesíteni, és folytathatja a szokásos bejelentkezési műveletet a saját címtárral, valamint a továbbra is kijelölt vendégbérlőkkel. A törölt címtárak nem lesznek elérhetők a jövőbeni használatra, amíg el nem távolítják a fiókszűrő.

a Visual Studio-fiók újrahitelesítése.

Jegyzet

A legjobb élmény érdekében tartsa nyitva a böngészőt, amíg az összes CA/MFA-szabályzatot nem érvényesítik az erőforrásaira. A böngésző bezárása a korábban létrehozott MFA-állapot elvesztését eredményezheti, és további engedélyezési kéréseket kérhet.

Bejelentkezési problémák elhárítása

CA/MFA-problémák

Ha ca/MFA-problémákat tapasztal, és/vagy a rendszerböngésző használatakor sem tud bejelentkezni, a probléma megoldásához próbálkozzon az alábbi lépésekkel:

  1. Jelentkezzen ki a fiókból a Visual Studióban.
  2. Válassza Eszközök>Beállítások>Fiókok> Törölje a jelölést Hitelesítés az összes Azure Active Directory között.
  3. Jelentkezzen be újra.

Jegyzet

Ezeket a lépéseket követően valószínűleg bejelentkezhet, de a fiókja szűrt állapotba kerül. Szűrt állapotban csak a fiók alapértelmezett bérlője és erőforrásai érhetők el. Az összes többi Microsoft Entra-bérlő és -erőforrás elérhetetlenné válik, de manuálisan újra hozzáadhatja őket.

Előhitelesítési problémák

Képernyőkép egy előhitelesítési hiba párbeszédpanelről.

A Visual Studio 2022 17.5-ös verziójától kezdve, ha megjelenik az előző hibaablak, próbálkozzon a következő lépésekkel a probléma megoldásához:

  1. Jelentkezzen ki a fiókból a Visual Studióban.
  2. Jelentkezzen be újra.
  3. Hozzon létre egy új Jelentse a problémát jegyet, amely ismerteti az éppen végzett tevékenységet és/vagy erőforrást, amelyhez a probléma észlelése előtt próbált hozzáférni.

Jegyzet

A jegy létrehozása segít azonosítani a problémás területeket, és megadni a szükséges naplókat a probléma kivizsgálásához és kezeléséhez.

A Web Account Manager (WAM) hibái

Ha hibákba ütközik, amikor a Windows hitelesítési közvetítő munkafolyamatát használja a Visual Studiovaló bejelentkezéshez, a hiba párbeszédpanelen felsorolt műveletet követve oldhatja meg vagy jelentheti a problémát. A párbeszédpanel hivatkozásai segítségével többet tudhat meg a hibáról, vagy megtekintheti a hibanaplókat.

TPM -hiba (megbízható platformmodul)

Ha például a következő hibaablak jelenik meg, megpróbálhatja megoldani a problémát a TPM-hibák hibaelhárításiutasításait követve.

WAM-hiba párbeszédpanel képernyőképe a hitelesítési mechanizmus módosításának opciójával a hiba megoldásához.

Ha a Windows Brokertől eltérő hitelesítési mechanizmusra kell váltania, ezt a a rendszer webböngészőjének engedélyezéséhez tartozó utasításokat követve teheti meg. Ha ezek az utasítások nem működnek, és támogatási szerződéssel rendelkezik, nyisson támogatási jegyet a Műszaki támogatási szolgálatnál

Egy adott Microsoft Entra-bérlő használatának letiltása a Visual Studióban

Visual Studio rugalmasan szűrheti ki a bérlőket egyenként vagy globálisan, és hatékonyan elrejtheti őket a Visual Studio elől. A szűrés szükségtelenné teszi a bérlővel való hitelesítést, de azt is jelenti, hogy nem fog tudni hozzáférni a társított erőforrásokhoz.

Ez a funkció akkor hasznos, ha több bérlővel rendelkezik, de egy adott részhalmaz megcélzásával szeretné optimalizálni a fejlesztési környezetet. Ez is segíthet olyan esetekben, amikor nem tud érvényesíteni egy adott CA/MFA szabályzatot, mivel kiszűrheti a problémás bérlőt.

Az összes bérlő szűrése

Az összes bérlő globális szűréséhez nyissa meg a Fiókbeállítások párbeszédpanelt (Fájl > Fiókbeállítások... > Fiókbeállítások lehetőségek), és törölje a Hitelesítés az összes Azure Active Directory között jelölőnégyzet jelölését.

Ha a beállítást nem jelöli ki, az biztosítja, hogy csak a fiók alapértelmezett bérlőjén keresztül történjen a hitelesítés. Ez azt is jelenti, hogy nem fog tudni hozzáférni más bérlőkhöz társított erőforrásokhoz, amelyeken a fiókja vendég lehet.

Az egyes bérlők szűrése

A Visual Studio-fiókhoz társított bérlők szűréséhez nyissa meg a Fiókbeállítások párbeszédpanelt (Fájl > fiókbeállítások...), majd kattintson a Szűrőalkalmazása elemre.

Szűrő alkalmazása.

Szűrő alkalmazása.

Megjelenik a Fiók szűrése párbeszédpanel, amelyen kiválaszthatja, hogy mely bérlőket szeretné használni a fiókjával.

Válassza ki a szűrni kívánt fiókot.

Miután megszüntette a bérlő szűrésre való kijelölését, a Fiókbeállítások és a Fiók szűrése párbeszédpanelen szűrt állapot jelenik meg.

Képernyőkép a szűrt bérlői állapotról a Fiókbeállítások és a Fiók szűrése párbeszédpanelekben

Képernyőkép a szűrt bérlői állapotról a Fiókbeállítások és a Fiók szűrése párbeszédpanelekben

Hálózatkezelési hibák a Visual Studióval

A bejelentkezés során Visual Studio a hálózattal kapcsolatos olyan hibákat tapasztalhatnak, amelyek általában nem Visual Studio termékproblémák, és a helyi informatikai támogatási szolgálatnak kell kivizsgálnia.

"Proxyengedély szükséges

Ha a gép vagy a szervezet biztonsági intézkedéseket, például tűzfalat vagy proxykiszolgálót használ, győződjön meg arról, hogy betartja a követelményeket a Visual Studio proxy vagy tűzfal mögöttihasználatához.

SSL-hibák

Az SSL-hibák különböző formában jelentkezhetnek. Néhány példa:

  • "A mögöttes kapcsolat lezárult"
  • "Az SSL-kapcsolat nem hozható létre"
  • "Nem hozható létre SSL/TLS biztonságos csatorna"
  • "A távoli gazdagép kényszerítetten bezárt egy meglévő kapcsolatot." (Ez a probléma a kapcsolatot blokkoló tűzfalak miatt is előfordulhat)
  • "A mögöttes kapcsolat lezárult: Váratlan hiba történt a küldéskor"

Ezeket a hibákat a következők okozhatják:

  1. Vállalati proxy vagy tűzfal blokkolja a TLS bizonyos verzióit
  2. A TLS 1.3 engedélyezve van a gépen, de a hálózat nem támogatja. Megpróbálhatja letiltani a TLS 1.3 a gépen, és tesztelni, hogy ez így van-e.
  3. A csoportházirend korlátozza, hogy milyen SSL-algoritmusok engedélyezettek, és ez az engedélyezett lista nem egyezik meg a kiszolgáló által elvárttal.

Az SSL-problémák elhárításához az alábbi erőforrások lehetnek hasznosak:

TLS 1.3 letiltása

1.3: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.3\Client] "DisabledByDefault"=dword:00000001 "Enabled"=dword:00000000

A kapcsolat elutasított hibái

"Nem sikerült kapcsolatot létesíteni, mert a célgép aktívan elutasította"

Ez a hiba azt jelenti, hogy amikor a Visual Studio egy internetes végponthoz próbál kapcsolatot létesíteni, a gép elutasította a kapcsolatot.

Gyakori okok:

  • Ha a "127.0.0.1" cím szerepel a hibaüzenetben, ez azt jelenti, hogy a rendszer megkísérelt kapcsolatot létesíteni egy helyi proxykiszolgálóval, de a helyi proxykiszolgáló nem futott.

  • VPN-kapcsolat – Próbáljon meg leválasztani bármelyik VPN-ről, és próbálkozzon újra a kapcsolattal. Ha működik, érdemes nyomon követnie a VPN-szolgáltatót vagy a hálózati rendszergazdát. Ide tartoznak a vállalati VPN- vagy külső VPN-szolgáltatások.

  • DNS – A számítógépen lévő tartománykeresés olyan címre lett feloldva, amely nem a várt kiszolgálóra mutat. Ez azt jelenti, hogy a kapcsolat egy másik gépre kerül, amely nem a várt szolgáltatásokat futtatja, és nem engedélyezi a kapcsolatot. A hiba elhárításához használhat olyan eszközöket, mint például az NsLookup, és összehasonlíthatja azt az Azure IP-címtartományokkal és szolgáltatáscímkékkel.

  • IPV6 – Egyes számítógépeken engedélyezve van az IPV6, de a hálózat nem támogatja a protokollt. Ebben az esetben előfordulhat, hogy egy kapcsolat elutasított üzenete jelenik meg, mert a kiszolgáló nem található. Próbálja meg letiltani az IPV6-ot a gépen, és ellenőrizze, hogy működik-e a kapcsolat.

  • SSL-problémák – Lásd: SSL-hibák.

  • Proxyk vagy tűzfalak a hálózaton – Ha proxy vagy tűzfal található a hálózaton, ez az első eszköz, amellyel a kapcsolat kommunikálni próbál, és lehet, hogy ez az egyetlen, aki megtagadja a kapcsolatot. A hálózati rendszergazdától megkérdezve megállapíthatja, hogy a tűzfal vagy a proxykiszolgáló blokkolja-e a kapcsolatokat. Másik lehetőségként a hálózati nyomkövetések is jelezhetik, hogy melyik géphez csatlakozik a rendszer, és azonosíthatja, hogy ki tagadja meg. Ha belső hálózati címről van szó, az azt jelenti, hogy a proxy vagy a tűzfal letiltotta a kapcsolatot. Ha külső IP-címről van szó, ez általában DNS-, IPV6- vagy SSL-problémákat jelent.

A hálózattal kapcsolatos problémák általában a Visual Studio helyett a géppel vagy a hálózat konfigurációval kapcsolatosak. fejlesztői közösség némi támogatást nyújthat, de a Visual Studióban a gépi konfiguráció helyett a funkciókra összpontosít. A hálózatspecifikus támogatáshoz a Microsoft támogatási közösség vagy a technikai támogatás lehet hasznos.

Hibák az első indításkor

A Visual Studio első indításakor hibák léphetnek fel. A hiba párbeszédpanelen az a probléma látható, amely megakadályozta Visual Studio megnyitását.

Hozzáférés megtagadva

A következő hibák egyike jelenhet meg:

Hibaüzenetet ábrázoló képernyőkép, amely szerint a 'C:\Users\<UserName>\AppData\Local\.IdentityService\<Néhány fájlnév>' elérési úthoz való hozzáférés megtagadva.

Képernyőkép az elérési út hibájának bemutatására:

Ha ilyen hibákba ütközik, zárja be a Visual Studio megnyitott példányait, és törölje a hibaüzenetben említett fájlt vagy könyvtárat a probléma megoldásához.

A fájl törlése előtt ellenőrizze a fájl biztonsági engedélyeit, és fontolja meg egy fejlesztői közösség visszajelzési jegy naplózását. Ez segít jobban megérteni, hogy miért van megtagadva ezekhez a fájlokhoz vagy könyvtárakhoz való hozzáférés.

A visszajelzési jegyben adja meg a következő információkat a probléma kivizsgálásához:

  1. A hibában említett fájlra vagy könyvtárra vonatkozó engedélyekkel rendelkező csoportok és felhasználók leírása vagy képernyőképe. Ennek megtekintéséhez kattintson a jobb gombbal a fájlra vagy könyvtárra, majd válassza a Tulajdonságok>Biztonságilehetőséget.
  2. A Visual Studio futtatásához használt felhasználói fiók.
  3. Ha a hiba a Visual Studio második indításakor is fennáll.