Bagikan melalui


Memecahkan masalah OverconstrainedAllocationRequest saat menerapkan layanan Cloud (klasik) ke Azure

Penting

Cloud Services (klasik) sekarang tidak lagi digunakan untuk pelanggan baru dan akan dihentikan untuk semua pelanggan pada 31 Agustus 2024. Penyebaran baru sebaiknya menggunakan Azure Resource Manager yang baru berdasarkan model penyebaran Azure Cloud Services (dukungan tambahan).

Dalam artikel ini, Anda memecahkan masalah atas kegagalan alokasi yang dibatasi yang mencegah penyebaran Azure Cloud Services (klasik).

Saat Anda menerapkan instans ke Layanan Awan, atau menambahkan instans peran web atau pekerja baru, Microsoft Azure mengalokasikan sumber daya komputasi.

Anda mungkin terkadang menerima kesalahan selama operasi ini bahkan sebelum Anda mencapai batas langganan Azure.

Tip

Informasi ini mungkin juga berguna saat Anda merencanakan penerapan layanan Anda.

Gejala

Gambar menunjukkan bilah Log operasi (klasik).

Tipe Pengecualian Pesan kesalahan
OverconstrainedAllocationRequest Ukuran komputer virtual (VM) (atau kombinasi ukuran VM) yang diperlukan oleh penyebaran ini tidak dapat disediakan karena kendala permintaan penyebaran. Jika memungkinkan, coba batasan santai seperti pengikatan jaringan virtual. Coba juga sebarkan ke layanan yang dihosting tanpa penyebaran lain di dalamnya dan ke grup afinitas yang berbeda atau tanpa grup afinitas. Anda dapat mencoba menyebarkan ke wilayah yang berbeda sama sekali.

Penyebab

Akar penyebabnya berbeda, tergantung layanan cloud disematkan atau tidak disematkan.

Catatan

Saat instans pertama diterapkan ke layanan cloud (baik dalam penahapan atau produksi), layanan cloud tersebut disematkan ke kluster.

Seiring waktu, sumber daya dalam kluster dapat menjadi sepenuhnya digunakan. Jika layanan Cloud (klasik) membuat permintaan alokasi untuk sumber daya tambahan saat sumber daya di kluster yang disematkan tidak mencukupi, permintaan akan mengakibatkan kegagalan alokasi.

Solusi

Ikuti panduan untuk kegagalan alokasi dalam skenario berikut.

Tidak disematkan ke kluster

Pertama kali Anda menyebarkan layanan Cloud (klasik), kluster tidak dipilih, sehingga layanan cloud tidak disematkan. Azure mungkin mengalami kegagalan penerapan karena:

  • Anda memilih ukuran tertentu yang tidak tersedia di wilayah tersebut.
  • Kombinasi ukuran yang diperlukan di berbagai peran tidak tersedia di wilayah ini.

Ketika Anda mengalami kesalahan alokasi dalam skenario ini, tindakan yang direkomendasikan adalah memeriksa ukuran yang tersedia di wilayah tersebut dan mengubah ukuran yang Anda tetapkan sebelumnya.

  1. Anda dapat memeriksa ukuran yang tersedia untuk tiap wilayah di halaman Produk layanan Cloud (klasik).

    Catatan

    Halaman Produk tidak akan menampilkan kapasitas yang tersedia. Untuk alokasi baru, Azure harus dapat memilih kluster optimal di wilayah Anda pada saat itu.

  2. Perbarui file definisi layanan untuk layanan Cloud (klasik) Anda untuk menentukan berbagai ukuran produk dari wilayah Anda.

Disematkan ke kluster

Layanan cloud yang ada disematkan ke kluster. Penyebaran lebih lanjut untuk layanan Cloud (klasik) terjadi di kluster yang sama.

Ketika Anda mengalami kesalahan alokasi dalam skenario ini, tindakan yang direkomendasikan adalah menerapkan ulang ke layanan Cloud baru (klasik) (dan memperbarui CNAME).

Tip

Solusi ini kemungkinan paling berhasil karena memungkinkan platform untuk memilih dari semua kluster di wilayah itu.

Catatan

Solusi ini tidak akan menimbulkan downtime.

  1. Terapkan beban kerja ke layanan Cloud baru (klasik).

    Peringatan

    Jika Anda tidak ingin kehilangan alamat IP yang terkait dengan slot penerapan ini, Anda dapat menggunakan Solusi 3 - Pertahankan alamat IP.

  2. Perbarui catatan CNAME atau A untuk mengarahkan lalu lintas ke layanan Cloud baru (klasik).

  3. Setelah tidak ada lalu lintas yang masuk ke situs lama, Anda dapat menghapus layanan Cloud lama (klasik).

Lihat Pemecahan masalah kegagalan alokasi layanan Cloud (klasik) | Microsoft Docs untuk langkah-langkah perbaikan lebih lanjut.

Langkah berikutnya

Untuk solusi kegagalan alokasi dan informasi latar belakang lainnya:

Jika masalah Azure Anda tidak diatasi dalam artikel ini, kunjungi forum Azure di Microsoft Developer Network (MSDN) dan Stack Overflow. Anda dapat memposting masalah Anda di forum ini, atau memposting ke @AzureSupport di Twitter. Anda juga dapat mengirimkan permintaan dukungan Azure. Untuk mengirimkan permintaan dukungan, pada halaman dukungan Azure, pilih Dapatkan dukungan.