Condividi tramite


Errore AADSTS50020 durante l'accesso all'app sincronizzazione OneDrive

Sintomi

Non è possibile accedere all'app sincronizzazione Microsoft OneDrive e viene visualizzato il messaggio di errore seguente:

AADSTS50020'account utente dal provider di identità non esiste nel tenant e non può accedere all'applicazione (OneDrive SyncEngine).

Causa

Questo problema potrebbe essere causato dalle identità memorizzate nella cache del tenant precedente. In genere si verifica durante una migrazione da tenant a tenant.

Per altre informazioni su altre possibili cause, vedere Errore AADSTS50020 - L'account utente del provider di identità non esiste nel tenant.

Risoluzione

Per risolvere questo problema, rimuovere le identità dell'account di Microsoft Office memorizzate nella cache dal Registro di sistema.

Importante

Seguire attentamente i passaggi in questa sezione. L'errata modifica del Registro di sistema può causare seri problemi. Prima di apportare le modifiche, eseguire il backup del Registro di sistema per il ripristino nel caso si verifichino dei problemi.

  1. Avviare l'editor del Registro di sistema

  2. Individuare la voce del Registro di sistema seguente:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity

  3. Fare clic con il pulsante destro del mouse su Identità e quindi scegliere Elimina.

Nota: Se l'attivazione del computer condiviso è abilitata, rimuovere anche la voce del Registro di sistema Identity da HKEY_USERS\<The user SID>\SOFTWARE\Microsoft\Office\16.0\Common. Per ottenere il SID dell'utente attualmente connesso, eseguire il whoami /user comando in una finestra del prompt dei comandi. Se il problema persiste, espandere "Sezione A: Rimuovere le licenze di Office & account memorizzati nella cache" in Cancella manualmente le informazioni di attivazione precedenti e quindi seguire la procedura descritta in Parte 1: Rimuovere le attivazioni di Office precedenti e Parte 3: Rimuovere le credenziali di Office archiviate in Windows Credential Manager.

Se il problema persiste, seguire questa procedura:

  1. Disconnettersi da OneDrive for Business. 

  2. Rimuovere tutte le cartelle nei percorsi seguenti:

    • %localappdata%/Microsoft/OneAuth
    • %localappdata%/Microsoft/IdentityCache