予約使用率のトラブルシューティング

この記事は、Azure portal で Azure 予約の使用率がゼロ (0) と表示される問題とそのトラブルシューティングについて説明します。 使用率が一致しない件についても説明します。

現象

  1. Azure portal にサインインし、 [予約] に移動します。
  2. 予約の一覧で、 [使用率 (%)] 列の予約の使用率を確認します。 場合により、0% と示されていることがあります。
  3. 予約を選択します。
  4. 予約の概要ページで、グラフの使用率が予約一覧に表示されている値と一致しない場合があります。

原因

Azure portal の [使用率 (%)] 列には、現在の日付の値が表示されます。 値は、リソースが実行されている場所から使用状況データが到着したときに計算されます。 Azure では、この使用状況を使用して使用率が計算されます。

一部のリソースでは、他のリソースよりもゆっくりと使用状況が報告されます。 また、SQL データベースのような一部の製品の種類では、使用状況データを報告するのに時間がかかります。

待ち時間が原因で、使用率の計算で実際の使用量よりも低い値が表示されることがあります。 この違いは、日の境界で顕著になります。 このような場合、Azure では、4 から 8 時間の使用状況データが取得されないと、0% の値が計算されます。 使用状況データが到着しておらず、予約がどのリソースにもベネフィットを適用していないように見えるため、0% の値が表示されます。

使用状況データが到着すると、値は適切な割合に向かって変化します。 すべての使用状況データが収集されると、正しい値が求められ、グラフに正確に表示されます。

解決策

使用率の値が想定と一致しない場合は、グラフを確認して、実際の使用状況を把握してください。 2 日以上前のすべてのポイント値は正確であるはずです。 7 日から 30 日の長期平均は正確であるはずです。

その他の一般的なシナリオ

  • 予約の状態が "No Benefit" (特典なし) の場合、警告メッセージが表示されます。この問題を解決するには、予約のページに表示される推奨事項に従ってください。
  • リソース A の実行を停止し、リソース B の実行を開始した可能性があります。これは、購入した予約には適用されません。 この問題を解決するには、予約を交換して適切なリソースに一致させる必要があります。
  • 1 つのサブスクリプションまたはリソース グループから別のサブスクリプションまたはリソース グループにリソースを移動したが、予約のスコープがリソースの移動先と異なる場合があります。 この問題を解決するには、予約のスコープの変更が必要になることがあります。
  • 同じスコープに特典を適用する別の予約も購入し、その結果、既存の予約インスタンスのうち、特典が適用されるものが少なくなった可能性があります。 この問題を解決するには、予約の 1 つを交換または払い戻しする必要がある場合があります。
  • 特定のリソースの実行を停止し、その結果、使用状況の生成が停止し、適用が停止された可能性があります。 この問題を解決するには、予約を交換して適切なリソースに一致させる必要があります。
  • 予約のスコープを変更したため、リソースへの特典の適用が停止された可能性があります。 これを修正するには、予約のスコープをもう一度変更して、同じスコープにリソースがデプロイされるようにする必要があります。
  • 予約の対象となったサブスクリプションが削除または移動されたため、リソースには適用されていません。 これを修正するには、予約のスコープの変更が必要になることがあります。

次の手順