Configuration Manager のコンソール内更新プログラムをインストールする

Configuration Manager (現在のブランチ) に適用

この記事では、Configuration Manager コンソール内から更新プログラムをインストールする方法について説明します。 開始する前に、「 本体内アップデートをインストールする準備をする」を確認してください。

Configuration Manager コンソール内から更新プログラムをインストールする準備ができたら、階層の最上位サイトから始めます。 このサイトは、サーバーの全体管理サイト (CAS) またはスタンドアロンのプライマリ サイトのいずれかです。

ビジネス オペレーションへの影響を最小限に抑えるために、各サイトの通常の営業時間外に更新プログラムをインストールしてください。 更新プログラムのインストールには、サイト コンポーネントやサイト システムの役割の再インストールなどのアクションが含まれる場合があります。

  • CAS が更新プログラムのインストールを完了した後、子プライマリ サイトは自動的に更新を開始します。 このプロセスは既定で推奨されています。 プライマリ サイトが更新プログラムをインストールするタイミングを制御するには、 サイト サーバーのサービス ウィンドウを使用します。

  • プライマリ親サイトの更新が完了したら、Configuration Manager コンソール内からセカンダリ サイトを手動で更新します。 セカンダリ サイト サーバーの自動更新はサポートされていません。

  • サイトの更新後に Configuration Manager コンソールを使用すると、コンソールを更新するように求められます。

  • サイト サーバーが更新プログラムのインストールを正常に完了すると、該当するすべてのサイト システムの役割が自動的に更新されます。 ただし、すべての配布ポイントが再インストールされず、同時にオフラインになって更新します。 代わりに、サイト サーバーはサイトのコンテンツ配布設定を使用して、一度に配布ポイントのサブセットに更新プログラムを配布します。 その結果、一部の配布ポイントのみがオフラインになって更新プログラムをインストールします。 更新が開始されていない配布ポイントや更新が完了した配布ポイントはオンラインのままで、クライアントにコンテンツを提供できます。

インストールの開始

階層の最上位サイトの Configuration Manager コンソールで、[管理] ワークスペースに移動し、[Updates and Servicing] ノードを選択します。 状態が [使用可能] の更新プログラムを選択し、リボンの [Update Pack のインストール ] を選択します。

注:

ユーザー アカウントには、更新プログラムをインストールするためのアクセス許可が必要です。 詳細については、「 本体内更新のアクセス許可」を参照してください。

セカンダリ サイトで更新プログラムのインストールを開始する

親プライマリ サイトが更新された後、Configuration Manager コンソール内からセカンダリ サイトを更新します。

  1. Configuration Manager コンソールで、[管理] ワークスペースに移動し、[サイトの構成] を展開して、[サイト] ノードを選択します。 更新するセカンダリ サイトを選択し、リボンの [アップグレード] を選択します。

  2. セカンダリ サイトの更新を開始するには、[ はい ] を選択します。

セカンダリ サイトでの更新プログラムのインストールを監視するには、セカンダリ サイトを選択し、リボンで [インストール状態の表示 ] を選択します。 また、[サイト] ノードに [バージョン ] 列を追加して、各セカンダリ サイトのバージョンを表示できるようにします。

本体の状態が更新されないか、更新に失敗したと表示される場合があります。 セカンダリ サイトが正常に更新されたら、[ インストールを再試行 ] オプションを使用します。 このオプションでは、更新プログラムを正常にインストールしたセカンダリ サイトの更新プログラムは再インストールされませんが、本体では状態が強制的に更新されます。

インストール プロセス

1. 更新プログラムのインストールが開始されたとき

更新プログラムが適用される製品領域の一覧を表示する Updates ウィザードが表示されます。

  • ウィザードの [ 全般 ] ページで、必要に応じて [前提条件の警告] を構成します。

    • 前提条件のエラーにより、常に更新プログラムのインストールが停止されます。 更新プログラムのインストールを正常に再試行する前に、エラーを修正します。 詳細については、失敗したアップデートのインストールを再試行するを参照してください。

    • 前提条件の警告によって、更新プログラムのインストールが停止される可能性もあります。 更新プログラムのインストールを再試行する前に警告を修正します。 詳細については、失敗したアップデートのインストールを再試行するを参照してください。

    • 前提条件チェックの警告を無視し、不足している要件に関係なくこの更新プログラムをインストールします: 前提条件の警告を無視するように更新プログラムをインストールする条件を設定します。 このオプションを指定すると、更新プログラムのインストールを続行できます。 このオプションを選択しない場合、更新プログラムのインストールは警告で停止します。 以前に前提条件チェックを実行し、サイトの前提条件の警告を修正したことがある場合を除き、このオプションを使用しないでください。

      [管理] ワークスペースと [監視] ワークスペースの両方の [Updates and Servicing] ノードのリボンには、[前提条件の警告を無視する] という名前のボタンがあります。 このボタンは、前提条件のチェックの警告が原因で更新プログラム パッケージのインストールに失敗した場合に使用できます。 たとえば、前提条件の警告を無視するオプションを使用せずに更新プログラムをインストールします (Updates ウィザード内から)。 更新プログラムのインストールは、前提条件の警告の状態で停止しますが、エラーは発生しません。 後で、リボンの [前提条件の警告を無視する ] を選択します。 このアクションにより、前提条件の警告が無視される更新プログラムのインストールが自動的に続行されます。 このオプションを使用すると、更新プログラムのインストールは数分後に自動的に続行されます。

  • 更新プログラムが Configuration Manager クライアントに適用されている場合は、制限されたクライアント セットでクライアント更新プログラムをテストすることを選択します。 詳細については、「 実稼働前コレクションでクライアントのアップグレードをテストする方法」を参照してください。

  • Configuration Manager 2107 以降、Microsoft エンドポイント マネージャーにまだオンボードされていないサイトには、アップグレード ウィザードの一部として、オプションでクラウド アタッチを行うように求められます。 次の機能の少なくとも 1 つが既に有効になっている場合、環境はクラウド接続と見なされます。

    オンボードしない場合は、[Microsoft Intune 管理センターを有効にする] と [共同管理の自動クライアント登録を有効にする] オプションの両方をオフにします。

2. 更新プログラムのインストール中

更新プログラムのインストールの一環として、Configuration Manager は次のアクションを実行します。

  • サイト システムの役割や Configuration Manager コンソールなど、影響を受けるコンポーネントを再インストールします。

  • クライアントのパイロットと自動 クライアント アップグレードの選択に基づいて、クライアントの更新を管理します。

  • 通常、サイト システム サーバーは、更新の一部として再起動する必要はありません。 ロールが .NET を使用し、パッケージがその前提条件コンポーネントを更新すると、サイト システムが再起動されることがあります。 詳細については、「 サイトとサイト システムの前提条件」を参照してください。

ヒント

Configuration Manager の更新プログラムをインストールすると、サイトは CD.Latest フォルダーも更新します。 詳細については、 CD.Latest フォルダーを参照してください

3. インストール時に更新プログラムの進行状況を監視する

進行状況を監視するには、次の手順に従います。

  • Configuration Manager コンソールで、[管理] ワークスペースに移動し、[Updates and Servicing] ノードを選択します。 このノードには、すべての更新プログラム パッケージのインストールの状態が表示されます。

  • Configuration Manager コンソールで、[監視] ワークスペースに移動し、[Updates and Servicing Status] ノードを選択します。 このノードには、サイトがインストール中の現在の更新プログラム パッケージのインストール状態のみが表示されます。

    更新プログラムのインストールは、監視を容易にするためにいくつかのフェーズに分かれています。 次の各フェーズについて、インストール状態の詳細には、詳細を表示するログ ファイルが含まれます。

    • ダウンロード: このフェーズは、サービス接続ポイントがあるトップレベル サイトにのみ適用されます。

    • レプリケーション

    • 前提条件のチェック

    • インストール

    • インストール後: 詳細については、 インストール後のタスクを参照してください。

  • サイト サーバー上の <ConfigMgr_Installation_Directory>\LogsCMUpdate.logファイルを表示します。

注:

インストール フェーズでは、ConfigMgr データベースのアップグレード タスクの状態を確認できます。

  • データベースのアップグレードがブロックされると、"進行 中です。注意が必要です" という警告が表示されます。
    • cmupdate.log では、データベースのアップグレードをブロックしているSQL Serverのプログラム名と sessionid が記録されます。
  • データベースのアップグレードがブロックされなくなると、状態は [ 進行中 ] または [完了] にリセットされます。
    • データベースのアップグレードがブロックされると、5 分ごとにチェックが行われ、まだブロックされているかどうかを確認します。

4. 更新プログラムのインストールが完了した場合

最初のサイトの更新プログラムのインストールが完了したら、次の手順を実行します。

5. Configuration Manager コンソールを更新する

CAS またはプライマリ サイトが更新された後、サイトに接続する各 Configuration Manager コンソールも更新する必要があります。 本体を更新するように求めるメッセージが表示されます。

  • 本体を開いたとき

  • 開いているコンソールで新しいノードに移動すると、

サイトの更新後すぐに本体を更新します。

本体の更新が完了したら、本体とサイトのバージョンが正しいことを確認します。 コンソールの左上隅にある [Configuration Manager について] に移動します。

注:

本体版はサイト版と若干異なります。 コンソールのマイナー バージョンは、Configuration Manager のリリース バージョンに対応します。 たとえば、Configuration Manager バージョン 2303 では、初期サイト バージョンは 5.0.9122.1000 で、初期コンソール バージョンは 5 です。9122.1082.1700. ビルド (1082) およびリビジョン (1700) の番号は、今後の修正プログラムによって変更される可能性があります。

次の手順

サイトの更新後に何が起こるか、または更新が失敗した場合の対処方法については、引き続きお読みください。