現象
Microsoft OneDrive にサインインしようとすると、サインインできません。次のエラー メッセージが表示されます。
このサービスにアクセスすることはできません。 詳細については、IT 部門にお問い合わせください。 (エラー コード: 0x8004deef)
原因
この問題は、ライセンスの不足や資格情報の不一致など、OneDrive アカウントに問題がある場合に発生する可能性があります。
解決方法
この問題を解決するには、次の方法を試してください。
方法 1: アカウントに有効なライセンスが割り当てられていることを確認する
Organizationがユーザー向けに OneDrive を購入した方法によっては、OneDrive ライセンスが割り当てられていないか、ライセンスの有効期限が切れている可能性があります。
メモ:次の手順は、organizationの Microsoft 365 管理者が完了する必要があります。
- Microsoft 365 管理センターで、[ユーザー] [アクティブ なユーザー] の順に選択します>。
- 問題が発生しているユーザーを選択します。
- ユーザー ウィンドウで、[ ライセンスとアプリ] を選択します。
- [ライセンス] セクション を 展開し、OneDrive ライセンスがユーザーに割り当てられていることを確認します。
注:
複数のユーザーに問題が発生した場合は、サブスクリプションの有効期限が切れている可能性があることを意味します。 サブスクリプションの状態をチェックするには、Microsoft 365 管理センターを開き、[製品の課金>] を選択します。
方法 2: キャッシュされたアカウント ID を削除する
重要
このセクションの手順の実行には注意が必要です。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 変更する前に、問題の発生に備えて復元用にレジストリのバックアップを作成してください。
レジストリ エディターを起動します。
次のレジストリ サブキーを見つけます。
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity
[ID] を右クリックし、[削除] を選択します。
注:
共有コンピューターのアクティブ化を有効にしている場合は、次のレジストリ サブキーも削除します。
HKEY_USERS\<user_SID>\SOFTWARE\Microsoft\Office\16.0\Common\Identity
現在サインインしているユーザーの SID を取得するには、コマンド プロンプトでコマンドを実行 whoami /user
します。 問題が解決しない場合は、[ 以前のアクティブ化情報を手動でクリアする] に移動し、[セクション A: キャッシュされたアカウント & Office ライセンスを削除する] を展開し、「パート 1: 以前の Office ライセンス認証を削除する」および「パート 3: Windows 資格情報マネージャーに格納されている Office 資格情報を削除する」の手順に従います。
それでも問題が解決しない場合は、次の手順に従って、キャッシュされた資格情報を含むフォルダーを削除します。
OneDrive からサインアウトします。
次のフォルダー内のすべてのサブフォルダーを削除します。
- %localappdata%/Microsoft/OneAuth
- %localappdata%/Microsoft/IdentityCache