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AksCapacityHeavyUsage エラー コードのトラブルシューティング

この記事では、Microsoft Azure Kubernetes Service (AKS) クラスターの作成時に発生する可能性がある AksCapacityHeavyUsage エラーを特定して解決する方法について説明します。

症状

AKS クラスターを作成しようとすると、次のエラー メッセージが表示されます。

コード: AksCapacityHeavyUsage

メッセージ: AKS では、リージョン <Region> で大量の使用量が発生しています。 新しい容量の追加に取り組んでいます。 それまでの間は、別のリージョンに新しい AKS クラスターを作成することを検討してください。 すべての Azure リージョンの一覧については、 https://aka.ms/aks/regionsを参照してください。 このエラーの詳細については、 https://aka.ms/akscapacityheavyusageを参照してください。

原因

容量が限られているリージョンにクラスターを作成しようとしています。

AKS クラスターを作成すると、Microsoft Azure によってコンピューティング リソースがサブスクリプションに割り当てられます。 特定のリージョンで Azure Kubernetes Service の需要が大幅に増加するため、 AksCapacityHeavyUsage エラーが発生することがあります。

KubernetesAPICallFailed エラー メッセージは、AKS クラスターが起動せず、コントロール プレーンが関連付けられていないことを示します。 そのため、API サーバーの呼び出しは失敗します。 この場合は、開始操作を再試行する必要があります。

解決策

解決策 1: 別のリージョンを選択する

最も簡単で迅速なソリューションは、別のリージョン (たとえば、WestEurope ではなく NorthEurope、カタールセントラルではなく UAENorth) にデプロイすることです。 近くのリージョンを検索するには、 Azure の [地域] ページを参照してください。

要求されたリージョンに既存のリソースが既にある場合、このアプローチは実現できない可能性がありますが、開発/テスト シナリオで推奨されるソリューションです。

解決策 2: 設定が異なるクラスターをデプロイする

AKS で管理されるクラスターをホストするインフラストラクチャには、割り当て予約が異なります。 そのため、AKS のパブリック クラスターの容量は、プライベート クラスターの容量よりも多い場合があります。 プライベート クラスターを作成しようとしたときに AksCapacityHeavyUsage エラーが発生した場合は、代わりにパブリック クラスターを作成してみてください (またはその逆も同様)。

解決策 3: Azure Enterprise サブスクリプションを使用する

容量が不足している場合、実際の運用シナリオ用にリソースを予約するために、AKS クラスターの作成時に非 Enterprise Agreement (EA) サブスクリプションが最初に制限されます。 EA サブスクリプションをお持ちの場合は、EA サブスクリプションを使用して AKS クラスターを作成してください。

解決策 4: 操作を再試行する

容量は、多くの場合、他のユーザーが AKS クラスターを停止または削除すると回収されます。 そのため、後で再試行すると、操作が成功する可能性があります。

詳細情報

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。