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Windows Stop エラー - 0xC000021A状態システム プロセスが終了しました

この記事では、オペレーティング システム (OS) でエラー コードの0xC000021Aが発生する問題を解決する手順について説明します。 このエラーにより、Azure 仮想マシン (VM) が再起動できなくなります。

現象

ブート 診断を使用して VM のスクリーンショットを表示すると、再起動中に OS でエラーが発生したことを示す次のメッセージが表示されます。

問題が発生したため、PC を再起動する必要があります。 エラー情報を収集しています。再起動できます。 (##% complete)詳細を知りたい場合は、後でオンラインでこのエラーを検索できます:0xC000021a。

エラー コードの停止: #0xC000021A と

原因

エラー 0xC000021AはSTATUS_SYSTEM_PROCESS_TERMINATEDを意味 します

このエラーは、Winlogon (winlogon.exe) やクライアント サーバー Run-Time サブシステム (csrss.exe) などの重要なプロセス失敗したときに発生します。 カーネルは、これらのサービスのいずれかが停止したことを検出すると、 STOP 0xC000021A エラー コードを返します。 このエラーには、次のようないくつかの原因が考えられます。

  • 一致しないシステム ファイルがインストールされました。
  • Service Pack または KB 更新プログラムのインストールに失敗しました。
  • ハード ディスクを復元するために使用されるバックアップ プログラムが、使用中のファイルを正しく復元できませんでした。
  • 互換性のないサード パーティ製プログラムがインストールされました。

解決策 1: バックアップから VM を復元する

VM の最近のバックアップがある場合は、バックアップ から VM を復元 して再起動の問題を解決できます。

解決策 2: メモリ ダンプ ファイルを収集する

バックアップを復元しても問題が解決しない場合は、クラッシュを分析できるようにメモリ ダンプ ファイルを収集します。 ダンプ ファイルを収集するには、次のセクションを参照してください。

パート 1: OS ディスクを復旧 VM に接続する
  1. 影響を受ける VM の OS ディスクのスナップショットを作成してバックアップを作成します。 詳細については、「仮想ハード ディスクのスナップショットをCreateする」を参照してください。

  2. 復旧 VM に OS ディスクを接続します

  3. リモート デスクトップ プロトコル (RDP) を使用して、復旧 VM にリモート接続します。

  4. 影響を受ける VM の OS ディスクが暗号化されている場合は、次の手順に進む前に暗号化をオフにします。 詳細については、「 暗号化された OS ディスクの暗号化を解除する」を参照してください。

パート 2: ダンプ ファイルを見つけてサポート チケットを送信する
  1. 復旧 VM で、接続されている OS ディスク上の Windows フォルダーに移動します。 たとえば、接続されている OS ディスクに割り当てられているドライブ文字が F の場合は、 F:\Windows に移動します。

  2. Memory.dmp ファイルを見つけて、サポート チケットを送信し、ダンプ ファイルを添付します。

注:

Memory.dmp ファイルの検索で問題が発生した場合は、代わりにシリアル コンソールでマスク不可割り込み (NMI) 呼び出しを使用してみてください。 このガイダンスを使用して、NMI 呼び出しを使用してクラッシュ ダンプ ファイルを生成できます。

次の手順

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