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Outlook 用 Dynamics 365 アプリにアクセスするときの "サインイン中に問題が発生しました" というエラー

適用対象: Dynamics 365 App for Outlook
元の KB 番号: 3064194、4035750

この記事では、Microsoft Dynamics 365 App for Outlookアクセスするときに発生する可能性がある次のサインイン エラーの解決策について説明します。

エラー 1

デスクトップ、Web、またはモバイルで Outlook を使用しているときに Dynamics 365 App for Outlook を開こうとすると、次のエラー メッセージが表示されることがあります。

サインイン中に問題が発生しました。 もう一度お試しください。 この問題が解決しない場合は、システム管理者にお問い合わせください。

原因 1

Dynamics 365 App for Outlook は、このアプリの使用が承認されていることを確認するために承認サービスに接続できません。

解像度

この問題を解決するには、まずアプリを閉じてから再度開いてみてください。 問題が解決しない場合は、インターネット ブラウザーを閉じてから再度開いてみてください。 問題が解決しない場合は、次のオプションを試して、Dynamics 365 で使用される URL と認証 URL が同じ整合性レベルを使用していることを確認します。

オプション 1 - 各 Dynamics 365 URL と認証 URL を Internet Explorer の同じセキュリティ ゾーンに追加する
  1. Internet Explorer で、[ツール] > [インターネット オプション] を選びます。

  2. [セキュリティ] タブを選択し、Trusted Sites ゾーンを選択し、[サイト] 選択します

  3. この Web サイトをゾーンに追加、一度に次の URL を入力します。

    *.dynamics.com
    *.microsoftonline.com
    https://login.windows.net

    重要

    フェデレーション認証を使用して会社の資格情報を使用して Dynamics 365 にアクセスする場合は、会社で使用される認証 URL も追加する必要があります。 たとえば、の認証 URL でhttps://adfs.contoso.com/...を使用している場合は、この URL を同じゾーンに追加するか、両方のゾーンに同じ保護モード設定があることを確認します。

  4. [追加] を選択し、OK を選択してサイトを保存します。

オプション 2 - 各 Internet Explorer セキュリティ ゾーンで保護モードを有効にする

各 Internet Explorer セキュリティ ゾーンで保護モードを有効にすると、各 URL が同じ整合性レベルで読み込まれます。

  1. Internet Explorer で、[ツール] > [インターネット オプション] を選びます。
  2. [セキュリティ] タブを選択します。
  3. 各ゾーン (Internetローカル イントラネット、および 信頼済みサイト) を選択します。
  4. 各ゾーンを選択しているときに、 [保護モードを有効にする ] チェック ボックスがオンになっていることを確認します。
  5. [OK] を選択して [インターネット オプション] ダイアログ ボックスを閉じます。

注:

セキュリティ ゾーンで保護モードが有効になっている場合、URL は低整合性レベル (最も安全) で読み込まれます。 セキュリティ ゾーンで保護モードが無効になっている場合、URL は中程度の整合性レベルで読み込まれます。 URL が Trusted Sites または Local Intranet ゾーンに追加されていない場合、既定では保護モードが有効になっているインターネット ゾーンへの読み込みが行われます。

原因 2

この問題は、Dynamics 365 App for Outlook のインストール後に Dynamics 365 (オンライン) URL が変更された場合に発生する可能性があります。 たとえば、アプリを展開するときに Dynamics 365 の URL が https://contosocorp.crm.dynamics.com されているが、後で URL を https://contoso.crm.dynamics.com に変更する場合です。

これが問題の原因であるかどうかを確認するには、エラー メッセージの Help me resolve this issue リンクを右クリックし、URL を確認します。 URL が現在の Dynamics 365 URL ではなく古い URL である場合は、それがエラーの原因である可能性があります。

解決

Dynamics 365 App for Outlook のインストール後に Dynamics 365 (オンライン) URL を変更する場合は、アプリを再デプロイする必要があります。

  1. システム管理者ロールを持つユーザーは、Dynamics 365 Web アプリケーションを開き、Settings 内の Dynamics 365 App for Outlook 領域に移動することで、アプリをユーザーに再デプロイできます。

  2. アプリを再デプロイする必要があるユーザーを選択し、 [アプリの追加 ] ボタンのいずれかを使用してアプリを再デプロイします。

  3. Status Outlook に追加に変わったら、問題が解決されたかどうかを確認できます。 既にアプリを開いている場合は、アプリを閉じて再度開きます。

エラー 2

デスクトップで Outlook を使用しているときに Dynamics 365 App for Outlook を開こうとすると、次のエラー メッセージが表示されることがあります。

サインインに問題がありますか?
サインイン中に問題が発生しました。 信頼済みサイトに次の URL を追加してみてください。
https://*.dynamics.com
https://login.microsoftonline.com
この問題が解決しない場合は、システム管理者にお問い合わせください。

原因

Dynamics 365 App for Outlook を使用するために必要な一部の URL は、 Internet Explorer セキュリティ ゾーン (ローカル イントラネット ゾーン、信頼済みサイト ゾーン、インターネット ゾーンなど) に存在します。

デスクトップ上の Outlook 内で Dynamics 365 App for Outlook を使用する場合、Internet Explorer を使用してコンテンツが表示され、必要に応じて認証にリダイレクトされます。 保護モードがゾーンに対して有効になっているかどうかに応じて、異なるセキュリティ ゾーンで異なる整合性レベルが使用される場合があります。 異なる URL が異なる整合性レベルで読み込まれると、認証 URL から Dynamics 365 に認証が正常に渡されなくなります。

解決

この問題を解決するには、次のいずれかのオプションを使用して、Dynamics 365 で使用される URL と認証 URL で同じ整合性レベルが使用されるようにします。