この記事では、ユーザーが Microsoft Copilot for Sales からレコードを作成しようとしたときに発生するエラー メッセージの解決策について説明します。
要件タイプ | Description |
---|---|
クライアント アプリ | Copilot for Sales Outlook アドイン |
プラットフォーム | Web およびデスクトップ クライアント |
OS | Windows および Mac |
展開 | ユーザー管理と管理者管理 |
CRM | Dynamics 365 および Salesforce |
ユーザー | Copilot for Sales から CRM レコードを作成しようとするユーザー |
現象
ユーザーが Copilot for Sales から CRM に新しいレコードを 作成しようとすると次のエラーが表示されます。 CRM の 重複しない検出ルールが原因でレコードの作成が失敗したことを示します。
この連絡先は既に存在します。 重複する連絡先を作成するには、Salesforce で連絡先を追加してみてください。
原因
CRM の重複検出ルールは、特定のフィールドに複数のレコード間で重複する値が含まれるのを防ぐために構成されています。 ユーザーが Copilot for Sales の重複フィールドを含むレコードを作成しようとすると、CRM の重複検出ルールによってレコードが作成されなくなります。
たとえば、既存のレコードと同じ電子メール アドレスを持つレコードが作成されないように重複検出ルールが構成されている場合、新しいレコードの電子メール アドレスが既存のレコードのメール アドレスと一致すると、レコードの作成は失敗します。
解決方法
エラーを解決するには、次のいずれかの方法を使用します。
- エラーの原因となったフィールドに別の値を指定して、レコードをもう一度作成します。 たとえば、新しいレコードの電子メール アドレスが既存のレコードのメール アドレスと一致するため、エラーが発生した場合は、別の電子メール アドレスでレコードを再作成します。
- CRM の重複検出ルールを変更して、エラーの原因となったフィールドの重複値を許可するように管理者に依頼します。
CRM の重複検出ルールの詳細については、以下を参照してください。
- Dynamics 365: データをクリーンに保つために重複検出ルールを設定する
- Salesforce: Duplicate ルール
詳細
問題がまだ解決しない場合は、 Copilot for Sales - Microsoft Community Hub にアクセスして、エキスパートと交流してください。
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