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Salesforce CRM への接続時の認証の問題

この記事は、 Microsoft Copilot for Sales アドイン for Outlook から Salesforce CRM に接続するときの認証の問題のトラブルシューティングと解決に役立ちます。

誰が影響を受けますか?

要件タイプ Description
クライアント アプリ Copilot for Sales Outlook アドインと Teams アプリ
プラットフォーム Web およびデスクトップ クライアント
OS Windows および Mac
展開 ユーザー管理と管理者管理
CRM セールスフォース
ユーザー Salesforce CRM にサインインしようとしているユーザー

現象

Outlook 用 Copilot for Sales アドインから Salesforce CRM にサインインしようとすると、次のエラー メッセージが表示されます。

リダイレクト URL に渡されたエラー。 error=OAUTH_APP_ACCESS_DENIED error_description=user は、このアプリへのアクセスが管理者によって承認されていません

認証エラーを示すスクリーンショット。

原因

Microsoft Power Platform 接続アプリのポリシーにより、ユーザーが Salesforce CRM に接続できなくなります。

Copilot for Sales は、Microsoft Power Platform に接続されたアプリを介して Salesforce CRM に接続します。 Copilot for Sales から Salesforce CRM にサインインするには、ユーザーが代わりに Salesforce CRM に連絡するために Microsoft Power Platform アプリに同意する必要があります。 同意できない場合、サインイン プロセスは失敗します。

解決方法

Copilot for Sales では、Microsoft Power Platform に接続されたアプリを使用して Salesforce CRM に接続します。 Microsoft Power Platform アプリのポリシーが、ユーザーが Salesforce CRM に接続できるように構成されていることを確認します。

  1. Salesforce CRM に管理者としてサインインします。

  2. 設定>プラットフォーム ツール>アプリ>接続されたアプリ>マネージドの接続されたアプリ の順に移動します。

  3. 接続アプリ ページで、Microsoft Power Platform を選択します。

    [接続済みアプリ] ページを示すスクリーンショット。

  4. ポリシーの編集 を選択します。

  5. OAuth ポリシー で、許可されたユーザー の次のいずれかの値を選択します:

    許可されたユーザーの値を示すスクリーンショット。

    1. すべてのユーザーが自己承認できます: このオプションでは、認証された Salesforce ユーザーが、Microsoft Copilot for Sales、Microsoft Power Automate、および他のアプリで使用される Microsoft Power Platform コネクタを介して Salesforce インスタンスに接続し、Salesforce にアクセスできる可能性があるため、問題を解決できます。

    2. 管理者が承認したユーザーは事前に承認されています: このオプションを使用すると、管理者は ProfilesPermission Sets を通じて個々のユーザーにアクセス許可を明示的に付与できます。 詳細については、「接続されたアプリと接続済みアプリへのアクセスの管理を参照してください。

      [プロファイル] セクションと [アクセス許可セット] セクションを示すスクリーンショット。

  6. [保存] を選択します。

詳細

問題がまだ解決しない場合は、 Copilot for Sales - Microsoft Community Hub にアクセスして、エキスパートと交流してください。

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