Share via


サード パーティの印刷ドライバーをインストールまたはアップグレードした後、印刷スプーラーのエラー メッセージが表示される

この記事では、サード パーティの印刷ドライバーをインストールまたはアップグレードした後に発生する印刷スプーラーのエラーを修正するための解決策について説明します。

適用対象: Windows 10 - すべてのエディション、Windows Server 2012 R2
元の KB 番号: 2793718

現象

Windows ベースのクライアント コンピューターで、次のいずれかの現象が発生する場合があります。

  • サード パーティの印刷ドライバーのインストールまたはアップグレード中に、次のエラー メッセージが表示される場合があります。

    • 操作が失敗しました (エラー0x00000057)
    • プリンター ドライバーをインストールしませんでした。 操作を完了できませんでした (エラー 0x00000057)
    • 操作が失敗しました (エラー 0x000005b3)
    • 操作を完了できませんでした (エラー 0x00000bc4)。 プリンターが見つかりませんでした。
    • プリンターへ接続できませんでした。 操作を完了できませんでした (エラー 0x00000002)
  • 印刷スプーラー サービスを開始または停止しようとすると、次のエラー メッセージが表示される場合があります。

    スプーラー サブシステム アプリケーションでエラーが発生したため終了します

  • [スタート] をクリックし、Windows XP では [プリンターと FAX]、Windows Vista 以降では [デバイスとプリンター] をクリックすると、次のエラー メッセージが表示される場合があります。

    スプーラー サブシステム アプリケーションでエラーが発生したため終了します

  • [スタート] をクリックし、Windows XP では [プリンターと FAX]、Windows Vista 以降では [デバイスとプリンター] をクリックしてプリンターを表示しようとしても、プリンターが表示されません。 この問題は、プリンターがインストールされている場合でも発生することがあります。

原因

これらの問題は、サード パーティのプリンター ドライバーまたはサービスが既存または新しくインストールされたプリンターの機能に影響を与える場合に発生する可能性があります。

解決方法

印刷スプーラーをクリアしてリセットするには、次の手順を実行します。

  1. タスク バーの検索ボックスに「サービス」と入力し、結果の一覧で [サービス] を選択します。
  2. [標準] タブを選択し、サービスの一覧で [印刷スプーラー] をダブルクリックします。
  3. [停止]、[OK] の順に選択します。
  4. タスク バーの検索ボックスに「%WINDIR%\system32\spool\printers」と入力し、結果の一覧で [%WINDIR%\system32\spool\PRINTERS] を選択して、フォルダー内のすべてのファイルを削除します。
  5. タスク バーの検索ボックスでサービスを検索し、結果の一覧で [サービス] を選択します。
  6. [標準] タブを選択し、サービスの一覧で [印刷スプーラー] をダブルクリックします。
  7. [スタート] を選択し、[スタートアップの種類] ボックスで [自動] を選択して、[OK] を選択します。

データ収集

Microsoft サポートからの支援が必要な場合は、「 TSS for User Experience の問題を使用した情報の収集」に記載されている手順に従って情報を収集することをお勧めします。