次の方法で共有


サード パーティの印刷ドライバーをインストールまたはアップグレードした後に、印刷スプーラーのエラー メッセージが表示される

この記事では、サード パーティの印刷ドライバーをインストールまたはアップグレードした後に発生する印刷スプーラー エラーを修正するソリューションを提供します。

元の KB 番号: 2793718

現象

Windows ベースのクライアント コンピューターでは、次のいずれかの現象が発生する可能性があります。

  • サード パーティの印刷ドライバーのインストールまたはアップグレード中に、次のエラー メッセージが表示される場合があります。

    • エラー 0x00000057で操作に失敗しました
    • プリンター ドライバーがインストールされていません。 操作を完了できませんでした (エラー 0x00000057)
    • エラー 0x000005b3で操作に失敗しました
    • 操作を完了できませんでした (エラー 0x00000bc4)。 プリンターが見つかりませんでした。
    • Windows はプリンターに接続できません。 操作を完了できませんでした (エラー 0x00000002)
  • 印刷スプーラー サービスを開始または停止しようとすると、次のエラー メッセージが表示されることがあります。

    スプーラー サブシステム アプリで問題が発生し、終了する必要がある

  • [Start] をクリックし、Windows XP で [プリンターと FAX] をクリックするか、Windows Vista 以降で [デバイスとプリンター ] をクリックすると、次のエラー メッセージが表示される場合があります。

    スプーラー サブシステム アプリでエラーが発生し、閉じる必要がある

  • [ スタート] をクリックし、Windows XP で [プリンターと FAX] をクリックするか Windows Vista 以降の Devices and Printers をクリックしてプリンターを表示しようとすると、プリンターは表示されません。 この問題は、プリンターがインストールされている場合でも発生する可能性があります。

原因

これらの問題は、サードパーティのプリンター ドライバーまたはサービスが既存のプリンターまたは新しくインストールされたプリンターの機能に影響を与える場合に発生する可能性があります。

解決方法

印刷スプーラーをクリアしてリセットするには、次の手順に従います。

  1. タスク バーの検索ボックスに「 services」と入力し、結果の一覧で Services を選択します。
  2. [標準] タブを選択し、サービスの一覧で印刷スプーラーをダブルクリックします。
  3. Stop を選択し、OK を選択します。
  4. タスク バーの検索ボックスに「 %WINDIR%\system32\spool\printers」と入力し、結果の一覧で %WINDIR%\system32\spool\PRINTERS を選択し、フォルダー内のすべてのファイルを削除します。
  5. タスク バーの検索ボックスでサービスを検索し、結果の一覧で Services を選択します。
  6. [標準] タブを選択し、サービスの一覧で印刷スプーラーをダブルクリックします。
  7. Startを選択し、Startup の種類 ボックスで Automatic を選択し、OK を選択します。

データ コレクション

Microsoft サポートからのサポートが必要な場合は、ユーザー エクスペリエンスの問題に TSS を使用して、 Gather 情報に記載されている手順に従って情報を収集することをお勧めします