この記事では、印刷中に発生する可能性がある新しい一般的な問題について説明し、それらの問題に対して考えられる解決策についても説明します。
これらのデバイスでスマート カード認証を使用すると、印刷とスキャンが失敗する可能性があります
環境内のドメイン コントローラーに KB5004237 をインストールすると、スマート カード (PIV) 認証を使用するときに、一部のプリンター、スキャナー、多機能デバイスが印刷されないことがあります。
解決方法
この問題の詳細については、「 KB5005408 - スマート カード認証によって印刷とスキャンが失敗する可能性があるを参照してください。
特定のプリンターが USB 経由で印刷できない
KB5003690以降の更新プログラム (帯域外更新プログラムのKB5004760やKB5004945を含む) をインストールした後、特定のプリンターに印刷しようとすると問題が発生する可能性があります。 さまざまなブランドやモデルが影響を受けます。主に、USB 経由で接続するレシート プリンターまたはラベル プリンターです。
解決方法
この問題は、 Known Issue Rollback (KIR)によって解決されます。 この問題は、CVE-2021-34527 または CVE-2021-1675 には関連しません。
Windows 印刷スプーラーのリモート コード実行の脆弱性
July 6、2021 -KB5004945 (OS ビルド 19041.1083、19042.1083、および 19043.1083) の帯域外更新プログラム以降の Windows 更新プログラムをインストールすると、管理者ではないユーザーは、署名された印刷ドライバーのみをプリント サーバーにインストールできます。 既定では、管理者は署名済みおよび署名なしの両方のプリンター ドライバーをプリント サーバーにインストールできます。 システムの信頼されたルート証明機関によって署名されたドライバーにインストールされたルート証明書。
解決方法
詳細については、「 KB5005010: 2021 年 7 月 6 日の更新プログラムを適用した後の新しいプリンター ドライバーのインストールを制限するを参照してください。
コンピューターに接続されているプリンターが印刷されない
原因
物理プリンター、印刷ドライバー、プリント サーバー、または印刷するアプリケーションに問題が存在する可能性があります。
解決方法
問題を特定して解決するには、次の手順を試してください。
- 物理プリンターが準備完了状態であり、正しい既定のプリンターが設定されていることを確認します。
- テスト ページを印刷してみてください。
- (PostScript 以外のプリンターでのみ) コマンド ラインから印刷してみてください。 コマンド プロンプトで「
Dir > LPT1
」と入力します。 - メモ帳などのテキスト エディターから印刷してみてください。 印刷に成功すると、プリンター ドライバーが正しいことと、アプリケーションによって問題が発生したことが確認されます。 メモ帳から印刷できない場合、問題はプリンター ドライバーによって発生します。
- システム ドライブで使用可能なディスク領域を確認します。 ジョブをスプールするための十分なスペースがない場合、小さいジョブでは失敗しない場合でも、大きなジョブが失敗する可能性があります。
ネットワークに接続されているプリンターが印刷されない
原因
物理プリンター、クライアント コンピューターの論理プリンター設定、印刷するアプリケーション、ネットワーク プロトコル、またはハードウェアに問題が存在する可能性があります。
解決方法
問題を特定して解決するには、次の方法を試してください。
- 基本的なネットワーク接続を確認します。 ユーザー権限、プロトコル、共有名などを確認して、サーバーを表示できるかどうかを判断します。 ファイルをサーバーにコピーしてみてください。 サーバーにアクセスできない場合は、プリンターにアクセスできない可能性があります。
- [ Advanced タブで、プリンターの使用時間が正しいことを確認します。
- ローカル プリンターを作成し、ポートをネットワーク サーバーにリダイレクトします。 プリンターの追加ウィザードを使用してローカルを選択し、プリンターのサーバー名とプリンター名を入力します (\\<servername>\<printername>)。 これにより、プリント サーバーからファイルをコピーできるかどうかが決まります。
- プリント サーバーで使用可能なディスク領域を確認します。 ジョブをスプールするための十分なスペースがない場合、小さいジョブでは失敗しない場合でも、大きなジョブが失敗する可能性があります。
アプリケーション内からプリンターを構成しようとすると、アクセス拒否メッセージが表示される
原因
プリンターの構成を変更するための適切なアクセス許可がありません。
解決方法
プリンターのセットアップを変更するには、プリンターの管理権限が必要です。
ドキュメントが完全に印刷されないか、文字化けして表示される
原因
プリンターのドライバーが破損しているか、正しくありません。
解決方法
クライアント コンピューターで適切なプリンター ドライバーを確認または再インストールします。
ハード ディスクの問題が発生し、ドキュメントがプリント サーバーに到達しない
原因
ハード ディスクに、ドキュメントをスプールするための十分な領域がない可能性があります。
解決方法
ハード ディスクに十分なディスク領域があることを確認するか、スプール フォルダーを別のボリュームに再配置します。
プリント サーバー上のドキュメントは印刷されないため、削除できません
原因
印刷スプーラーがストールしている可能性があります。
解決方法
プリント サーバーで、印刷スプーラー サービスを停止して再起動してみてください。
ドライバーが表示されない
解決方法
Windows プリンター ドライバーは、Microsoft と印刷デバイスを製造する独立系ハードウェア ベンダーとの協力によって開発されています。 新しいプリンター ドライバーと更新されたプリンター ドライバーについては、「 最新のプリンター ドライバーをダウンロードしてインストールする方法で Microsoft の印刷サポートを参照してください Windows Update。
インターネットからダウンロードした新しい印刷ドライバーをインストールする必要があります
原因
印刷ドライバーは、 プリンターの追加ウィザード プリンターの一覧には表示されませんが、インターネットからダウンロードされました。
解決方法
- プリンター ドライバーを空のフォルダーにダウンロードします。
- 実行可能ファイルの名前を入力し、その後に
-d
スイッチを入力して、ファイルを展開します。 たとえば、ファイルの名前が Nt4prn.exeされている場合は、コマンド プロンプトで次のコマンドを入力します:nt4prn -d
。 - Readme.txtファイルとLicense.txt ファイルを読み取る。
- Start ボタンを選択し、Settings>Devices>Printers & scanners を選択します。
- 右側の [関連する設定で、[サーバーのプロパティ印刷] を選択。
- [ Drivers ] タブで、プリンターが表示されているかどうかを確認します。 設定されている場合は、すべて設定されます。
- プリンターが一覧に表示されない場合は、[追加] を選択し、プリンター ドライバーの追加ウィザードの [次へを選択します。
- [ プロセッサの選択 ] ダイアログ ボックスで、デバイスのアーキテクチャを選択し、[次へ ] を選択。
- [ プリンター ドライバーの選択 ] ダイアログ ボックスで、[ディスク 動作] を選択しし、[ [参照] ボタンを選択します。
- 手順 1 でドライバーをダウンロードしたフォルダーをポイントし、指示に従ってドライバーを追加します。
プリンターの場所の追跡が有効になっている場合でも、一部のプリンターを見つけられない
原因
プリンターの場所の追跡を有効にすると、既定の動作では、場所属性が名前付け規則に一致するプリンターのみがユーザーに見つかります。
解決方法
このプリンターの場所の文字列をもう一度設定します。 これを行う方法については、「 プリンターの場所の追跡の有効化」を参照してください。
会社が組織を変更したため、名前付けスキームを変更する必要があります
解決方法
Active Directory サイトとサービスを使用して、サイトとサブネットを更新します。 次に、組織内の影響を受けるプリンターのすべてのプリンターの場所フィールドを更新する必要があります。 Active Directory サービス インターフェイス (ADSI) スクリプトを作成して、更新を迅速化できます。
組織にはサブネットのない小規模なネットワークがある
解決方法
Active Directory は、サブネットが関連付けられていないと、ディレクトリのツリー内のノードを見つけることができません。 組織が十分に小さい場合、ユーザーは組織内の任意のプリンターを検索できるため、この状況は問題になりません。 ただし、多数のプリンターを持つ大規模な組織や組織の場合でも、ユーザーがプリンターを見つけるための支援として場所階層を参照できます。 これを行うには、作成する階層に対応する人工サブネットを Active Directory に作成する必要があります。
データ コレクション
Microsoft サポートからのサポートが必要な場合は、ユーザー エクスペリエンスの問題に TSS を使用して、 Gather 情報に記載されている手順に従って情報を収集することをお勧めします。