チュートリアル: アプリケーションを構築する

適用対象:yesVisual Studio noVisual Studio for Mac noVisual Studio Code

この記事では、Visual Studio を使用してアプリケーションをビルドする場合に構成できるいくつかのオプションについて理解を深めます。 サンプル アプリケーション用に、カスタムのビルド構成の作成、特定の警告メッセージの非表示設定、ビルド出力情報の拡張を行います。

サンプル アプリケーションをインストールする

このチュートリアルで使われているサンプル コードは、WPF サンプルにあります。 リポジトリをクローンするには、GitHub の緑色の [Clone](クローン) ボタンを使って、[Clone in Visual Studio](Visual Studio でクローン) を選びます。 ローカル ハード ドライブ上で、リポジトリの内容のコピーを作成する場所を選ぶことができます。 リポジトリには多くのソリューションが含まれています。 Visual Studio でソリューションのいずれかを開いている場合は、ソリューションを閉じてから、[プロジェクトを開く] または [ソリューションを開く] を選び、リポジトリをクローンした場所を参照し、その下で、GettingStarted/WalkthroughFirstWPFApp/csharp/ExpenseItIntro.sln (C# の場合) または GettingStarted/WalkthroughFirstWPFApp/vb/ExpenseItIntro2.sln (Visual Basic の場合) を見つけます。

カスタム ビルド構成を作成する

ソリューションを作成すると、デバッグおよびリリースのビルド構成と、それらの既定のプラットフォーム ターゲットが、ソリューションに対して自動的に定義されます。 これらの構成をカスタマイズすることも、独自に作成することもできます。 ビルド構成では、ビルドの種類を指定します。 ビルド プラットフォームでは、その構成でアプリケーションが対象とするオペレーティング システムを指定します。 詳細については、「ビルド構成について」、「ビルド プラットフォームについて」、「方法: デバッグ構成とリリース構成を設定する」を参照してください。

[構成マネージャー] ダイアログ ボックスを使用すると、構成とプラットフォームの設定を変更または作成できます。 この手順では、テスト用のビルド構成を作成します。

ビルド構成を作成する

  1. [構成マネージャー] ダイアログ ボックスを開きます。

    [ビルド] メニュー、[構成マネージャー] コマンドのスクリーンショット。

    [ビルド] メニュー [構成マネージャー] コマンドのスクリーンショット。

  2. [アクティブ ソリューション構成] の一覧で、 [<新規作成...>] をクリックします。

  3. [新しいソリューション構成] ダイアログ ボックスで、新しい構成の名前として「Test」と入力し、既存のデバッグ構成から設定をコピーして、 [OK] を選びます。

    [新しいソリューション構成] ダイアログ ボックスのスクリーンショット

    [新しいソリューション構成] ダイアログ ボックスでのテスト構成の作成を示すスクリーンショット。

  4. [アクティブ ソリューション プラットフォーム] 一覧の <[新規作成...]> をクリックします。

  5. [新しいソリューション プラットフォーム] ダイアログ ボックスで、 [x64] を選択します。x86 プラットフォームの設定はコピーしません。

    [新しいソリューション プラットフォーム] ダイアログ ボックスのスクリーンショット。

    [新しいソリューション プラットフォーム] ダイアログ ボックスのスクリーンショット。

  6. [OK] を選択します。

    アクティブなソリューション構成がテストに変更され、アクティブなソリューション プラットフォームが x64 に設定されました。

    テスト構成を使用した構成マネージャーのスクリーンショット。

    テスト構成を使用した構成マネージャーのスクリーンショット。

  7. [閉じる] を選択します。

[標準] ツール バーの [ソリューション構成] ボックスの一覧を使用すると、アクティブなソリューション構成を簡単に確認または変更することができます。

[標準] ツール バーの [ソリューション構成] ドロップダウン リストのスクリーンショット。

[標準] ツール バーの [ソリューション構成] ドロップダウン リストのスクリーンショット。

アプリケーションのビルド

次に、カスタム ビルド構成を使用してソリューションをビルドします。

ソリューションをビルドする

  • メニュー バーで [ビルド]>[ソリューションのビルド] の順に選択するか、Ctrl+Shift+B キーを押します。

    [出力] ウィンドウに、ビルドの結果が表示されます。 ビルドに成功しました。

コンパイラの警告を非表示にする

次に、コンパイラに警告を生成させるコードを紹介します。

  1. C# プロジェクトで、ExpenseReportPage.xaml.cs ファイルを開きます。 ExpenseReportPage メソッドにコード int i; を追加します。

    OR

    Visual Basic プロジェクトで、ExpenseReportPage.xaml.vb ファイルを開きます。 カスタム コンストラクターの Public Sub New... にコード Dim i を追加します。

  2. ソリューションをビルドします。

[出力] ウィンドウに、ビルドの結果が表示されます。 ビルドに成功しましたが、次の警告が生成されました。

Visual Basic の [出力] ウィンドウに表示されたビルド警告のスクリーンショット。

C# の [出力] ウィンドウに表示されたビルド警告のスクリーンショット。

C# の [出力] ウィンドウに表示されたビルド警告のスクリーンショット。

Visual Basic の [出力] ウィンドウに表示されたビルド警告のスクリーンショット。

ビルド出力が見やすくなるように、ビルド時に特定の警告メッセージを一時的に非表示にすることができます。

C# の特定の警告を非表示にする

  1. ソリューション エクスプローラーで、最上位のプロジェクト ノードを選択します。

  2. メニュー バーで [表示]>[プロパティ ページ] の順に選びます。

    プロジェクト デザイナーが開きます。

  3. [ビルド] タブまたはセクションを選んでから、[警告の表示なし] ボックスで、警告番号 0168 を指定します。 他の警告が既に表示されている場合は、区切り記号としてセミコロンを使います。

    [ビルド] ページ、プロジェクト デザイナーのスクリーンショット。

    [プロジェクトのプロパティ] の [ビルド] セクションのスクリーンショット。

    詳細については、「Build Page, Project Designer (C#)」([ビルド] ページ (プロジェクト デザイナー) (C#)) を参照してください。

  4. [ビルド] > [ソリューションのリビルド] を使って、ソリューションをビルドします。

    [出力] ウィンドウには、ビルドの概要情報のみが表示されます (警告は表示されません)。

    ビルド警告が表示されない C# の [出力] ウィンドウのスクリーンショット

    ビルド警告が表示されない C# の [出力] ウィンドウのスクリーンショット

Visual Basic のすべてのビルド警告を非表示にする

  1. ソリューション エクスプローラーで、最上位のプロジェクト ノードを選択します。

  2. メニュー バーで [表示]>[プロパティ ページ] の順に選びます。

    プロジェクト デザイナーが開きます。

  3. [コンパイル] ページで、 [すべての警告を表示しない] チェック ボックスをオンにします。

    [コンパイル] ページ、[プロジェクト デザイナー]

    [プロジェクト デザイナー] の [コンパイル] タブで警告を無効にするスクリーンショット

    詳細については、「Visual Basic での警告の構成」を参照してください。

  4. ソリューションをビルドします。 リビルドが行われない場合は、[ビルド] > [ソリューションのリビルド] を使ってソリューションをビルドします。

    [出力] ウィンドウには、ビルドの概要情報のみが表示されます (警告は表示されません)。

    ビルド警告が表示されない Visual Basic の [出力] ウィンドウのスクリーンショット

    ビルド警告が表示されない Visual Basic の [出力] ウィンドウのスクリーンショット

    詳細については、コンパイラ警告の非表示」を参照してください。

出力ウィンドウに追加のビルド詳細を表示する

[出力] ウィンドウに表示されるビルド プロセスに関する情報量を変更できます。 ビルドの詳細度は、通常、最小に設定されています。これは、優先度の高い警告またはエラーと共にビルド プロセスの概要のみが [出力] ウィンドウに表示されることを意味します。 ビルドに関する詳細情報を表示するには、「[オプション] ダイアログ ボックス、[プロジェクトおよびソリューション]、[ビルド/実行]」を参照してください。

重要

詳細情報を表示する場合は、ビルドの完了までにかかる時間が長くなります。

[出力] ウィンドウの情報量を変更する

  1. [オプション] ダイアログ ボックスを開きます。

    [ツール] メニューの [オプション] コマンドのスクリーンショット。

    [ツール]、[オプション] メニュー項目のスクリーンショット。

  2. [プロジェクトおよびソリューション] カテゴリを選択し、 [ビルド/実行] ページを選択します。

  3. [MSBuild プロジェクト ビルドの出力の詳細] ボックスの一覧の [標準] を選択し、 [OK] をクリックします。

  4. メニュー バーで、 [ビルド]>[ソリューションのクリーン] を選びます。

  5. ソリューションをビルドし、 [出力] のウィンドウの情報をレビューします。

    ビルド情報には、ビルドの開始時刻 (出力の先頭にあります) とファイルが処理された順序が含まれています。 この情報には、ビルド時に Visual Studio で実行される実際のコンパイラ構文も含まれています。

    たとえば、C# のビルドの場合、/nowarn オプションには、このトピックで指定した警告コード 0168 が、他の 3 つの警告と共に示されます。

    Visual Basic のビルドの場合、/nowarn には除外する特定の警告が含まれていないため、警告は表示されません。

    ヒント

    Ctrl+F キーを押して [検索] ダイアログ ボックスを表示すると、[出力] ウィンドウの内容を検索できます。

詳細については、ビルド ログ ファイルを表示、保存、および構成する」をご覧ください。

リリース ビルドを作成する

出荷用に最適化されたバージョンとしてサンプル アプリケーションをビルドすることができます。 リリース ビルドでは、ビルドの開始前に実行可能ファイルをネットワーク共有にコピーすることを指定します。

詳細については、ビルド出力ディレクトリを変更する」と「Visual Studio でのプロジェクトとソリューションのビルドおよびクリーン」を参照してください。

Visual Basic 用にリリース ビルドを指定する

  1. プロジェクト デザイナーを開くには、ソリューション エクスプローラーでプロジェクト ノードを選び、右クリックして [プロパティ] を選ぶ (または Alt+Enter キーを押す) か、[表示] メニューで [プロパティ ページ] を選びます。

    [表示]、[プロパティ ページ] メニュー項目のスクリーンショット。

    [表示]、[プロパティ ページ] メニュー項目のスクリーンショット。

  2. [コンパイル] ページをクリックします。

  3. [構成] ボックスの一覧の [リリース] をクリックします。

  4. [プラットフォーム] ボックスの一覧の [x86] をクリックします。

  5. [ビルド出力パス] ボックスに、ネットワーク パスを指定します。

    たとえば、\\myserver\builds を指定できます。

    重要

    メッセージ ボックスが表示され、指定したネットワーク共有が信頼できる場所ではない可能性があるという警告が示されることがあります。 指定した場所を信頼できる場合は、メッセージ ボックスの [OK] をクリックします。

  6. アプリケーションをビルドします。

    [ビルド] メニューの [ソリューションのビルド] コマンド

    [ビルド] メニューの [ソリューションのビルド] コマンドのスクリーンショット

C# 用にリリース ビルドを指定する

  1. プロジェクト デザイナーを開きます。

    [表示]、[プロパティ ページ] メニュー項目のスクリーンショット。

    [表示]、[プロパティ ページ] メニュー項目のスクリーンショット。

  2. [ビルド] ページを選びます。

  3. [構成] ボックスの一覧の [リリース] をクリックします。

  4. [プラットフォーム] ボックスの一覧の [x86] をクリックします。

  5. [出力パス] ボックスに、ネットワーク パスを指定します。

    たとえば、\\myserver\builds を指定できます。

    重要

    メッセージ ボックスが表示され、指定したネットワーク共有が信頼できる場所ではない可能性があるという警告が示されることがあります。 指定した場所を信頼できる場合は、メッセージ ボックスの [OK] をクリックします。

  6. 標準ツール バーで、ソリューション構成を [リリース] に、ソリューション プラットフォームを [x86] に設定します。

  7. アプリケーションをビルドします。

    [ビルド] メニューの [ソリューションのビルド] コマンド

    [ビルド] メニューの [ソリューションのビルド] コマンドのスクリーンショット

    指定したネットワーク パスに、実行可能ファイルがコピーされます。 そのパスは \\myserver\builds\\FileName.exe になります。

おめでとうございます! このチュートリアルは以上で完了です。

関連項目