手順 5: Python 環境へのパッケージのインストール

適用対象:yesVisual Studio noVisual Studio for Mac noVisual Studio Code

前の手順:デバッガーでコードを実行する

Python 開発者コミュニティは、ユーザーが独自のプロジェクトに組み込むことのできる便利なパッケージを何千も作成してきました。 Visual Studio には、Python 環境内のパッケージを管理するための UI が用意されています。

環境の表示

  1. [表示]>[その他のウィンドウ]>[Python 環境] メニュー コマンドを選びます。 ソリューション エクスプローラーへのピアとして [Python 環境] ウィンドウが開き、利用可能なさまざまな環境が示されます。 この一覧には、Visual Studio インストーラーを使用してインストールした環境と、個別にインストールした環境の両方が表示されます。 これには、グローバル環境、仮想環境、および Conda 環境が含まれます。 太字で示されている環境は、新しいプロジェクトに使用される既定の環境です。 環境の使用方法の詳細については、Visual Studio 環境で Python 環境を作成および管理する方法に関する記事をご覧ください。

    Python Environments window-2022

    Python Environments window-2019

    Note

    また、Ctrl + K、Ctrl + ` キーボード ショートカットを使用して、[ソリューション エクスプローラー] ウィンドウから [Python 環境] ウィンドウを開くこともできます。 ショートカットが機能せず、メニューに [Python 環境] ウィンドウが見つからない場合は、Python ワークロードをインストールしていない可能性があります。 Python をインストールする方法については、「Windows 用 Visual Studio に Python サポートをインストールする方法」をご覧ください。

    Python プロジェクトを開いた状態で、ソリューション エクスプローラーから [Python 環境] ウィンドウを開くことができます。 [Python 環境] を右クリックし、 [すべての Python 環境の表示] を選択します。

    Python Environments-2022

    Python Environments-2019

  2. 次に、 [ファイル]>[新規]>[プロジェクト] で、 [Python アプリケーション] テンプレートを選択して新しいプロジェクトを作成します。

  3. 表示されるコード ファイルに、次のコードを貼り付けます。これにより、前のチュートリアルの手順のように余弦波が作成されますが、今回はグラフィカルにプロットされるだけです。 また、前に作成したプロジェクトを使用して、そのコードを置き換えることもできます。

    from math import radians
    import numpy as np # installed with matplotlib
    import matplotlib.pyplot as plt
    
    def main():
        x = np.arange(0, radians(1800), radians(12))
        plt.plot(x, np.cos(x), 'b')
        plt.show()
    
    main()
    
  4. エディター ウィンドウで、インポート ステートメント numpy および matplotlib にマウスポインターを移動します。 それらは解決されていないことがわかります。 インポート ステートメントを解決するには、既定のグローバル環境にパッケージをインストールします。

    Unresolved package import-2022

    Unresolved package import

  5. エディター ウィンドウでは、インポート ステートメント numpymatplotlib にマウス ポインターを合わせると、それらが解決されていないことがわかります。 そのパッケージが既定のグローバル環境にインストールされていないためです。

    たとえば、 [対話型ウィンドウを開く] を選択すると、その特定の環境の対話型ウィンドウが Visual Studio で表示されます。

  6. [Python 環境] ウィンドウの [パッケージ] タブには、環境に現在インストールされているすべてのパッケージが一覧表示されます。

[Python 環境] ウィンドウを使用したパッケージのインストール

  1. [Python 環境] ウィンドウで、新しい Python プロジェクトの既定の環境を選択し、 [パッケージ] タブを選択します。環境に現在インストールされているパッケージの一覧が表示されます。

  2. matplotlib をインストールするには、検索フィールドにその名前を入力して、 [次のコマンドを実行する: pip install matplotlib] オプションを選択します。 コマンドを実行すると、matplotlib とそれが依存するすべてのパッケージ (この場合、numpy が含まれます) がインストールされます。

  3. [パッケージ] タブを選択します。

  4. 昇格に同意するように求められた場合は、同意します。

  5. パッケージがインストールされると、 [Python 環境] ウィンドウにそのパッケージが表示されます。 アンインストールするには、パッケージの右にある [X] 選択します。

  6. 検索フィールドに「matplotlib」と入力して、matplotlib をインストールします。

  7. [次のコマンドを実行する: pip install matplotlib] オプションを選択します。 このオプションによって、matplotlib と、それが依存するすべてのパッケージ (この場合には numpy が含まれます) がインストールされます。

    Installing matplotlib in the environment-2022 in Packages tab

    Installing matplotlib in the environment-2019 in Packages tab

  8. 昇格に同意するように求められた場合は、同意します。

  9. パッケージがインストールされると、 [Python 環境] ウィンドウにそれが表示されます。 アンインストールするには、パッケージの右にある [X] 選択します。

    Installing matplotlib in the environment-2022

    Installing matplotlib in the environment-2019

    Note

    環境の下に小さい進行状況バーが表示され、Visual Studio が新しくインストールしたパッケージに対して、IntelliSense データベースを構築していることが示される場合があります。 [IntelliSense] タブにはより詳細な情報も表示されます。 そのデータベースが完了するまで、エディターではそのパッケージのオートコンプリートや構文チェックなどの IntelliSense 機能がアクティブにならないことに注意してください。

    Visual Studio 2017 バージョン 15.6 以降では、高速で IntelliSense を操作する異なった方法が使用されています。その効果に関するメッセージが [IntelliSense] タブに表示されます。

プログラムを実行する

これで matplotlib がインストールされたので、プログラムをデバッガーと共に実行 (F5 キー) するか、デバッガーなしで実行 (Ctrl+F5 キー) して、出力を確認します。

Output of matplotlib example

次のステップ

詳しい説明