Бөлісу құралы:


Устранение неполадок с прогнозированием

Эта статья поможет вам устранить неполадки, связанные с прогнозированием в Microsoft Dynamics 365 Sales.

Проблема 1. При попытке создать прогноз на основе территории отображается ошибка

Симптомы

При попытке создать прогноз на основе территории отображается ошибка. Кроме того, данные в прогнозе на основе территории могут не обновляться.

Причина

При обновлении системы иерархия сущности территории отключается (хотя вы включили ее ранее), что приводит к этой ошибке.

Разрешение

Чтобы устранить эту проблему, необходимо включить иерархию в определении связи territory_parent_territory из раздела Связи. Выполните следующие действия:

  1. Перейдите в раздел Предварительные параметры.

    На вкладке откроется страница предварительных параметров.

  2. Выберите Параметры>Настройки Настройки>.

    Откроется страница параметров Power Apps .

  3. Выберите Сущности данных>, а затем — Территория.

    Выберите сущность территории в Power Apps.

  4. На странице Территория перейдите на вкладку Связи , а затем выберите Родительский.

    Выберите родительский объект для сущности территории.

  5. В диалоговом окне "Многие к одному" выберите поле Иерархический проверка и нажмите кнопку Готово.

    Включите параметр Иерархия в диалоговом окне

  6. Сохраните и закройте сущность.

Проблема 2. Не удается скрыть поле категории прогноза в формах возможностей

Причина

Иногда приложение отображает поле Категория прогноза в формах возможностей, даже если оно было настроено как невидимое по умолчанию с помощью настроек формы.

Разрешение

Чтобы устранить эту ошибку, необходимо удалить поле Категория прогноза из формы. Выполните следующие действия:

  1. В приложении на панели навигации щелкните значок Параметры , а затем выберите Дополнительные параметры.

    Дополнительные параметры в меню Параметры.

    На новой вкладке браузера откроется страница "Параметры управления бизнесом ".

  2. На панели навигации выберите Параметры, а затем в разделе Настройка выберите Настройки.

  3. Выберите Настроить систему.

  4. В разделе Компоненты в обозревателе решений разверните узел Сущности, Разверните узел Возможность, а затем выберите Формы.

  5. Откройте форму "Возможность " с типом "Основной".

    Форма "Возможность" откроется в новом окне.

  6. В разделе Сводка выберите поле Категория прогноза и нажмите кнопку Удалить.

    Удалите поле категории прогноза.

  7. Сохраните и опубликуйте конфигурацию.

Проблема 3. Не удается просмотреть прогнозы

Причина

Если вы использовали предыдущую версию прогнозирования и обновили ее до последней версии, карта сайта прогнозирования может не быть обновлена. Это может быть вызвано наличием неуправляемого слоя приложения Sales Hub, который позволит карте сайта прогнозирования открыть предыдущую версию прогнозирования.

На следующем рисунке показан пример предыдущей версии домашней страницы прогнозирования.

Домашняя страница предыдущей версии прогнозирования.

Разрешение

Чтобы устранить эту проблему, обновите запись карты сайта прогнозирования до последней сетки входных данных прогноза. Дополнительные сведения см. в разделе Добавление параметров сетки прогноза и конфигурации в схеме сайта.

Проблема 4. Не удается загрузить сетку прогноза и отображается ошибка

Причина

Процесс ForecastInstanceActions отключен. Причина может быть в том, что владелец организации изменился, что приводит к сбою при загрузке сетки прогноза. Отображается ошибка, показанная на следующем рисунке.

Действие (ForecastInstanceActions) для получения прогнозов отключено.

Сообщение об ошибке Действие (ForecastInstanceAction) для получения прогнозов отключено.

Разрешение

Чтобы устранить эту ошибку, активируйте процесс ForecastInstanceActions . Выполните следующие действия:

  1. Перейдите в раздел Дополнительные параметры и выберите Параметры Процессы>центра обработки>.

  2. В поле поиска введите ForecastInstanceActions. Вы видите, что процесс находится в состоянии Черновика .

    Процесс ForecastInstanceActions в состоянии черновика.

  3. Выберите процесс и нажмите кнопку Активировать.

    Активируйте процесс ForecastInstanceActions.

  4. В сообщении подтверждения выберите Активировать.

    Активирован процесс действий экземпляра прогнозирования.

  5. Убедитесь, что состояние процесса активировано, а затем закройте параметры.

Проблема 5. Не удается просмотреть данные детализации в сетке прогноза

Причина

У вас недостаточно привилегий для сущности конфигурации прогноза для просмотра детализации данных в сетке прогноза. Отображается ошибка, показанная на следующем рисунке.

Произошла ошибка.
Произошла ошибка при получении записей прогноза.
Перезагрузите страницу браузера еще раз.

Сообщение об ошибке, возникающее при попытке просмотреть данные детализации в сетке прогноза.

Разрешение

Чтобы устранить эту ошибку, администратор должен предоставить вашей роли безопасности права на чтение сущности прогнозируемой конфигурации . Выполните следующие действия:

  1. Перейдите в раздел Дополнительные параметры и выберите Параметры Роли>безопасности>.

  2. Выберите роль безопасности, для которой требуется применить привилегии.

  3. На странице роли безопасности выберите вкладку Настраиваемые сущности и перейдите к строке Прогноз конфигурации .

  4. Выберите и предоставьте права на чтение.

    Предоставьте права на чтение для сущности конфигурации прогноза.

  5. Закройте параметры.

Проблема 6. Поля категории прогноза не обновляются

Причина

В прогнозе после обновления поля категории прогноза до won или Lost возможности по-прежнему отображаются в предыдущем контейнере конвейера. Эта ошибка возникает из-за того, что рабочий процесс сопоставления категорий прогноза возможностей отключен в вашей организации.

Разрешение

Чтобы устранить ошибку, активируйте рабочий процесс сопоставления категорий прогноза возможностей . Выполните следующие действия:

  1. Перейдите в раздел Дополнительные параметры и выберите Параметры>Настройки>Настройка системы.

  2. На карте сайта выберите Процессы.

  3. Выберите рабочий процесс сопоставления категорий прогноза возможностей , а затем нажмите кнопку Активировать.

    Активируйте рабочий процесс сопоставления категорий прогноза возможностей.

    Категории прогнозов в возможностях будут обновлены должным образом. Возможности, которые были изменены перед активацией рабочего процесса, необходимо изменить вручную. Кроме того, откройте рабочий процесс сопоставления категорий прогнозов и убедитесь, что условия правильно определены для каждой категории прогноза.

    Условия рабочего процесса сопоставления категорий прогноза возможностей.

  4. Сохраните и закройте параметры.

Причина

Эта проблема возникает из-за того, что пользователь "прогнозирование Dynamics 365 Sales" не имеет разрешения на чтение сущности подстановки, связанной с иерархией.

Разрешение

Чтобы устранить эту проблему, выполните следующие действия:

  1. Перейдите в раздел Дополнительные параметры и выберите Параметры Роли>безопасности>системы>.

  2. Откройте роль Прогноз appUser и выберите вкладку, на которой присутствует тип сущности.

    Снимок экрана: роль пользователя приложения прогноза.

  3. Включите разрешение на чтение на уровне организации для типа сущности поля подстановки.

  4. Сохраните изменения.

Проблема 8. Не удается активировать прогноз

Причина

Активация прогноза завершается сбоем по нескольким причинам.

Разрешение

Чтобы устранить эту проблему, выполните следующие действия:

  1. Убедитесь, что выполнены все обязательные настройки для модели прогнозирования.
  2. Убедитесь, что иерархионные фильтры в конфигурации прогноза не отфильтровывают всю иерархию. Перейдите к разделу Предварительный просмотр на шаге Общие , чтобы убедиться, что иерархия существует. Дополнительные сведения см. в разделе Добавление дополнительных фильтров в прогноз.

Проблема 9. Не удается найти параметр конфигурации прогноза в разделе "Параметры приложения"

Причина

Параметр конфигурации прогноза может не отображаться в параметрах приложения "Центр продаж" по следующим причинам:

Разрешение

Чтобы устранить эту проблему, выполните следующие действия.

  1. Назначьте роль безопасности диспетчера прогнозов пользователю, который должен иметь возможность создавать конфигурации прогнозов и управлять ими.
  2. В конфигурации прогноза элементы области навигации прогноза должны быть добавлены в пользовательское приложение.

Проблема 10. Не удается просмотреть прогнозы для иерархии пользователей

Причина

Эта проблема возникает из-за нехватки разрешений для просмотра прогноза.

Разрешение

Чтобы устранить эту проблему, убедитесь, что:

  1. Выполняется одно из следующих условий:

    • Вы являетесь владельцем прогноза. Поле подстановки владельца на шаге Разрешения конфигурации прогноза показывает, кто является владельцем.

      Снимок экрана: шаг

    • Вы являетесь частью ролей безопасности, имеющих разрешение на чтение, как указано на шаге Разрешения конфигурации прогноза.

    • Кто-то поделился с вами прогнозом. Дополнительные сведения см. в разделе Включение или отключение общего доступа к прогнозам.

  2. Для поля подстановки владельца на шаге Разрешения конфигурации прогноза не задано значение Нет. Если задано значение Нет, никто не сможет просмотреть прогноз.

Проблема 11. Значения полей прогноза отображаются в сетке прогноза нулевым или пустым

Причина

Для столбцов, связанных с полем Selector, Amount и Date , может быть включена безопасность на уровне полей.

Разрешение

Чтобы устранить эту проблему, необходимо предоставить разрешение на чтение пользователю #Dynamics 365 Sales Прогнозирование в профилях безопасности поля. В противном случае в столбце будет отображаться значение 0 для всех пользователей. Чтобы настроить профили безопасности полей, выполните следующие действия.

  1. Перейдите в раздел Параметры>Дополнительные параметры>> Профильбезопасности поля безопасности.
  2. Выберите профиль безопасности поля, связанный с полем, которое показывает значение 0.
  3. Выберите Пользователи>Добавить.
  4. Найдите пользователя #Dynamics 365 Sales Прогнозирование, установите флажок напротив имени пользователя и нажмите Кнопку Добавить>.
  5. Выберите Разрешения поля и предоставьте полю разрешение на чтение .
  6. Сохраните и закройте профиль.

Пересчитайте прогноз и убедитесь, что в столбце отображаются соответствующие значения.

Проблема 12. Не удается вручную пересчитать столбец прогноза на странице "Прогнозы"

Причина

Столбец прогноза на странице Прогнозы не может быть пересчитан вручную.

Разрешение

Столбец прогноза в прогнозе автоматически пересчитывается каждые семь дней и не поддерживает пересчет вручную. Это связано с тем, что прогнозы основаны на моделях на основе ИИ, которые рассматривают исторические данные и открытый конвейер продаж для прогнозирования будущих результатов дохода. В столбце прогноза показан прогнозируемый доход для каждого продавца и руководителя на основе поля Состояние возможности. Чтобы оптимизировать точность прогнозов, убедитесь, что значения категории прогнозов синхронизированы с полем Состояние . Для готовой категории прогноза рабочий процесс гарантирует, что при закрытии возможности как "Выигранный " или "Потерянный" категория прогноза обновляется с соответствующим значением.

Проблема 13. Базовое представление сетки прогноза отключено (только для чтения) при загрузке страницы

Причина

Настраиваемый Код JavaScript, настроенный в конфигурации прогноза, предотвращает возможность редактирования сетки.

Разрешение

Чтобы устранить эту проблему, просмотрите пользовательский код JavaScript и проверка, если он отключает представление сетки базовых записей.