Notitie
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen u aan te melden of de directory te wijzigen.
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen de mappen te wijzigen.
Belangrijk
Deze functie is beschikbaar als openbare preview.
Met het Databricks-stuurprogramma voor SQLTools kunt u de SQLTools-extensie voor Visual Studio Code gebruiken om door SQL-objecten te bladeren en SQL-query's uit te voeren in externe Azure Databricks-werkruimten.
Requirements
Voordat u het Databricks-stuurprogramma voor SQLTools kunt gebruiken, moeten uw Azure Databricks-werkruimte en uw lokale ontwikkelcomputer aan de volgende vereisten voldoen.
Werkruimtevereisten
U moet ten minste één Azure Databricks-werkruimte beschikbaar hebben en de werkruimte moet voldoen aan de volgende vereisten:
De werkruimte moet ten minste één Databricks SQL warehouse bevatten.
Opmerking
Azure Databricks-clusters worden niet ondersteund door het Databricks-stuurprogramma voor SQLTools.
Voor werkruimten die zijn ingeschakeld voor Unity Catalog, moet de werkruimte ten minste één catalogus bevatten, met ten minste één schema (formeel een database genoemd) in die catalogus.
Voor werkruimten die niet zijn ingeschakeld voor Unity Catalog, moet de werkruimte ten minste één schema bevatten (voorheen een database genoemd).
Vereisten voor lokale ontwikkelcomputers
U moet het volgende hebben op uw lokale ontwikkelcomputer:
- Visual Studio Code versie 1.70 of hoger. Als u de geïnstalleerde versie wilt bekijken, klikt u op Code > over Visual Studio Code in het hoofdmenu op Linux of macOS en Help > Info op Windows. Zie Visual Studio Code instellen als u Visual Studio Code wilt downloaden, installeren en configureren.
- De SQLTools-extensie voor Visual Studio Code.
- De Databricks-stuurprogramma voor de SQLTools-extensie voor Visual Studio Code.
Als u de SQLTools-extensie wilt installeren, gaat u naar SQLTools en klikt u op Installeren of:
Klik in Visual Studio Code op Beeld > Extensies in het hoofdmenu.
Voer in het vak Zoekextensies in Marketplace de tekst in
SQLTools.Klik op het item SQLTools van Matheus Teixeira.
Opmerking
Er worden mogelijk meerdere SQLTools-vermeldingen vermeld. Klik op de vermelding van Matheus Teixeira.
Klik op Install.
Als u de extensie Databricks Driver for SQLTools wilt installeren, gaat u naar Databricks Driver for SQLTools en klikt u vervolgens op Installeren, of:
- Klik in Visual Studio Code op Beeld > Extensies in het hoofdmenu.
- Voer in het vak Zoekextensies in Marketplace de tekst in
Databricks Driver for SQLTools. - Klik op de vermelding Databricks Driver for SQLTools.
- Klik op Install.
Authenticatie
U moet als volgt authenticatie instellen voor het Databricks-stuurprogramma voor SQLTools.
Het Databricks-stuurprogramma voor SQLTools ondersteunt de volgende Azure Databricks-verificatietypen:
- Azure Databricks-authenticatie met persoonlijke toegangstokens
- Azure Databricks OAuth machine-to-machine (M2M)-authenticatie
- Azure Databricks OAuth-gebruiker-naar-machine-authenticatie (U2M)
- Azure CLI-authenticatie
Opmerking
Het Databricks-stuurprogramma voor SQLTools biedt geen ondersteuning voor Microsoft Entra ID-tokens.
Azure Databricks-authenticatie met een persoonlijk toegangstoken
Als u het Databricks-stuurprogramma voor SQLTools wilt gebruiken met persoonlijke toegangstokenverificatie van Azure Databricks, moet u een persoonlijk toegangstoken van Azure Databricks hebben. Als u een persoonlijk toegangstoken wilt maken, volgt u de stappen in Persoonlijke toegangstokens maken voor werkruimtegebruikers.
Azure Databricks OAuth machine-to-machine (M2M)-authenticatie
U kunt Azure Databricks OAuth-machine-naar-machineverificatie (M2M) gebruiken om te verifiëren met het Databricks-stuurprogramma voor SQLTools, als volgt:
Opmerking
Azure Databricks OAuth M2M-verificatie is beschikbaar in Databricks Driver voor SQLTools-versies 0.4.2 en hoger.
- Voltooi de configuratiestappen voor OAuth M2M-verificatie. Zie OAuth-machine-naar-machine (M2M)-authenticatie.
- Maak een Azure Databricks-configuratieprofiel met de configuratie-instellingen voor OAuth M2M-verificatie. Zie de sectie 'Config' van OAuth machine-to-machine (M2M)-authenticatie.
- Installeer en open de Databricks-extensie voor Visual Studio Code op uw lokale ontwikkelcomputer.
- Klik in de Databricks IDE-extensie op de knop Configureren in het configuratievenster . Als de knop Configureren niet wordt weergegeven, klikt u in plaats daarvan op het tandwielpictogram (Werkruimte configureren).
- In het Opdrachtpalet voert u bij Databricks Host uw Azure Databricks-URL per werkruimte in, bijvoorbeeld , en drukt u vervolgens op Enter.
- Selecteer de vermelding van het configuratieprofiel die overeenkomt met de vermelding die u in stap 2 hebt gemaakt.
- Voltooi de instructies op het scherm in uw webbrowser om de verificatie met uw Azure Databricks-account te voltooien.
Azure Databricks OAuth-gebruiker-naar-machine-authenticatie
U kunt Azure Databricks OAuth-authenticatie van gebruiker naar machine (U2M) gebruiken om te verifiëren met het Databricks-stuurprogramma voor SQLTools, als volgt:
Opmerking
Azure Databricks OAuth U2M-verificatie is beschikbaar in Databricks Driver voor SQLTools-versies 0.4.2 en hoger.
- Installeer en open de Databricks-extensie voor Visual Studio Code op uw lokale ontwikkelcomputer.
- Klik in de Databricks IDE-extensie op de knop Configureren in het configuratievenster . Als de knop Configureren niet wordt weergegeven, klikt u in plaats daarvan op het tandwielpictogram (Werkruimte configureren).
- Voer in het Opdrachtenpalet voor Databricks-host uw Azure Databricks-URL per werkruimte in, bijvoorbeeld
https://adb-1234567890123456.7.azuredatabricks.net. Druk vervolgens op Enter. - Selecteer OAuth (gebruiker naar computer).
- Voltooi de instructies op het scherm in uw webbrowser om de verificatie met uw Azure Databricks-account te voltooien. Als u hierom wordt gevraagd, geeft u
all-apistoegang.
Azure CLI-authenticatie
U kunt de Azure CLI als volgt gebruiken om te authenticeren met het Databricks-stuurprogramma voor SQLTools:
Opmerking
Aanmelden met de Azure CLI heeft de status van een experimentele functie. Deze functie is beschikbaar in Databricks Driver voor SQLTools-versies 0.4.2 en hoger.
- Installeer de Azure CLI op uw lokale ontwikkelcomputer als u dit nog niet hebt gedaan.
- Installeer en open de Databricks-extensie voor Visual Studio Code op uw lokale ontwikkelcomputer.
- Klik in de Databricks IDE-extensie op de knop Configureren in het configuratievenster . Als de knop Configureren niet wordt weergegeven, klikt u in plaats daarvan op het tandwielpictogram (Werkruimte configureren).
- Voer in het Command Palette bij Databricks Host uw Azure Databricks-URL per werkruimte in, bijvoorbeeld
https://adb-1234567890123456.7.azuredatabricks.net. Druk vervolgens op Enter. - Selecteer Azure CLI.
- Volg de aanwijzingen op het scherm om de verificatie met de Azure CLI te voltooien.
Verbinding maken met een schema
Klik in Visual Studio Code op de zijbalk op het pictogram SQLTools.
Als dit de eerste keer is dat u de SQLTools-extensie gebruikt, klikt u in de weergave SQLTools op Nieuwe verbinding toevoegen in het deelvenster Verbindingen. Klik anders op het pictogram Nieuwe verbinding toevoegen in de titelbalk van het deelvenster.
Klik op het pictogram Databricks op het tabblad SQLTools-instellingen bij de stap Een databasestuurprogramma selecteren.
Voer voor de stap Verbindingsinstellingen de volgende informatie in over uw magazijn, catalogus en schema:
- Voer voor verbindingsnaam een unieke naam in voor deze verbinding.
- (Optioneel) Voer voor de verbindingsgroep de naam in van een bestaande verbindingsgroep om de nieuwe verbinding aan die groep toe te voegen. U kunt ook een unieke naam opgeven om een nieuwe verbindingsgroep met de nieuwe verbinding te maken. Verbindingsgroepen maken het gemakkelijker om verbindingen in de extensie te vinden.
- Selecteer een van de volgende opties voor Verbinding maken met behulp van:
- Als u een persoonlijk toegangstoken van Azure Databricks wilt gebruiken voor verificatie, selecteert u Hostnaam en Token.
- Voor Databricks-stuurprogramma voor SQLTools-versies 0.4.2 en hoger selecteert u VS Code-extensie (bèta) om OAuth U2M- of M2M- of Azure CLI-verificatie te gebruiken.
Als u Hostnaam en Token hebt geselecteerd voor Verbinding maken met behulp van host, voert u voor Host de instelling serverhostnaam van het magazijn in. Zie Verbindingsgegevens ophalen voor een Azure Databricks-rekenresource om de hostnaaminstelling van een magazijnserver op te halen.
Voer bij Pad de HTTP-padinstelling van het magazijn of het cluster in. Zie Verbindingsgegevens ophalen voor een Azure Databricks-rekenresource om de instelling voor het HTTP-pad van een magazijn te verkrijgen.
Als u Hostname en Token hebt geselecteerd voor Verbinding maken via, voert u de waarde van uw persoonlijke Azure Databricks-toegangstoken in Token in.
Voor Catalogus voert u de naam van uw catalogus in.
Opmerking
Voor werkruimten die niet zijn ingeschakeld voor Unity Catalog, kunt u Catalogus leeg laten om de standaardwaarde van te gebruiken.
Voer voor Schema de naam van uw schema in.
(Optioneel) Laat voor Show records default limit de standaardwaarde van staan om alleen de eerste 50 rijen voor elke query weer te geven, of voer een andere limiet in.
Klik op Verbinding testen.
Als de verbindingstest is geslaagd, klikt u op Verbinding opslaan.
De instellingen van een verbinding wijzigen
In deze procedure wordt ervan uitgegaan dat u verbinding hebt gemaakt met ten minste één magazijn.
- Als de weergave SQLTools niet zichtbaar is, klikt u in Visual Studio Code op de zijbalk op het pictogram SQLTools .
- Vouw in het deelvenster Verbindingen de verbindingsgroep uit, als deze bestaat voor de doelverbinding.
- Klik met de rechtermuisknop op de verbinding en klik op Verbinding bewerken.
- Wijzig de doelinstellingen.
- Klik op Verbinding testen.
- Als de verbindingstest is geslaagd, klikt u op Verbinding opslaan.
Door de objecten van een schema bladeren
- Vouw in het deelvenster Verbindingen de verbindingsgroep uit, als deze bestaat voor de doelverbinding.
- Dubbelklik of klap de doelverbinding voor uw magazijn uit.
- Klap de doeldatabase (schema) uit als er een bestaat voor uw verbinding.
- Vouw tabellen of weergaven uit als er een of meer tabellen of weergaven bestaan voor uw database (schema).
- Vouw een doeltabel of -weergave uit om de kolommen van de tabel of weergave weer te geven.
De rijen of het schema voor een tabel of weergave weergeven
Met Tabellen of Weergaven uitgevouwen in het deelvenster Verbindingen, doet u een van de volgende handelingen:
- Als u de rijen van de tabel of weergave wilt weergeven, klikt u met de rechtermuisknop op de tabel of weergave en klikt u op Tabelrecords weergeven of Weergaverecords weergeven.
- Als u het schema van de tabel of weergave wilt weergeven, klikt u met de rechtermuisknop op de tabel of weergave en klikt u op Tabel beschrijven of Weergave beschrijven.
Een INSERT-query voor een tabel genereren
- Plaats de cursor in een bestaande editor op de locatie waar u de invoegquery wilt toevoegen.
- Als Tabellen zijn uitgevouwen in het deelvenster Verbindingen, klikt u met de rechtermuisknop op de tabel en klikt u op Invoegquery genereren. De definitie van de insert-query wordt toegevoegd op de plaats waar de cursor zich bevindt.
Een query maken en uitvoeren
In deze procedure wordt ervan uitgegaan dat u verbinding hebt gemaakt met ten minste één magazijn.
- Vouw in het deelvenster Verbindingen de verbindingsgroep uit, als deze bestaat voor de doelverbinding.
- Dubbelklik of klap de doelverbinding voor uw magazijn uit.
- Klik terwijl de verbinding is geselecteerd op Nieuw SQL-bestand in de titelbalk van het deelvenster Verbindingen . Er wordt een nieuw editortabblad weergegeven.
- Voer uw SQL-query in de nieuwe editor in.
- Als u de SQL-query wilt uitvoeren, klikt u op Uitvoeren op actieve verbinding in de editor. De resultaten van de query worden weergegeven op een nieuw editortabblad.
Een bestaande query uitvoeren
In deze procedure wordt ervan uitgegaan dat u succesvol verbonden bent met ten minste één magazijn.
- Vouw in het deelvenster Verbindingen de verbindingsgroep uit, als deze bestaat voor de doelverbinding.
- Dubbelklik of klap de doelverbinding voor uw magazijn uit.
- Als de verbinding is geselecteerd, opent u een bestand met de extensie
.sql, of selecteert u een groep aaneengesloten SQL-instructies in een willekeurige editor die eerder is geopend. - Om de SQL-query uit te voeren vanuit een geopend
.sqlbestand, terwijl de inhoud van uw.sqlbestand in de editor wordt weergegeven, klikt u in de editor op Uitvoeren op actieve verbinding. De resultaten van de query worden weergegeven op een nieuw editortabblad. - Als u een geselecteerde groep doorlopende SQL-instructies wilt uitvoeren in een editor die eerder is geopend, klikt u met de rechtermuisknop op de selectie en klikt u vervolgens op Geselecteerde query uitvoeren. De resultaten van de query worden weergegeven op een nieuw editortabblad.
Gebruikslogboeken verzenden naar Databricks
Als u problemen ondervindt tijdens het gebruik van het Databricks-stuurprogramma voor SQLTools, kunt u gebruikslogboeken en gerelateerde informatie verzenden naar Databricks Support door het volgende te doen:
- Installeer de Databricks-extensie voor Visual Studio Code op uw lokale ontwikkelcomputer.
- Zet logging aan door de instelling Logs: Enabled aan te vinken of door
databricks.logs.enabledin te stellen optrue, zoals beschreven in Instellingen voor de Databricks IDE-extensie. Zorg ervoor dat je Visual Studio Code opnieuw start nadat je logging hebt ingeschakeld. - Probeer uw issue te reproduceren.
- Voer vanuit het Command Palette (Weergave > Opdrachtpalet in het hoofdmenu) de opdracht Databricks: Open full logs uit.
- Verzend de bestanden
Databricks Logs.log,databricks-cli-logs.jsonensdk-and-extension-logs.jsondie voor Databricks Support zichtbaar zijn. - Kopieer ook de inhoud van de Terminal (View > Terminal) in de context van het probleem en verzend deze inhoud naar Databricks Support.
De weergave Uitvoer (Weergave > Uitvoer, Databricks-logboeken) toont afgekorte informatie als Logboeken: Ingeschakeld is ingeschakeld of is ingesteld op . Voor meer informatie kunt u de volgende instellingen wijzigen, zoals beschreven in Instellingen voor de Databricks IDE-extensie:
-
Logboeken: Maximale arraylengte of
databricks.logs.maxArrayLength -
Logboeken: Maximale veldlengte of
databricks.logs.maxFieldLength -
Logs: Afkappingsdiepte of
databricks.logs.truncationDepth