Problemen met Azure Load Balancer oplossen

Op deze pagina vindt u informatie over probleemoplossing voor algemene vragen over Basic en Standard voor Azure Load Balancer. Zie Overzicht van Standard Load Balancer voor meer informatie over Standard Load Balancer.

Wanneer de load balancer-connectiviteit niet beschikbaar is, zijn de meest voorkomende symptomen als volgt:

  • VM's achter de Load Balancer reageren niet op statustests
  • VM's achter de Load Balancer reageren niet op het verkeer op de geconfigureerde poort

Wanneer de externe clients naar de back-end-VM's de load balancer doorlopen, wordt het IP-adres van de clients gebruikt voor de communicatie. Zorg ervoor dat het IP-adres van de clients is toegevoegd aan de acceptatielijst voor NSG's.

Probleem: Geen uitgaande connectiviteit van interne Standard Load Balancers (ILB)

Validatie en oplossing

Standaard-IL's zijn standaard beveiligd. Standaard-IL's hebben verbinding met internet toegestaan via een verborgen openbaar IP-adres, het standaard-IP-adres voor uitgaande toegang. Dit wordt niet aanbevolen voor productieworkloads omdat het IP-adres niet statisch of vergrendeld is via netwerkbeveiligingsgroepen waarvan u eigenaar bent. Als u onlangs bent overgestapt van een basic-ILB naar een standaard-ILB, moet u expliciet een openbaar IP-adres maken via alleen uitgaande configuratie, waardoor het IP-adres wordt vergrendeld via netwerkbeveiligingsgroepen. U kunt ook een NAT-gateway in uw subnet gebruiken. NAT Gateway is de aanbevolen oplossing voor uitgaand verkeer.

Probleem: Geen binnenkomende connectiviteit met Standard externe Load Balancers (ELB)

Oorzaak

Standaard load balancers en standaard openbare IP-adressen worden gesloten voor binnenkomende verbindingen, tenzij deze worden geopend door netwerkbeveiligingsgroepen. Netwerkbeveiligingsgroepen worden gebruikt om toegestaan verkeer expliciet toe te staan. Als u geen NSG op een subnet of NIC van uw virtuele-machineresource hebt, is verkeer niet toegestaan om deze resource te bereiken.

Oplossing

Als u inkomend verkeer wilt toestaan, voegt u een netwerkbeveiligingsgroep toe aan het subnet of de interface voor uw virtuele resource.

Probleem: kan de back-endpoort niet wijzigen voor een bestaande LB-regel van een load balancer waarop virtuele-machineschaalset is geïmplementeerd in de back-endpool.

Oorzaak

De back-endpoort kan niet worden gewijzigd voor een taakverdelingsregel die wordt gebruikt door een statustest voor load balancer waarnaar wordt verwezen door virtuele-machineschaalset

Oplossing

Als u de poort wilt wijzigen, kunt u de statustest verwijderen door de virtuele-machineschaalset bij te werken, de poort bij te werken en vervolgens de statustest opnieuw te configureren.

Probleem: klein verkeer gaat nog steeds via load balancer na het verwijderen van VM's uit de back-endpool van de load balancer.

Oorzaak

VM's die zijn verwijderd uit de back-endpool mogen geen verkeer meer ontvangen. De kleine hoeveelheid netwerkverkeer kan betrekking hebben op opslag, DNS en andere functies in Azure.

Oplossing

U kunt een netwerktracering uitvoeren om dit te controleren. De FQDN (Fully Qualified Domain Name) die wordt gebruikt voor uw blob-opslagaccount, wordt vermeld in de eigenschappen van elk opslagaccount. Vanaf een virtuele machine in uw Azure-abonnement kunt u uitvoeren nslookup om het Azure-IP-adres te bepalen dat aan dat opslagaccount is toegewezen.

Probleem: Load Balancer met de status Mislukt

Oplossing

  • Nadat u de resource hebt geïdentificeerd die zich in een mislukte status bevindt, gaat u naar Azure Resource Explorer en identificeert u de resource in deze status.
  • Werk de wisselknop in de rechterbovenhoek bij naar Lezen/Schrijven.
  • Selecteer Bewerken voor de resource met de status Mislukt.
  • Selecteer PUT gevolgd door GET om ervoor te zorgen dat de inrichtingsstatus is bijgewerkt naar Geslaagd.
  • U kunt vervolgens doorgaan met andere acties omdat de resource de status Mislukt heeft.

Netwerkopnamen die nodig zijn voor probleemoplossing en ondersteuningscases

Als u besluit een ondersteuningsaanvraag te openen, verzamelt u de volgende informatie voor een snellere oplossing. Kies één back-end-VM om de volgende tests uit te voeren:

  • Gebruik ps ping van een van de back-end-VM's in het virtuele netwerk om het antwoord van de testpoort te testen (bijvoorbeeld: ps ping 10.0.0.4:3389) en recordresultaten.
  • Als er geen antwoord wordt ontvangen in deze pingtests, voert u een gelijktijdige Netsh-trace uit op de back-end-VM en de virtuele netwerktest-VM terwijl u PsPing uitvoert, en stopt u de Netsh-trace.

Volgende stappen

Als het probleem niet wordt opgelost met de voorgaande stappen, opent u een ondersteuningsticket.