Delen via


Problemen met voorwaardelijke toegang voor Teams Android-apparaten oplossen

Symptomen

Voorwaardelijke toegang is een Microsoft Entra-functie waarmee u ervoor kunt zorgen dat apparaten die toegang hebben tot bedrijfsbronnen correct worden beheerd en beveiligd. Als beleid voor voorwaardelijke toegang wordt toegepast op de Microsoft Teams-service, moeten Android-apparaten die toegang hebben tot Teams voldoen aan het beleid. Dergelijke apparaten omvatten Teams-telefoons, Teams-schermen, Teams-paneel s en Teams-ruimten op Android. Anders voorkomt voorwaardelijke toegang dat gebruikers zich aanmelden bij of de Teams-app op de apparaten gebruiken.

Als deze beleidsregels worden toegepast, ondervindt u mogelijk een of meer van de volgende problemen op niet-compatibele apparaten:

  • De apparaten kunnen zich niet aanmelden bij Teams of ze blijven hangen in aanmeldingslussen.
  • De apparaten melden zich automatisch willekeurig af bij Teams.
  • Microsoft Teams reageert niet meer (loopt vast).

Oorzaak

Deze problemen kunnen om de volgende redenen optreden:

  • Niet-ondersteund beleid voor voorwaardelijke toegang of instellingen voor intune-nalevingsbeleid voor apparaten

    Als een apparaat is gemarkeerd als niet-compatibel, wordt de tokens voor het apparaatobject niet vernieuwd door de Microsoft Entra-token-verlenende service of wordt het token zelfs ingetrokken. In dit geval kan het apparaat geen bijgewerkt verificatietoken ophalen en wordt het gedwongen zich af te melden.

    Als u de nalevingsstatus van uw apparaten wilt controleren, gebruikt u het Intune-dashboard voor apparaatnaleving.

  • De instelling voor de aanmeldingsfrequentie

    Deze instelling dwingt periodieke verificatie af. Deze actie kan ertoe leiden dat de apparaten zich willekeurig afmelden, afhankelijk van het aantal van uw beleid voor voorwaardelijke toegang waarvoor verschillende aanmeldingsfrequenties zijn ingesteld. Wanneer er opnieuw verificatie plaatsvindt, wordt het token ingetrokken en wordt er een nieuw apparaatobject gemaakt onder het gebruikersaccount. Als het aantal apparaatobjecten groter is dan de apparaatlimiet van Microsoft Entra of intune-apparaatlimiet, kan de gebruiker zich niet aanmelden bij het apparaat.

  • De gebruiksvoorwaarden (ToU) en MFA-beleid voor voorwaardelijke toegang, als beide worden gebruikt

    Zie Bekende problemen met Teams-telefoons voor meer informatie.

Oplossing

Identificeer de specifieke oorzaak van het probleem door meerdere details te controleren over de toegang van de betrokken gebruiker tot de Teams-app. Als u de vereiste controles wilt uitvoeren, kunt u een geautomatiseerde optie gebruiken of de controles handmatig uitvoeren met behulp van de opgegeven stappen.

Geautomatiseerde controles

De automatische optie is het uitvoeren van de Microsoft Teams-ruimten Aanmeldingsconnectiviteitstest in het hulpprogramma Microsoft Remote Connectivity Analyzer. Dit hulpprogramma wordt gebruikt om verbindingsproblemen op te lossen die van invloed zijn op Teams. Tijdens de connectiviteitstest worden controles uitgevoerd om de machtigingen van een specifieke gebruiker voor aanmelding bij Teams te verifiëren met behulp van een Teams-ruimten apparaat.

Notitie

  • Er is een globale beheerdersaccount vereist om de connectiviteitstest voor Microsoft Teams-ruimten aanmelding uit te voeren.
  • Het hulpprogramma Microsoft Remote Connectivity Analyzer is niet beschikbaar voor de GCC- en GCC High Microsoft 365 Government-omgevingen.

Voer de volgende stappen uit om de connectiviteitstest uit te voeren:

  1. Open een webbrowser en navigeer naar de connectiviteitstest Microsoft Teams-ruimten Aanmelden.
  2. Meld u aan met behulp van de referenties van een globale beheerdersaccount.
  3. Geef de gebruikersnaam op voor het account dat geen toegang heeft tot de Teams-ruimten-app.
  4. Selecteer in het veld Apparaatselectie een type voor het apparaat van de betrokken gebruiker.
  5. Voer de verificatiecode in die wordt weergegeven en selecteer Verifiëren.
  6. Schakel het selectievakje in om de voorwaarden van de overeenkomst te accepteren en selecteer vervolgens Test uitvoeren.

Nadat de test is voltooid, geeft het scherm details weer over alle uitgevoerde controles en of de test is geslaagd, mislukt of geslaagd, maar een paar waarschuwingen heeft weergegeven. Selecteer de opgegeven koppeling voor meer informatie over de waarschuwingen en fouten en hoe u deze kunt oplossen.

Handmatige controles

Volg deze stappen om handmatig de gebruikerstoegang tot de Teams-app te controleren:

  1. Ga naar de aanmeldingslogboeken in Azure Portal.

  2. Selecteer het tabblad Gebruikersaanmelding (niet-interactief).

  3. Selecteer Filters toevoegen om de volgende filters toe te voegen:

    • Status: Selecteer Fout en selecteer Vervolgens Toepassen.
    • Toepassing: Voer Teams in en selecteer Vervolgens Toepassen.

    Schermopname van de status- en toepassingsfilters.

  4. Zoek voor de betrokken gebruikersnamen naar items met de volgende toepassingswaarden :

    • Microsoft Teams
    • Microsoft Teams-service
    • Microsoft Teams - Agent voor apparaatbeheerder
  5. Selecteer elk item om details over de mislukte aanmelding weer te geven. Meestal krijgt u meer informatie uit de volgende velden op het tabblad Basisinformatie :

    • Foutcode voor aanmelding
    • Reden van fout
    • Aanvullende details

    Schermopname van de pagina Basisgegevens van de details van de aanmeldingsactiviteit.

  6. Als de aanmeldingsfoutcode te maken heeft met naleving, selecteert u het tabblad Voorwaardelijke toegang en zoekt u naar beleidsregels met een foutresultaat.

    Schermopname van de pagina Voorwaardelijke toegang van de details van de aanmeldingsactiviteit.

  7. Bekijk de beleidsdetails.

    Schermopname van de details van het beleid voor voorwaardelijke toegang.

Nadat u het specifieke beleid voor voorwaardelijke toegang hebt geïdentificeerd dat het probleem veroorzaakt, kunt u apparaatfilters gebruiken om het betreffende apparaat uit te sluiten van het beleid. Veelgebruikte apparaateigenschappen in apparaatfilters zijn fabrikant en model. Deze worden samen met de operators Contains, StartsWith en In gebruikt.

Notitie

  • Apparaatfilters zijn alleen van toepassing op apparaatobjecten, niet op gebruikersaccounts.
  • Sommige kenmerken, zoals het model en de fabrikant, kunnen alleen worden ingesteld als apparaten zijn ingeschreven bij Intune. Als uw apparaten niet zijn ingeschreven bij Intune, gebruikt u extensiekenmerken.
  • Controleer elke beleidsinstelling voor niet-ondersteunde instellingen voor Teams-apparaten.

In de volgende schermopname ziet u een voorbeeldapparaatfilter.

Schermopname van een voorbeeldapparaatfilter.

Verwijzingen