Queryoverzicht in Power BI Desktop

Met Power BI Desktop kunt u verbinding maken met de wereld van gegevens, overtuigende en gefundeerde rapporten maken en uw resultaten delen met anderen, die verder kunnen bouwen op uw werk en hun business intelligence-activiteiten kunnen uitbreiden.

U kunt kiezen uit drie weergaven in Power BI Desktop:

  • Rapportweergave : u kunt query's die u maakt gebruiken om aantrekkelijke visualisaties te maken, gerangschikt zoals u ze wilt weergeven en met meerdere pagina's, die u met anderen kunt delen.
  • Gegevensweergave : bekijk de gegevens in uw rapport in de indeling van het gegevensmodel, waar u metingen kunt toevoegen, nieuwe kolommen kunt maken en relaties kunt beheren.
  • Modelweergave : krijg een grafische weergave van de relaties die in uw gegevensmodel tot stand zijn gebracht en beheer of wijzig deze indien nodig.

Open deze weergaven door een van de drie pictogrammen aan de linkerkant van Power BI Desktop te selecteren. In de volgende afbeelding is de weergave Rapport geselecteerd. Dit is te zien aan de gele band naast het pictogram.

Schermopname van Power BI Desktop met rapportweergave geselecteerd.

Power BI Desktop wordt ook geleverd bij Power Query-editor. Gebruik Power Query-editor om verbinding te maken met een of meer gegevensbronnen, de gegevens naar behoefte vorm te geven en te transformeren, en dat model vervolgens in Power BI Desktop te laden.

Dit artikel biedt een overzicht van het werken met gegevens in de Power Query-editor, maar er is nog meer te leren. Aan het einde van dit artikel vindt u koppelingen naar gedetailleerde richtlijnen over ondersteunde gegevenstypen. Ook vindt u hier informatie over het maken van verbinding met gegevens, het vormgeven van gegevens, het maken van relaties en hoe u kunt beginnen.

Maar laten we eerst kennismaken met Power Query-editor.

Power Query-editor

Als u naar Power Query-editor wilt gaan, selecteert u Gegevens transformeren op het tabblad Start van Power BI Desktop.

Schermopname van Power BI Desktop met het pictogram Gegevens transformeren gemarkeerd.

Zonder gegevensverbindingen wordt Power Query-editor weergegeven als een leeg venster dat gereed is voor gegevens.

Schermopname van Power BI Desktop met Power Query-editor zonder gegevensverbindingen.

Nadat een query is geladen, wordt Power Query-editor weergave interessanter. Als u verbinding maakt met de volgende webgegevensbron, laadt Power Query-editor informatie over de gegevens, die u vervolgens kunt vormgeven:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Hier ziet u hoe Power Query-editor wordt weergegeven nadat een gegevensverbinding tot stand is gebracht:

  1. In het lint zijn veel knoppen actief om de gegevens in de query te gebruiken.

  2. In het linkerdeelvenster worden query's vermeld die beschikbaar zijn om te worden geselecteerd, weergegeven en vormgegeven.

  3. In het middelste deelvenster worden gegevens uit de geselecteerde query weergegeven en geactiveerd voor weergave.

  4. Het deelvenster Queryinstellingen wordt weergegeven, waarin de eigenschappen van de query en de toegepaste stappen worden weergegeven.

    Schermopname van Power BI Desktop met het deelvenster Queryinstellingen in Power Query-editor.

Elk van deze vier gebieden wordt later uitgelegd: het lint, het deelvenster Query's, de gegevensweergave en het deelvenster Query-instellingen.

Het lint in Query-editor

Het lint in Power Query-editor bestaat uit vier tabbladen: Start, Transformeren, Kolom toevoegen, Weergave, Hulpmiddelen en Help.

Het tabblad Start bevat de algemene querytaken.

Schermopname van Power BI Desktop met het lint Power Query-editor query.

Selecteer Nieuwe bron om een verbinding met gegevens te maken en te beginnen met het opbouwen van een query. Er verschijnt een menu met de meestvoorkomende gegevensbronnen.

Schermopname van Power BI Desktop met de knop Nieuwe bron.

Zie Gegevensbronnen voor meer informatie over beschikbare gegevensbronnen. Zie Verbinding maken met gegevens voor meer informatie over het maken van verbindingen met gegevens, inclusief voorbeelden en stappen.

Het tabblad Transformeren biedt toegang tot algemene taken voor gegevenstransformatie, zoals:

  • Kolommen toevoegen of verwijderen
  • Gegevenstypen wijzigen
  • Kolommen splitsen
  • Andere gegevensgestuurde taken

Schermopname van Power BI Desktop met het tabblad Transformeren.

Zie voor meer informatie over het transformeren van gegevens, inclusief voorbeelden, Zelfstudie: Gegevens vormgeven en combineren in Power BI Desktop.

Het tabblad Kolom toevoegen bevat meer taken die zijn gekoppeld aan het toevoegen van een kolom, het opmaken van kolomgegevens en het toevoegen van aangepaste kolommen. De volgende afbeelding toont het tabblad Kolom toevoegen.

Schermopname van Power BI Desktop met het tabblad Kolom toevoegen.

Het tabblad Weergeven van het lint wordt gebruikt om te bepalen of bepaalde deelvensters of vensters worden weergegeven. Het wordt ook gebruikt om de geavanceerde editor weer te geven. De volgende afbeelding toont het tabblad Weergeven.

Schermopname van Power BI Desktop met het tabblad Beeld.

Veel taken in het lint zijn overigens ook beschikbaar door met de rechtermuisknop te klikken op een kolom, of andere gegevens, in het middelste deelvenster.

Het linkerdeelvenster (Query's)

In het linkerdeelvenster of het deelvenster Query's wordt het aantal actieve query's en de naam van de query weergegeven. Wanneer u een query selecteert in het linkerdeelvenster, worden de bijbehorende gegevens weergegeven in het middelste deelvenster, waar u de gegevens naar behoefte kunt vormgeven en transformeren. De volgende afbeelding toont het linkerdeelvenster met een query.

Schermopname van Power BI Desktop met Query's in het linkerdeelvenster.

Het middelste deelvenster (Gegevens)

In het middelste deelvenster, het deelvenster Gegevens, worden de gegevens van de geselecteerde query weergegeven. In dit deelvenster worden veel taken van de queryweergave uitgevoerd.

In de volgende afbeelding ziet u de webgegevensverbinding die eerder tot stand is gebracht. De kolom Algehele score is geselecteerd en op de koptekst wordt met de rechtermuisknop geklikt om de beschikbare menu-items weer te geven. U ziet dat veel van deze items in het snelmenu hetzelfde zijn als de knoppen op de linttabbladen.

Schermopname van Power BI Desktop met Gegevens in het middelste deelvenster.

Als u een snelmenu-item (of een knop op het lint) selecteert, past de query de stap toe op de gegevens. Ook wordt de stap opgeslagen als onderdeel van de query zelf. De stappen worden vastgelegd in het deelvenster Query-instellingen in sequentiële volgorde, zoals beschreven in de volgende sectie.

Het rechterdeelvenster (Query-instellingen)

In het rechterdeelvenster, of het deelvenster Query-instellingen, worden alle stappen weergegeven die zijn gekoppeld aan een query. Zo ziet u in de volgende afbeelding van de sectie Toegepaste stappen van het deelvenster Query-instellingen dat we zojuist het type van de kolom Totale score hebben gewijzigd.

Schermopname van Power BI Desktop met Query-instellingen in het rechterdeelvenster.

Naarmate er meer vormgevingsstappen worden toegepast op de query, worden deze vastgelegd in de sectie Toegepaste stappen .

Het is belangrijk te weten dat de onderliggende gegevens niet zijn gewijzigd. In plaats daarvan wordt de weergave van de gegevens in Power Query-editor aangepast en beïnvloed. Ook wordt de weergave van elke interactie met de onderliggende gegevens die plaatsvinden op basis van de gewijzigde en aangepaste weergave van Power Query-editor van die gegevens beïnvloed en aangepast.

In het deelvenster Query-instellingen kunt u de namen van stappen wijzigen, stappen verwijderen of de volgorde van de stappen naar wens aanpassen. Hiertoe klikt u met de rechtermuisknop op een stap in de sectie Toegepaste stappen en kiest u een optie in het snelmenu. De querystappen worden uitgevoerd in de volgorde waarin ze worden weergegeven in het deelvenster Toegepaste stappen.

Schermopname van Power BI Desktop met de filters Eigenschappen van query-instellingen en Toegepaste stappen.

Geavanceerde editor

Met de Geavanceerde editor kunt u de code zien die Power Query-editor maakt bij elke stap. U kunt ook uw eigen bepalende code maken. Om de geavanceerde editor te starten, selecteert u Weergave in het lint en vervolgens Geavanceerde Editor. Er verschijnt een venster met de bestaande querycode.
Schermopname van Power BI Desktop met het dialoogvenster Geavanceerde editor.

U kunt de code rechtstreeks bewerken in het venster Geavanceerde editor. Om het venster te sluiten, selecteert u knop Gereed of Annuleren.

Uw werk opslaan

Wanneer de query zich op de gewenste locatie bevindt, selecteert u Toepassen sluiten & in het menu Bestand van Power Query-editor. Met deze actie worden de wijzigingen toegepast en wordt de editor gesloten.
Schermopname van Power BI Desktop met de optie Sluiten en toepassen op het tabblad Bestand.

In Power BI Desktop wordt de voortgangsstatus in een dialoogvenster aangegeven.
Schermopname van Power BI Desktop met het bevestigingsdialoogvenster Wijzigingen toegepaste query.

Als u klaar bent, kan Power BI Desktop uw werk opslaan in de vorm van een pbix-bestand.

Als u uw werk wilt opslaan, selecteert u Bestand>opslaan (of Bestand>opslaan als), zoals wordt weergegeven in de volgende afbeelding. Schermopname van Power BI Desktop met het tabblad Power Query-editor Bestand. De opties opslaan en opslaan als zijn gemarkeerd.

Volgende stappen

U kunt allerlei handelingen uitvoeren met Power BI Desktop. Bekijk de volgende bronnen voor meer informatie over de vele mogelijkheden: