Delen via


Het OneDrive-synchronisatie statuspictogram geeft ten onrechte 'synchroniseren' weer in Bestandenverkenner

Nadat u bestanden of mappen hebt gesynchroniseerd met OneDrive, geeft het OneDrive-pictogram in het systeemvak van de taakbalk de status Up-to-date weer voor bestanden of mappen die volledig zijn gesynchroniseerd. Sommige of alle bestanden en mappen in de OneDrive-map in Bestandenverkenner worden echter nog steeds weergegeven als 'synchroniseren'. Dit artikel bevat mogelijke oplossingen die u kunt gebruiken om deze problemen op te lossen.

Sommige bestanden en mappen geven de status 'synchroniseren' weer

Oorzaak

Dit probleem kan de volgende oorzaken hebben:

  • De OneDrive-map bevat verborgen en tijdelijke bestanden. Verborgen en tijdelijke bestanden geven standaard de status 'synchroniseren' weer, maar ze worden niet gesynchroniseerd door OneDrive. Daarom hebben ze geen invloed op de status 'Up-to-date'.
  • De Windows Search-index heeft een onjuiste cachestatus. Dit kan leiden tot een onverwachte synchronisatiestatus in sommige bestanden en mappen.

Oplossing

U kunt dit probleem oplossen door te controleren of er verborgen of tijdelijke bestanden en mappen in de OneDrive-map staan. Verwijder de gevonden items:

  1. Verborgen bestanden en mappen weergeven in Bestandenverkenner.

  2. Verwijder alle verborgen bestanden en mappen die niet zijn gekoppeld aan de bestanden die u momenteel bewerkt.

  3. Zoek naar tijdelijke Office-bestanden. Als u deze bestanden wilt verwijderen, sluit u alle geopende Office-bestanden en wist u vervolgens de Office-documentcache.

  4. Als het wissen van de Office-documentcache geen tijdelijke Office-bestanden verwijdert die nog worden gesynchroniseerd, controleert u of de bestanden handmatig kunnen worden verwijderd.

    Waarschuwing

    Dit kan leiden tot gegevensverlies van het Office-document. Zorg er daarom voor dat de bestanden veilig kunnen worden verwijderd.

  5. Als de bestanden geen tijdelijke Office-bestanden zijn, bepaalt u of ze veilig kunnen worden verwijderd. Als ze niet kunnen worden verwijderd, verplaatst u ze uit de OneDrive-map om te zien of het probleem is opgelost.

Als er geen verborgen of tijdelijke bestanden zijn die ervoor zorgen dat de synchronisatiestatus onjuist is, controleert u of dit probleem wordt veroorzaakt door de Windows Search-index:

  1. Selecteer Start, voer Services in en selecteer vervolgens Services in de zoekresultaten om de Service-toepassing te openen.

  2. Dubbelklik op Windows Search en wijzig het opstarttype in Uitgeschakeld.

  3. Selecteer in Servicestatusde optie Stoppen.

  4. Selecteer OK.

  5. Vernieuw het Bestandenverkenner venster. Als de inhoud van de OneDrive-map niet meer wordt weergegeven als 'synchroniseren', wordt het probleem veroorzaakt door de zoekindex in de cache. Volg de volgende stappen om dit probleem op te lossen.

  6. Ga terug naar de toepassing Services en zet het opstarttype van de Windows Search-service terug op Automatisch (vertraagd starten).

  7. De Windows Search-index opnieuw opbouwen:

    1. Selecteer Start, voer Indexering in en selecteer vervolgens Indexeringsopties in de zoekresultaten.

    2. Selecteer Geavanceerde>herbouw.

      Opmerking

      Dit proces kan enige tijd in beslag nemen. Deze wordt sneller uitgevoerd als de computer niet in gebruik is. Daarom raden we u aan de index opnieuw op te bouwen buiten gebruikstijden, zoals 's nachts of in het weekend. Als het probleem niet is opgelost, is er mogelijk een probleem in de indexeringslaag. Zie Problemen oplossen in Windows Search voor meer informatie.

Alle bestanden en mappen geven de status 'synchroniseren' weer

Oorzaak

Dit probleem kan optreden als het UseFindFirstFileEnumeration Windows-beleid is ingesteld op Waar. Dit beleid is ontworpen voor verouderde bestandssystemen. Het is niet compatibel met OneDrive Files on Demand. Als dit beleid is ingesteld op Waar, kunt Bestandenverkenner de code reparse voor bestanden en mappen niet lezen. Daarom worden alle bestanden en mappen ingesteld op de standaardstatus 'synchroniseren'.

Oplossing

U kunt dit probleem oplossen door deze stappen uit te voeren om de registerwaarde te verwijderen of de UseFindFirstFileEnumeration waarde ervan te wijzigen in 0.

Belangrijk

Volg de stappen in deze sectie zorgvuldig. Als u het register onjuist bewerkt, kunnen er grote problemen optreden. Maak een back-up van het register voor herstel in geval van problemen voordat u het wijzigt.

  1. Selecteer Start, voer regedit in en selecteer vervolgens Register Editor in de zoekresultaten.

  2. Zoek de volgende registersubsleutel:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Explorer

  3. Klik met de rechtermuisknop op UseFindFirstFileEnumerationen selecteer vervolgens Verwijderen. Of selecteer Wijzigen en stel de waarde in op 0.

  4. Start Bestandenverkenner opnieuw.