Sysprep mislukt nadat u Microsoft Store-apps met ingebouwde Windows-installatiekopieën hebt verwijderd of bijgewerkt
In dit artikel wordt een probleem besproken dat optreedt wanneer u een ingerichte Microsoft Store-app verwijdert of bijwerkt met behulp van de Microsoft Store en vervolgens sysprep uitvoert op de computer.
Van toepassing op: Windows 10 - alle edities, Windows 11
Oorspronkelijk KB-nummer: 2769827
Inleiding
Sysprep is een hulpprogramma voor IT-beheerders die een installatie van Windows willen voorbereiden op duplicatie, controle en levering van klanten. De richtlijnen in dit artikel zijn bedoeld voor gebruik door ondersteuningsmedewerkers en IT-professionals. Als u een thuisgebruiker bent die problemen ondervindt tijdens het gebruik van Microsoft Store-apps, raadpleegt u Problemen met apps uit de Microsoft Store oplossen.
Verschillende Microsoft Store-apps zijn ingebouwd in Windows-installatiekopieën. Deze apps omvatten onder andere de apps Mail, Kaarten, Berichten, Bing, Reizen en Nieuws. Deze apps worden ook wel ingerichte apps genoemd. Ingerichte apps worden gefaseerd in de installatiekopieën en moeten worden geïnstalleerd voor elke gebruiker van de Windows-installatiekopieën bij de eerste aanmelding. Naast de ingebouwde apps kunt u uw eigen Line-Of-Business Microsoft Store-apps sideloaden in de Windows-installatiekopie zonder ze naar de Microsoft Store te hoeven publiceren. U kunt pakketten sideloaden met behulp van online- of offlineserviceopdrachten die beschikbaar zijn in DISM.exe of via de DISM PowerShell-module Appx
.
Symptomen
Bekijk de volgende scenario's:
Scenario 1
- U maakt een aangepaste Windows 10- of Windows 11-referentiecomputer die u wilt sysprep en vastleggen.
- U wilt enkele van de ingerichte Microsoft Store-apps (
Appx
pakketten) van deze referentiecomputer verwijderen. - U kunt de
dism -online /Remove-ProvisionedAppxPackage /PackageName:<packagename>
inrichting van deAppx
pakketten ongedaan maken.
Wanneer u in dit scenario sysprep-bewerking uitvoert, kan de bewerking mislukken met de volgende fout:
Hulpprogramma voor systeemvoorbereiding 3.14
Er is een onherstelbare fout opgetreden tijdens het proberen om de computer te sysprep
Scenario 2
- U hebt een bestaande Windows-installatiekopieën en verschillende Microsoft Store-apps worden naast elkaar geladen in de installatiekopieën.
- U wilt enkele van de sideloadingpakketten
Appx
uit uw installatiekopieën verwijderen en deze verder aanpassen. - U start op de referentiecomputer op en voert een van de volgende PowerShell-opdrachten uit om het inrichten van het
Appx
pakket te verwijderen:Remove-AppxProvisionedPackage -PackageName <packagename>
Remove-ProvisionedAppxPackage -PackageName <packagename>
Wanneer u in dit scenario sysprep-bewerking uitvoert, kan de bewerking mislukken met de volgende fout:
Hulpprogramma voor systeemvoorbereiding 3.14
Er is een onherstelbare fout opgetreden tijdens het proberen om de computer te sysprep
Scenario 3
- U maakt een windows 10- of Windows 11-referentieafbeelding.
- U maakt verbinding met de Microsoft Store en vervolgens werkt u de ingebouwde Microsoft Store-apps bij met behulp van de Microsoft Store.
Wanneer u in dit scenario sysprep-bewerking uitvoert, kan de bewerking mislukken met de volgende fout:
Hulpprogramma voor systeemvoorbereiding 3.14 Er is een fatale fout opgetreden tijdens het proberen om de computer te sysprep
Bovendien ziet u in de SetupErr.log mogelijk de volgende foutvermeldingen:
<Datum></tijd>, fout SYSPRP PackageFullName> <is geïnstalleerd voor een gebruiker, maar niet ingericht voor alle gebruikers. Dit pakket werkt niet goed in de sysprep-installatiekopieën.
<Datum></tijd>, fout SYSPRP kan geen apps voor de huidige gebruiker verwijderen: 0x80073cf2.
<Date><Time>, Error SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.
<Datum></tijd>, fout [0x0f0082] SYSPRP ActionPlatform::LaunchModule: fout opgetreden tijdens het uitvoeren van SysprepGeneralize vanuit C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
<Datum></tijd>, fout SYSPRP ActionPlatform::ExecuteAction: Fout bij het uitvoeren van de actie; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteActionList: Error in execute actions; dwRet = 0x3cf2
<Datum></tijd>, fout SYSPRP SysprepSession::Execute: Error in executing actions from C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP RunPlatformActions:Failed while executeing SysprepSession actions; dwRet = 0x3cf2
<Datum></tijd>, fout [0x0f0070] SYSPRP RunExternalDlls:Er is een fout opgetreden tijdens het uitvoeren van register sysprep-DLL's, waardoor de uitvoering van sysprep wordt gestopt. dwRet = 0x3cf2
<Date><Time>, Error [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0x80073cf2
Oorzaak
Sysprep heeft een extra provider die in Windows is toegevoegd om pakketten op te schonen Appx
en de installatiekopieën te generaliseren. De provider werkt alleen als het Appx
pakket een pakket per gebruiker of een door alle gebruikers ingericht pakket is.
- Pakket per gebruiker betekent dat het
Appx
pakket is geïnstalleerd voor een bepaald gebruikersaccount en niet beschikbaar is voor andere gebruikers van de computer. - Alle gebruikerspakketten betekent dat het
Appx
is ingericht in de installatiekopieën, zodat alle gebruikers die deze installatiekopieën gebruiken, toegang hebben tot de app.
Als een pakket voor alle gebruikers dat in de installatiekopieën is ingericht, handmatig uit de installatiekopieën is verwijderd, maar niet voor een bepaalde gebruiker is verwijderd, treedt er een fout op tijdens het opschonen van dit pakket tijdens sysprep. De provider mislukt ook als een pakket voor alle gebruikers dat is ingericht in de installatiekopieën is bijgewerkt door een van de gebruikers op deze referentiecomputer.
Oplossing
Als u dit probleem wilt oplossen, verwijdert u het pakket voor de gebruiker die sysprep uitvoert en verwijdert u ook de inrichting. Daarvoor voert u de volgende stappen uit.
Notitie
Als u wilt voorkomen dat microsoft Store apps bijwerkt, koppelt u de internetverbinding los of schakelt u Automatische updates uit in de controlemodus voordat u de installatiekopieën maakt.
Voer de volgende PowerShell-cmdlets uit:
Import-Module Appx Import-Module Dism Get-AppxPackage -AllUsers | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation
Notitie
- Controleer in de uitvoer van deze laatste cmdlet de gebruikers voor wie het pakket wordt weergegeven als Geïnstalleerd. Verwijder deze gebruikersaccounts van de referentiecomputer of meld u aan bij de computer met behulp van deze gebruikersaccounts. Voer vervolgens de cmdlet uit in stap 2 om het
Appx
pakket te verwijderen. - Met deze opdracht worden alle pakketten weergegeven die zijn gepubliceerd door Microsoft en geïnstalleerd door elke gebruiker van die referentiecomputer. Omdat de computer moet worden sysprepped, gaan we ervan uit dat deze gebruikersprofielen het pakket niet meer nodig hebben.
- Als u handmatig ingerichte apps hebt die deel uitmaken van andere uitgevers, voert u de volgende opdracht uit om deze weer te geven:
Get-AppxPackage -AllUsers | Format-List -Property PackageFullName,PackageUserInformation
Verwijder
Appx
het pakket door de volgende cmdlet uit te voeren:Remove-AppxPackage -Package <packagefullname>
Verwijder de inrichting door de volgende cmdlet uit te voeren:
Remove-AppxProvisionedPackage -Online -PackageName <packagefullname>
Als u probeert te herstellen na een updateprobleem, kunt u de app opnieuw inrichten nadat u deze stappen hebt uitgevoerd.
Notitie
Het probleem treedt niet op als u een offlineinstallatiekopie onderhoudt. In dat scenario wordt het inrichten automatisch gewist voor alle gebruikers. Dit omvat de gebruiker die de opdracht uitvoert.
Meer informatie
Zie voor meer informatie over het toevoegen en verwijderen van apps:
Gegevens verzamelen
Als u hulp nodig hebt van Microsoft-ondersteuning, raden we u aan de informatie te verzamelen door de stappen te volgen die worden vermeld in Informatie verzamelen met behulp van TSS voor implementatiegerelateerde problemen.