Delen via


De nieuwe printerstatus is offline nadat u een afdrukwachtrij hebt verwijderd en vervolgens een Windows-computer opnieuw hebt opgestart

Dit artikel bevat een oplossing voor een probleem waarbij de status van de nieuwe printer offline is nadat u een afdrukwachtrij hebt verwijderd en vervolgens een Windows-computer opnieuw hebt opgestart.

Oorspronkelijk KB-nummer: 2027593

Symptomen

Bekijk het volgende scenario:

  • U verwijdert een afdrukwachtrij terwijl deze de status Offline heeft.
  • U voegt een nieuwe afdrukwachtrij toe met dezelfde naam als de oude afdrukwachtrij.
  • U start de computer opnieuw op.

In dit scenario wordt de status van de nieuwe afdrukwachtrij weergegeven als Offline.

Oorzaak

Dit probleem treedt op als de computer de volgende registerwaarde heeft geconfigureerd wanneer u de printer instelt op de status Offline :

Sleutel: Waarde: HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\<print queue name> PrinterOnLine
Gegevens: 0

Deze waarde wordt echter niet verwijderd door het Localspl.dll bestand wanneer de afdrukwachtrij wordt verwijderd. Wanneer u dus een afdrukwachtrij met dezelfde naam als de oude afdrukwachtrij toevoegt, neemt de nieuwe printerwachtrij de offlinestatus van de verwijderde afdrukwachtrij over.

Oplossing

Als u dit probleem wilt oplossen, klikt u met de rechtermuisknop op de nieuwe afdrukwachtrij in het hulpmiddel Printers en Faxen en schakelt u de instelling Printer offline gebruiken uit. Hiermee wordt de registersleutel opnieuw ingesteld op de juiste waarde. In plaats daarvan kunt u de registersleutel verwijderen die wordt vermeld in de sectie Oorzaak nadat u een afdrukwachtrij hebt verwijderd, maar voordat u een nieuwe afdrukwachtrij met dezelfde naam toevoegt.

Is het probleem opgelost

  • Controleer of het probleem is opgelost. Als het probleem is opgelost, bent u klaar met deze sectie. Als het probleem niet is opgelost, kunt u contact opnemen met de ondersteuning.
  • Wij stellen uw feedback zeer op prijs. Als u feedback wilt geven of problemen met deze oplossing wilt melden, laat u een opmerking achter door ons een e-mailbericht te sturen.

Gegevens verzamelen

Als u hulp nodig hebt van Microsoft Ondersteuning, raden we u aan de informatie te verzamelen door de stappen te volgen die worden vermeld in Gegevens verzamelen met behulp van TSS voor problemen met de gebruikerservaring.