Supported Kubernetes versions in Azure Kubernetes Service (AKS) (Obsługiwane wersje rozwiązania Kubernetes w usłudze Azure Kubernetes Service)

Społeczność platformy Kubernetes publikuje wersje pomocnicze mniej więcej co cztery miesiące.

Wersje pomocnicze obejmują nowe funkcje i ulepszenia. Wersje poprawek są częstsze (czasami co tydzień) i są przeznaczone dla krytycznych poprawek błędów w wersji pomocniczej. Wersje poprawek obejmują poprawki luk w zabezpieczeniach lub głównych usterek.

Wersje platformy Kubernetes

Platforma Kubernetes używa standardowego schematu przechowywania wersji semantycznych dla każdej wersji:

[major].[minor].[patch]

Examples:
  1.29.2
  1.29.1

Każda liczba w wersji wskazuje ogólną zgodność z poprzednią wersją:

  • Wersje główne zmieniają się, gdy niezgodne aktualizacje interfejsu API lub zgodność z poprzednimi wersjami mogą być uszkodzone.
  • Wersje pomocnicze zmieniają się po wprowadzeniu aktualizacji funkcji, które są zgodne wstecz z innymi wersjami pomocniczymi.
  • Wersje poprawek zmieniają się po wprowadzeniu poprawek usterek zgodnych z poprzednimi wersjami.

Staraj się uruchomić najnowszą wersję poprawki uruchomionej wersji pomocniczej. Jeśli na przykład klaster produkcyjny jest włączony 1.29.1 i 1.29.2 jest najnowszą dostępną wersją poprawki dostępną dla wersji pomocniczej 1.29 , należy uaktualnić klaster do 1.29.2 możliwie najszybszego, aby upewnić się, że klaster jest w pełni poprawiony i obsługiwany.

Kalendarz wydania usługi AKS Kubernetes

Wyświetl nadchodzące wersje w kalendarzu wydania usługi AKS Kubernetes. Aby wyświetlić aktualizacje stanu wersji regionu i informacje o wersji w czasie rzeczywistym, odwiedź stronę internetową stanu wydania usługi AKS. Aby dowiedzieć się więcej na temat strony internetowej ze stanem wydania, zobacz Monitor wersji usługi AKS.

Uwaga

Usługa AKS jest zgodna z 12-miesięczną obsługą ogólnie dostępnej wersji platformy Kubernetes. Aby dowiedzieć się więcej na temat naszych zasad pomocy technicznej dotyczących przechowywania wersji na platformie Kubernetes, przeczytaj często zadawane pytania.

Aby zapoznać się z przeszłością historii wersji, zobacz Historia platformy Kubernetes.

Wersja K8s Wersja nadrzędna Wersja zapoznawcza usługi AKS Usługa AKS (ogólna dostępność) Koniec życia Obsługa platform
1,26 Grudzień 2022 r. Luty 2023 r. Kwiecień 2023 r. Mar 2024 Do 1.30 GA
1.27* Kwiecień 2023 r. Czerwiec 2023 r. Lipiec 2023 Lipiec 2024, LTS do lipca 2025 r. Do 1.31 GA
1.28 Sierpień 2023 r. Wrzesień 2023 r. Listopad 2023 r. Listopad 2024 r. Do 1.32 GA
1,29 Grudzień 2023 r. Luty 2024 r. Mar 2024 Do 1.33 ogólna dostępność
1,30 Kwiecień 2024 r. Maj 2024 r. Czerwiec 2024 r. Do 1.34 GA

* Wskazuje, że wersja jest przeznaczona do obsługi długoterminowej

Wykres Gantta harmonogramu wydania usługi AKS Kubernetes

Jeśli wolisz wyświetlić te informacje wizualnie, oto wykres Gantta ze wszystkimi wyświetlanymi bieżącymi wersjami:

Wykres Gantta przedstawiający cykl życia wszystkich wersji platformy Kubernetes, które są obecnie aktywne w usłudze AKS.

Zmiany powodujące niezgodność składników usługi AKS według wersji

Przed uaktualnieniem do dowolnej z dostępnych wersji pomocniczych należy pamiętać o następujących ważnych zmianach:

Wersja rozwiązania Kubernetes Dodatki zarządzane przez usługę AKS Składniki usługi AKS Składniki systemu operacyjnego Zmiany powodujące niezgodność Uwagi
1,26 Azure Policy 1.3.0
Metrics-Server 0.6.3
KEDA 2.10.1
Otwórz usługę Service Mesh 1.2.3
Podstawowa wersja DNS 1.9.4
Nakładka VPA 0.11.0
Azure-Keyvault-SecretsProvider 1.4.1
Kontroler ruchu przychodzącego usługi Application Gateway (AGIC) 1.5.3
Image Cleaner v1.2.3
Tożsamość obciążenia platformy Azure w wersji 1.0.0
MDC Defender 1.0.56
Tożsamość zasobnika usługi Azure Active Directory 1.8.13.6
GitOps 1.7.0
KMS 0.5.0
azurefile-csi-driver 1.26.10
Cilium 1.12.8
CNI 1.4.44
Skalowanie automatyczne klastra 1.8.5.3
Obraz systemu operacyjnego Ubuntu 22.04 Cgroups V2
ContainerD 1.7
Azure Linux 2.0
Grupy Cgroup w wersji 1
ContainerD 1.6
azurefile-csi-driver 1.26.10 Brak
1.27 Azure Policy 1.3.0
azuredisk-csi driver v1.28.5
azurefile-csi driver v1.28.7
blob-csi v1.22.4
csi-attacher v4.3.0
csi-resizer v1.8.0
csi-snapshotter v6.2.2
snapshot-controller v6.2.2
Metrics-Server 0.6.3
Keda 2.11.2
Otwórz usługę Service Mesh 1.2.3
Podstawowa wersja DNS 1.9.4
Nakładka VPA 0.11.0
Azure-Keyvault-SecretsProvider 1.4.1
Kontroler ruchu przychodzącego usługi Application Gateway (AGIC) 1.7.2
Image Cleaner v1.2.3
Tożsamość obciążenia platformy Azure w wersji 1.0.0
MDC Defender 1.0.56
Tożsamość zasobnika usługi Azure Active Directory 1.8.13.6
GitOps 1.7.0
azurefile-csi-driver 1.28.7
KMS 0.5.0
Sterownik magazynu tajnego CSI 1.3.4-1
Cilium 1.13.10-1
CNI 1.4.44
Skalowanie automatyczne klastra 1.8.5.3
Obraz systemu operacyjnego Ubuntu 22.04 Cgroups V2
ContainerD 1.7 dla systemów Linux i 1.6 dla systemu Windows
Azure Linux 2.0
Grupy Cgroup w wersji 1
ContainerD 1.6
Keda 2.11.2
Cilium 1.13.10-1
azurefile-csi-driver 1.28.7
azuredisk-csi driver v1.28.5
blob-csi v1.22.4
csi-attacher v4.3.0
csi-resizer v1.8.0
csi-snapshotter v6.2.2
snapshot-controller v6.2.2
Ze względu na stan certyfikacji FIPS systemu Ubuntu 22.04 przełączymy węzły AKS FIPS z wersji 18.04 na 20.04 z wersji 1.27.
1.28 Azure Policy 1.3.0
azurefile-csi-driver 1.29.2
csi-node-driver-rejestrator v2.9.0
csi-livenessprobe 2.11.0
azuredisk-csi-linux v1.29.2
azuredisk-csi-windows v1.29.2
csi-provisioner v3.6.2
csi-attacher v4.5.0
csi-resizer v1.9.3
csi-snapshotter v6.2.2
snapshot-controller v6.2.2
Metrics-Server 0.6.3
KEDA 2.11.2
Otwórz usługę Service Mesh 1.2.7
Podstawowa wersja DNS 1.9.4
Nakładka VPA 0.13.0
Azure-Keyvault-SecretsProvider 1.4.1
Kontroler ruchu przychodzącego usługi Application Gateway (AGIC) 1.7.2
Image Cleaner v1.2.3
Tożsamość obciążenia platformy Azure w wersji 1.2.0
MDC Defender Security Publisher 1.0.68
Sterownik magazynu tajnego CSI 1.3.4-1
MDC Defender Old File Cleaner 1.3.68
MDC Defender Pod Collector 1.0.78
Moduł zbierający niskiego poziomu usługi MDC Defender 1.3.81
Tożsamość zasobnika usługi Azure Active Directory 1.8.13.6
GitOps 1.8.1
Cilium 1.13.10-1
CNI v1.4.43.1 (ustawienie domyślne)/v1.5.11 (nakładka azure CNI)
Skalowanie automatyczne klastra 1.27.3
Tigera-Operator 1.28.13
Obraz systemu operacyjnego Ubuntu 22.04 Cgroups V2
ContainerD 1.7.5 dla systemów Linux i 1.7.1 dla systemu Windows
Azure Linux 2.0
Grupy Cgroup w wersji 1
ContainerD 1.6
azurefile-csi-driver 1.29.2
csi-resizer v1.9.3
csi-attacher v4.4.2
csi-provisioner v4.4.2
blob-csi v1.23.2
azurefile-csi driver v1.29.2
azuredisk-csi driver v1.29.2
csi-livenessprobe v2.11.0
csi-node-driver-rejestrator v2.9.0
Brak
1,29 Azure Policy 1.3.0
csi-provisioner v4.0.0
csi-attacher v4.5.0
csi-snapshotter v6.3.3
snapshot-controller v6.3.3
Metrics-Server 0.6.3
KEDA 2.11.2
Otwórz usługę Service Mesh 1.2.7
Podstawowa wersja DNS 1.9.4
Nakładka VPA 0.13.0
Azure-Keyvault-SecretsProvider 1.4.1
Kontroler ruchu przychodzącego usługi Application Gateway (AGIC) 1.7.2
Image Cleaner v1.2.3
Tożsamość obciążenia platformy Azure w wersji 1.2.0
MDC Defender Security Publisher 1.0.68
MDC Defender Old File Cleaner 1.3.68
MDC Defender Pod Collector 1.0.78
Moduł zbierający niskiego poziomu usługi MDC Defender 1.3.81
Tożsamość zasobnika usługi Azure Active Directory 1.8.13.6
GitOps 1.8.1
Sterownik magazynu tajnego CSI 1.3.4-1
azurefile-csi-driver 1.29.3
Cilium 1.13.5
CNI v1.4.43.1 (ustawienie domyślne)/v1.5.11 (nakładka azure CNI)
Skalowanie automatyczne klastra 1.27.3
Tigera-Operator 1.30.7
Obraz systemu operacyjnego Ubuntu 22.04 Cgroups V2
ContainerD 1.7.5 dla systemów Linux i 1.7.1 dla systemu Windows
Azure Linux 2.0
Grupy Cgroup w wersji 1
ContainerD 1.6
Tigera-Operator 1.30.7
csi-provisioner v4.0.0
csi-attacher v4.5.0
csi-snapshotter v6.3.3
snapshot-controller v6.3.3
Brak

Wersja pomocnicza aliasu

Uwaga

Wersja pomocnicza aliasu wymaga interfejsu wiersza polecenia platformy Azure w wersji 2.37 lub nowszej, a także wersji interfejsu API 20220401 lub nowszej. Użyj az upgrade polecenia , aby zainstalować najnowszą wersję interfejsu wiersza polecenia.

Usługa AKS umożliwia utworzenie klastra bez określania dokładnej wersji poprawki. Podczas tworzenia klastra bez wyznaczania poprawki klaster uruchamia najnowszą poprawkę ogólnie dostępnej wersji pomocniczej. Jeśli na przykład utworzysz klaster z elementem 1.29 i 1.29.2 jest dostępna najnowsza poprawka ogólnie dostępnej, klaster zostanie utworzony za pomocą polecenia 1.29.2. Jeśli chcesz uaktualnić wersję poprawki w tej samej wersji pomocniczej, użyj automatycznego uaktualniania.

Aby zobaczyć, jaka poprawka jest włączona, uruchom az aks show --resource-group myResourceGroup --name myAKSCluster polecenie . Właściwość currentKubernetesVersion zawiera całą wersję platformy Kubernetes.

{
 "apiServerAccessProfile": null,
  "autoScalerProfile": null,
  "autoUpgradeProfile": null,
  "azurePortalFqdn": "myaksclust-myresourcegroup.portal.hcp.eastus.azmk8s.io",
  "currentKubernetesVersion": "1.29.2",
}

Zasady obsługi wersji platformy Kubernetes

Usługa AKS definiuje ogólnie dostępną wersję jako wersję dostępną we wszystkich regionach i włączoną we wszystkich pomiarach slo lub SLA. Usługa AKS obsługuje trzy wersje pomocnicze ogólnie dostępne na platformie Kubernetes:

  • Najnowsza wersja pomocnicza ga wydana w usłudze AKS (która jest nazywana N).
  • Dwie poprzednie wersje pomocnicze.
    • Każda obsługiwana wersja pomocnicza obsługuje również maksymalnie dwie stabilne poprawki.

Usługa AKS może również obsługiwać wersje wersji zapoznawczej, które są jawnie oznaczone etykietą i podlegają warunkom i warunkom wersji zapoznawczej.

Usługa AKS zapewnia obsługę platformy tylko dla jednej wersji pomocniczej ogólnie dostępnej platformy Kubernetes po regularnych obsługiwanych wersjach. Okno obsługi platformy wersji platformy Kubernetes w usłudze AKS jest nazywane "N-3". Aby uzyskać więcej informacji, zobacz Zasady pomocy technicznej platformy.

Uwaga

Usługa AKS korzysta z bezpiecznych rozwiązań wdrażania, które obejmują stopniowe wdrażanie regionów. Oznacza to, że udostępnienie nowej wersji we wszystkich regionach może potrwać do 10 dni roboczych.

Obsługiwane okno wersji pomocniczych platformy Kubernetes w usłudze AKS jest nazywane "N-2", gdzie N odnosi się do najnowszej wersji, co oznacza, że obsługiwane są również dwie poprzednie wersje pomocnicze.

Na przykład w dniu wprowadzenia usługi AKS w wersji 1.29 pomoc techniczna jest dostępna dla następujących wersji:

Nowa wersja pomocnicza Lista obsługiwanych wersji pomocniczych
1,29 1.29, 1.28, 1.27

Po wprowadzeniu nowej wersji pomocniczej najstarsza wersja pomocnicza jest przestarzała i usuwana. Załóżmy na przykład, że bieżąca obsługiwana lista wersji pomocniczych to:

1.29
1.28
1.27

Gdy usługa AKS wyda 1.30, wszystkie wersje 1.27 nie będą obsługiwane 30 dni później.

Usługa AKS obsługuje również maksymalnie dwie wersje poprawek danej wersji pomocniczej. Na przykład biorąc pod uwagę następujące obsługiwane wersje:

Current Supported Version List
------------------------------
1.29.2, 1.29.1, 1.28.7, 1.28.6, 1.27.11, 1.27.10

Jeśli wersje 1.29.3 usługi AKS i 1.28.8, najstarsze wersje poprawek są przestarzałe i usuwane, a lista obsługiwanych wersji stanie się:

New Supported Version List
----------------------
1.29.3, 1.29.2, 1.28.8, 1.28.7, 1.27.11, 1.27.10

Zasady obsługi platformy

Zasady pomocy technicznej platformy to ograniczony plan pomocy technicznej dla niektórych nieobsługiwanych wersji platformy Kubernetes. Podczas pomocy technicznej platformy klienci otrzymują pomoc techniczną od firmy Microsoft tylko w przypadku problemów związanych z platformą AKS/Azure. Wszelkie problemy związane z funkcjonalnością i składnikami platformy Kubernetes nie są obsługiwane.

Zasady obsługi platformy dotyczą klastrów w wersji n-3 (gdzie n jest najnowszą obsługiwaną wersją pomocniczą usługi AKS GA), zanim klaster spadnie do n-4. Na przykład platforma Kubernetes v1.26 jest traktowana jako obsługa platformy, gdy wersja 1.29 jest najnowszą wersją ogólnie dostępnej. Jednak w wersji 1.30 ogólnie dostępnej wersja v1.26 zostanie automatycznie uaktualniona do wersji 1.27. Jeśli korzystasz z wersji n-2, moment, w którym stanie się on n-3, staje się również przestarzały i wchodzisz w zasady pomocy technicznej platformy.

Usługa AKS opiera się na wydaniach i poprawkach z platformy Kubernetes, czyli projektu open source, który obsługuje tylko okno przesuwne trzech wersji pomocniczych. Usługa AKS może zagwarantować pełną obsługę tylko wtedy, gdy te wersje są obsługiwane jako nadrzędne. Ponieważ nie ma więcej poprawek tworzonych nadrzędnie, usługa AKS może pozostawić te wersje niezaznaczone lub rozwidlenie. Ze względu na to ograniczenie obsługa platformy nie obsługuje żadnych funkcji opartych na nadrzędnym rozwiązaniu Kubernetes.

W tej tabeli opisano wytyczne dotyczące pomocy technicznej dla społeczności w porównaniu z obsługą platformy.

Kategoria pomocy technicznej Pomoc techniczna społeczności (N-2) Obsługa platformy (N-3)
Uaktualnienia z N-3 do obsługiwanej wersji Obsługiwane Obsługiwane
Dostępność platformy (Azure) Obsługiwane Obsługiwane
Skalowanie puli węzłów Obsługiwane Obsługiwane
Dostępność maszyny wirtualnej Obsługiwane Obsługiwane
Problemy związane z magazynem, siecią Obsługiwane Obsługiwane z wyjątkiem poprawek błędów i wycofanych składników
Uruchamianie/zatrzymywanie Obsługiwane Obsługiwane
Wymiana certyfikatów Obsługiwane Obsługiwane
Umowa SLA dotycząca infrastruktury Obsługiwane Obsługiwane
Umowa SLA płaszczyzny sterowania Obsługiwane Obsługiwane
Umowa SLA platformy (AKS) Obsługiwane Nieobsługiwane
Składniki platformy Kubernetes (w tym dodatki) Obsługiwane Nieobsługiwane
Aktualizacje składników Obsługiwane Nieobsługiwane
Poprawki składników Obsługiwane Nieobsługiwane
Stosowanie poprawek błędów Obsługiwane Nieobsługiwane
Stosowanie poprawek zabezpieczeń Obsługiwane Nieobsługiwane
Obsługa interfejsu API platformy Kubernetes Obsługiwane Nieobsługiwane
Tworzenie puli klastrów lub węzłów Obsługiwane Nieobsługiwane
Migawka puli węzłów Obsługiwane Nieobsługiwane
Uaktualnienie obrazu systemu węzła Obsługiwane Nieobsługiwane

Uwaga

Powyższa tabela podlega zmianie i zawiera opis typowych scenariuszy pomocy technicznej. Wszelkie scenariusze związane z funkcjami i składnikami platformy Kubernetes nie są obsługiwane w przypadku N-3. Aby uzyskać dalszą pomoc techniczną, zobacz Pomoc techniczna i rozwiązywanie problemów z usługą AKS.

Obsługiwane kubectl wersje

Możesz użyć jednej wersji pomocniczej starszej lub nowszej kubectl względem wersji kube-apiserver , zgodnej z zasadami obsługi platformy Kubernetes dla narzędzia kubectl.

Jeśli na przykład serwer kube-apiserver ma wartość 1.28, możesz użyć wersji 1.27 do 1.29 kubectl z tym serwerem kube-apiserver.

Aby zainstalować lub zaktualizować kubectl do najnowszej wersji, uruchom polecenie:

az aks install-cli

Obsługa długoterminowa (LTS)

Usługa AKS zapewnia roczną pomoc techniczną społeczności i jeden rok długoterminowego wsparcia technicznego (LTS) w celu zwrotu poprawek zabezpieczeń portów ze społeczności nadrzędnej w naszym repozytorium publicznym. Nasza nadrzędna grupa robocza LTS przyczynia się do wysiłków z powrotem do społeczności, aby zapewnić naszym klientom dłuższe okno pomocy technicznej.

Aby uzyskać więcej informacji na temat ltS, zobacz Długoterminowa obsługa usługi Azure Kubernetes Service (AKS).

Proces wydawania i wycofywania

Możesz odwołać się do nadchodzących wersji i wycofań w kalendarzu wydania usługi AKS Kubernetes.

W przypadku nowych wersji pomocniczych platformy Kubernetes:

  • Usługa AKS publikuje ogłoszenie z planowaną datą wydania nowej wersji i odpowiednim wycofaniem starej wersji w informacjach o wersji usługi AKS co najmniej 30 dni przed usunięciem.
  • Usługa AKS używa usługi Azure Advisor , aby otrzymywać alerty, jeśli nowa wersja może powodować problemy w klastrze z powodu przestarzałych interfejsów API. Usługa Azure Advisor ostrzega cię również, jeśli nie masz pomocy technicznej
  • Usługa AKS publikuje powiadomienie o kondycji usługi dostępne dla wszystkich użytkowników z dostępem do usługi AKS i portalu oraz wysyła wiadomość e-mail do administratorów subskrypcji z zaplanowanymi datami usunięcia wersji.

    Uwaga

    Aby dowiedzieć się, kto jest administratorami subskrypcji lub zmienić ją, zapoznaj się z tematem Zarządzanie subskrypcjami platformy Azure.

  • Od usunięcia wersji masz 30 dni od uaktualnienia do obsługiwanej wersji pomocniczej, aby nadal otrzymywać pomoc techniczną.

W przypadku nowych wersji poprawek platformy Kubernetes:

  • Ze względu na pilny charakter wersji poprawek można je wprowadzić do usługi w miarę ich dostępności. Po udostępnieniu poprawki mają minimalny cykl życia dwóch miesięcy.
  • Ogólnie rzecz biorąc, usługa AKS nie komunikuje się zasadniczo z wydaniem nowych wersji poprawek. Jednak usługa AKS stale monitoruje i weryfikuje dostępne poprawki CVE, aby obsługiwać je w usłudze AKS w odpowiednim czasie. Jeśli znaleziono poprawkę krytyczną lub wymagana jest akcja użytkownika, usługa AKS powiadomi Cię o uaktualnieniu do nowo dostępnej poprawki.
  • Od usunięcia wersji poprawki z usługi AKS w celu uaktualnienia do obsługiwanej poprawki i nadal otrzymujesz pomoc techniczną. Nie będzie już można tworzyć klastrów ani pul węzłów po wycofaniu/usunięciu wersji.

Obsługiwane wyjątki zasad wersji

Usługa AKS zastrzega sobie prawo do dodawania lub usuwania nowych/istniejących wersji z co najmniej jednym krytycznym problemem produkcyjnym lub problemami z zabezpieczeniami bez wcześniejszego powiadomienia.

Określone wersje poprawek mogą zostać pominięte lub przyspieszone w zależności od ważności błędu lub problemu z zabezpieczeniami.

Wersje witryny Azure Portal i interfejsu wiersza polecenia

Podczas wdrażania klastra usługi AKS za pomocą witryny Azure Portal, interfejsu wiersza polecenia platformy Azure, programu Azure PowerShell klaster jest domyślnie domyślnie w wersji pomocniczej N-1 i najnowszej poprawki. Jeśli na przykład usługa AKS obsługuje 1.29.2, 1.29.1, 1.28.7, 1.28.6, 1.27.11 i 1.27.10, wybrana wersja domyślna to 1.28.7.

Aby dowiedzieć się, jakie wersje są obecnie dostępne dla twojej subskrypcji i regionu, użyj az aks get-versions polecenia . W poniższym przykładzie wymieniono dostępne wersje platformy Kubernetes dla regionu EastUS :

az aks get-versions --location eastus --output table

Często zadawane pytania

Jak firma Microsoft powiadamia mnie o nowych wersjach platformy Kubernetes?

Zespół usługi AKS publikuje ogłoszenia z zaplanowanymi datami nowych wersji platformy Kubernetes w naszej dokumentacji, usłudze GitHub i wiadomościach e-mail do administratorów subskrypcji, którzy są właścicielami klastrów, które przestaną być obsługiwane. Usługa AKS używa również usługi Azure Advisor do zgłaszania alertów w witrynie Azure Portal w przypadku braku pomocy technicznej i informowania o przestarzałych interfejsach API, które mogą mieć wpływ na aplikację lub proces programowania.

Jak często należy oczekiwać uaktualnienia wersji platformy Kubernetes, aby pozostać w pomocy technicznej?

Począwszy od platformy Kubernetes 1.19, społeczność open source rozszerzyła wsparcie do jednego roku. Usługa AKS zatwierdza włączanie poprawek i obsługę dopasowywania zobowiązań nadrzędnych. W przypadku klastrów usługi AKS w wersji 1.19 lub nowszej można uaktualnić co najmniej raz w roku, aby pozostać w obsługiwanej wersji.

Co się stanie, gdy uaktualnisz klaster Kubernetes z wersją pomocniczą, która nie jest obsługiwana?

Jeśli korzystasz z wersji n-3 lub starszej, oznacza to, że jesteś poza pomocą techniczną i zostanie wyświetlony monit o uaktualnienie. Po pomyślnym uaktualnieniu z wersji n-3 do n-2 wróć do naszych zasad pomocy technicznej. Na przykład:

  • Jeśli najstarsza obsługiwana wersja pomocnicza usługi AKS to 1.27 i korzystasz z wersji 1.26 lub starszej, jesteś poza pomocą techniczną.
  • Po pomyślnym uaktualnieniu z wersji 1.26 do wersji 1.27 lub nowszej wróć do naszych zasad pomocy technicznej.

Zmiany na starszą dół nie są obsługiwane.

Co oznacza "Poza pomocą techniczną"?

"Poza pomocą techniczną" oznacza, że:

  • Uruchomiona wersja znajduje się poza listą obsługiwanych wersji.
  • Podczas żądania pomocy technicznej zostanie wyświetlony monit o uaktualnienie klastra do obsługiwanej wersji, chyba że okres prolongaty wynosi 30 dni po wycofaniu wersji.

Ponadto usługa AKS nie wykonuje żadnych gwarancji środowiska uruchomieniowego ani innych gwarancji dla klastrów spoza listy obsługiwanych wersji.

Co się stanie w przypadku skalowania klastra Kubernetes z wersją pomocniczą, która nie jest obsługiwana?

W przypadku wersji pomocniczych, które nie są obsługiwane przez usługę AKS, skalowanie w lub na wybiegu powinno nadal działać. Ponieważ nie ma gwarancji jakości usług, zalecamy uaktualnienie, aby przywrócić obsługę klastra.

Czy możesz pozostać w wersji Kubernetes na zawsze?

Jeśli klaster nie obsługuje ponad trzech (3) wersji pomocniczych i stwierdzono, że niesie ze sobą zagrożenia bezpieczeństwa, platforma Azure aktywnie kontaktuje się z Tobą w celu uaktualnienia klastra. Jeśli nie podejmiesz dalszych działań, platforma Azure zastrzega sobie prawo do automatycznego uaktualniania klastra w Twoim imieniu.

Co się stanie w przypadku skalowania klastra Kubernetes z wersją pomocniczą, która nie jest obsługiwana?

W przypadku wersji pomocniczych, które nie są obsługiwane przez usługę AKS, skalowanie w lub na wybiegu powinno nadal działać. Ponieważ nie ma gwarancji jakości usług, zalecamy uaktualnienie, aby przywrócić obsługę klastra.

Jaka wersja jest obsługiwana przez płaszczyznę sterowania, jeśli pula węzłów nie znajduje się w jednej z obsługiwanych wersji usługi AKS?

Płaszczyzna sterowania musi znajdować się w oknie wersji ze wszystkich pul węzłów. Aby uzyskać szczegółowe informacje na temat uaktualniania płaszczyzny sterowania lub pul węzłów, zapoznaj się z dokumentacją dotyczącą uaktualniania pul węzłów.

Jaka jest dozwolona różnica w wersjach między płaszczyzną sterowania i pulą węzłów?

Zasady niesymetryczności wersji umożliwiają teraz różnicę z maksymalnie 3 wersjami między płaszczyzną sterowania a pulami agentów. Usługa AKS jest zgodna z tą niesymetryczną zmianą zasad wersji począwszy od wersji 1.28.

Czy można pominąć wiele wersji usługi AKS podczas uaktualniania klastra?

Podczas uaktualniania obsługiwanego klastra usługi AKS nie można pominąć wersji pomocniczych platformy Kubernetes. Zasady niesymetryczności wersji płaszczyzn sterowania platformy Kubernetes nie obsługują pomijania wersji pomocniczej. Na przykład uaktualnienia między:

  • 1.28.x ->1.29.x: dozwolone.
  • 1.27.x ->1.28.x: dozwolone.
  • 1.27.x ->1.29.x: niedozwolone.

Aby uaktualnić z wersji 1.27.x ->1.29.x:

  1. Uaktualnij z wersji 1.27.x ->1.28.x.
  2. Uaktualnij z wersji 1.28.x ->1.29.x.

Pomijanie wielu wersji można wykonać tylko w przypadku uaktualniania z nieobsługiwanej wersji z powrotem do minimalnej obsługiwanej wersji. Na przykład można uaktualnić z nieobsługiwanej wersji 1.25.x do obsługiwanej wersji 1.27.x, jeśli wersja 1.27 jest minimalną obsługiwaną wersją pomocniczą.

Podczas uaktualniania z nieobsługiwanej wersji , która pomija co najmniej dwie wersje pomocnicze, uaktualnienie jest wykonywane bez żadnej gwarancji funkcjonalności i jest wykluczone z umów dotyczących poziomu usług i ograniczonej gwarancji. Klastry z nieobsługiwaną wersją mają elastyczność odłączania uaktualnień płaszczyzny sterowania z uaktualnieniami puli węzłów. Jeśli jednak wersja jest znacznie nieaktualna, zalecamy ponowne utworzenie klastra.

Czy mogę utworzyć nowy klaster 1.xx.x w 30-dniowym oknie pomocy technicznej?

L.p. Po wycofaniu/usunięciu wersji nie można utworzyć klastra w tej wersji. W miarę wdrażania zmian zaczniesz widzieć starą wersję usuniętą z listy wersji. Ten proces może potrwać do dwóch tygodni od ogłoszenia stopniowo według regionu.

Mam świeżo przestarzałą wersję, czy nadal mogę dodać nowe pule węzłów? A może muszę przeprowadzić uaktualnienie?

L.p. Nie możesz dodawać pul węzłów przestarzałej wersji do klastra. Tworzenie lub uaktualnianie pul węzłów do nieobsługiwanej wersji płaszczyzny kontroli wersji jest dozwolone, niezależnie od różnicy wersji między pulą węzłów a płaszczyzną sterowania. Dozwolone są tylko drobne uaktualnienia aliasów.

Jak często aktualizujesz poprawki?

Poprawki mają cykl życia minimum dwóch miesięcy. Aby być na bieżąco po wydaniu nowych poprawek, postępuj zgodnie z informacjami o wersji usługi AKS.

Następne kroki

Aby uzyskać informacje na temat uaktualniania klastra, zobacz: