Udostępnij za pośrednictwem


Rozwiązywanie problemów: kody błędów VPN typu site-to-site platformy Azure

W tym artykule wymieniono typowe kody błędów dla połączeń między lokalizacjami, które mogą wystąpić. Omówiono również możliwe przyczyny i rozwiązania tych problemów. Jeśli znasz kod błędu, możesz wyszukać rozwiązanie na tej stronie.

Przekroczono limit czasu negocjacji (kod błędu: 13805, szesnastkowy kod: 0X35ED)

Objaw

Błąd łączności.

Przyczyna

Lokalne urządzenie sieci VPN klienta nie odpowiada na żądania połączeń (komunikaty protokołu IKE) z bramy sieci VPN platformy Azure.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące kroki:

  1. Upewnij się, że lokalny adres IP jest poprawnie skonfigurowany w zasobie bramy sieci lokalnej na platformie Azure

  2. Sprawdź, czy lokalne urządzenie sieci VPN odbiera komunikaty IKE z bramy sieci VPN platformy Azure.

    • Jeśli pakiety IKE nie są odbierane w bramie lokalnej, sprawdź, czy istnieje zapora lokalna, która usuwa pakiety IKE.
    • Sprawdź dzienniki lokalnych urządzeń sieci VPN, aby dowiedzieć się, dlaczego urządzenie nie odpowiada na komunikaty IKE z bramy sieci VPN platformy Azure.
    • Wykonaj kroki zaradcze, aby upewnić się, że urządzenie lokalne odpowiada na żądania IKE usługi Azure VPN Gateway. Skontaktuj się z dostawcą urządzenia, aby uzyskać pomoc zgodnie z potrzebami.

Poświadczenia uwierzytelniania IKE są niedopuszczalne (kod błędu: 13801, szesnastkowo: 0X35E9)

Objaw

Błąd łączności.

Przyczyna

Niezgodność klucza wstępnego.

Rozwiązanie

Upewnij się, że klucz wstępny skonfigurowany w zasobie połączenia platformy Azure jest zgodny z kluczem wstępnego skonfigurowanym w tunelu lokalnego urządzenia sieci VPN.

Błąd dopasowania polityki (Kod błędu: 13868, HEX: 0X362C) / Brak skonfigurowanej polityki (Kod błędu: 13825, HEX: 0X3601)

Objaw

Błąd łączności.

Przyczyna

Niezgodność zasad IKE /IPsec.

Rozwiązanie

W przypadku konfigurowania niestandardowych zasad na zasobie połączenia w Azure, upewnij się, że polityki IKE skonfigurowane w tunelu urządzenia VPN w sieci lokalnej mają tę samą konfigurację.

Aby uzyskać konfigurację domyślnych zasad, sprawdź konfigurację zasad połączeń protokołu IPsec/IKE dla sieci VPN typu lokacja-lokacja oraz połączeń sieci VNet-do-VNet, aby zweryfikować, czy konfiguracja w tunelu lokalnego urządzenia sieci VPN jest zgodna.

Niedopuszczalne selektory ruchu (kod błędu: 13999, szesnastkowy: 0X36AF)

Objaw

Błąd łączności.

Przyczyna

Niezgodność konfiguracji selektora ruchu.

Rozwiązanie

Sprawdź dziennik urządzeń lokalnych, aby dowiedzieć się, dlaczego konfiguracja selektora ruchu proponowana przez bramę sieci VPN platformy Azure nie jest akceptowana przez urządzenie lokalne. Aby rozwiązać ten problem, użyj jednej z następujących metod:

Objaw

Błąd łączności.

Przyczyna

Brama sieci VPN odebrała nieobsługiwane komunikaty/protokoły IKE z lokalnego urządzenia sieci VPN.

Rozwiązanie

  1. Upewnij się, że urządzenie lokalne należy do jednego z obsługiwanych urządzeń. Zobacz Informacje o urządzeniach sieci VPN dla połączeń.

  2. Skontaktuj się z dostawcą urządzenia lokalnego, aby uzyskać pomoc.

Odbiorca nie może obsłużyć wersji protokołu IKE określonej w nagłówku komunikatu (kod błędu: 13880, Hex: 0X3638)

Objaw

Błąd łączności.

Przyczyna

Niezgodność wersji protokołu IKE

Rozwiązanie

Upewnij się, że wersja protokołu IKE (IKE v1 lub IKE v2) jest taka sama w zasobie połączenia na platformie Azure i w konfiguracji tunelu lokalnego urządzenia sieci VPN.

Niepowodzenie obliczeń Diffie-Hellman (Kod błędu: 13822, Hex: 0X35FE)

Objaw

Błąd łączności.

Przyczyna

Niepowodzenie w obliczeniach Diffie-Hellman.

Rozwiązanie

  1. W przypadku konfiguracji zasad niestandardowych na zasobie połączenia na platformie Azure sprawdź, czy grupa DH skonfigurowana w tunelu lokalnego urządzenia sieci VPN ma tę samą konfigurację.
  2. Aby uzyskać domyślną konfigurację grupy DH, sprawdź konfigurację zasad połączeń protokołu IPsec/IKE dla połączeń sieci VPN typu S2S i między sieciami wirtualnymi, aby upewnić się, że konfiguracja tunelu w lokalnym urządzeniu sieci VPN jest zgodna.
  3. Jeśli to nie rozwiąże problemu, skontaktuj się z dostawcą urządzenia sieci VPN w celu dalszego zbadania.

Komputer zdalny odmówił połączenia sieciowego (kod błędu: 1225, hex: 0X4C9)

Objaw

Błąd łączności.

Przyczyna

Zasób połączenia platformy Azure jest skonfigurowany jako tryb tylko inicjatora i może nie akceptować żadnych żądań połączenia z urządzenia lokalnego.

Rozwiązanie

Zaktualizuj właściwość trybu połączenia w zasobie połączenia na platformie Azure do domyślnej lub tylko odpowiedzi. Aby uzyskać więcej informacji, zobacz Ustawienia trybu połączenia.

Następne kroki

Aby uzyskać więcej informacji na temat rozwiązywania problemów z usługą VPN Gateway, zobacz Rozwiązywanie problemów z połączeniami typu lokacja-lokacja.