Omówienie zapytań w Power BI Desktop

Za pomocą programu Power BI Desktop możesz łączyć się ze światem danych, tworzyć atrakcyjne i podstawowe raporty oraz dzielić się swoimi wysiłkami z innymi osobami — którzy mogą następnie budować swoją pracę i rozwijać swoje wysiłki w zakresie analizy biznesowej.

Widoki programu Power BI Desktop

Program Power BI Desktop ma trzy widoki:

  • Widok raportu — możesz użyć utworzonych zapytań w celu utworzenia atrakcyjnych wizualizacji, uporządkowanych tak, jak chcesz je wyświetlić, oraz z wieloma stronami, które można udostępniać innym osobom.
  • Widok tabeli — zobacz dane w swoim raporcie w formacie modelu danych, gdzie można dodawać miary, tworzyć nowe kolumny i zarządzać relacjami.
  • Widok modelu — uzyskaj graficzną reprezentację relacji, które są ustanawiane w modelu danych, i zarządzaj nimi lub zmodyfikuj je w razie potrzeby.

Uzyskaj dostęp do tych widoków, wybierając jedną z trzech ikon po lewej stronie programu Power BI Desktop. Na poniższej ilustracji jest zaznaczony widok Raport , oznaczony żółtym pasmem obok ikony.

Zrzut ekranu programu Power BI Desktop przedstawiający wybrany widok raportu.

Program Power BI Desktop jest również dostarczany z Edytor Power Query. Użyj Edytor Power Query, aby połączyć się z jednym lub wieloma źródłami danych, kształtować i przekształcać dane zgodnie z potrzebami, a następnie załadować ten model do programu Power BI Desktop.

Ten artykuł zawiera omówienie pracy z danymi w Edytor Power Query, ale istnieje więcej informacji. Na końcu tego artykułu znajdziesz linki do szczegółowych wskazówek dotyczących obsługiwanych typów danych. Znajdziesz również wskazówki dotyczące nawiązywania połączenia z danymi, kształtowania danych, tworzenia relacji i rozpoczynania pracy.

Najpierw zapoznajmy się z Edytorem Power Query.

Edytor Power Query

Power BI Desktop oferuje dwa interfejsy Edytora Power Query:

  • Nowe środowisko Power Query (wersja zapoznawcza): przeprojektowany edytor z usprawnionym nawigacją, ulepszoną dostępnością i spójnym środowiskiem Power Query w programie Power BI Desktop, modelowaniu internetowym i innych produktach Fabric.
  • Klasyczny interfejs: Oryginalne okno Edytora Power Query.

W obu środowiskach używasz Edytor Power Query do łączenia się z jednym lub wieloma źródłami danych, kształtowania i przekształcania danych w celu spełnienia Twoich potrzeb, a następnie ładowania wyniku do programu Power BI Desktop. Wybierz kartę odpowiadającą używanemu środowisku.

Aby zapoznać się ze znanymi ograniczeniami, sposobami obejścia i miejscem, w którym możesz przekazać opinię, zobacz Znane ograniczenia i sposoby obejścia dotyczące nowego środowiska Power Query.

Uwaga / Notatka

Nowe środowisko Power Query jest w wersji zapoznawczej.

Wymagania wstępne

Power BI Desktop z włączoną funkcją zapoznawczą Nowe doświadczenie Power Query.

Aby włączyć nowy interfejs Power Query:

  1. Uruchom program Power BI Desktop.
  2. Przejdź do pozycji Plik>Opcje i ustawienia>Opcje.
  3. Zaznacz funkcje zapoznawcze, a następnie zaznacz pole wyboru Nowe środowisko Power Query.
  4. Kliknij przycisk OK.

Ta sama funkcja w wersji zapoznawczej umożliwia zarówno nowy interfejs Pobierz dane, jak i nowy Edytor Power Query. Aby powrócić do starszego edytora, wyczyść pole wyboru. Nie musisz ponownie uruchamiać programu Power BI Desktop. Aby uzyskać więcej informacji na temat nowego środowiska Pobierania danych, zobacz Pobieranie danych w programie Power BI Desktop.

Otwórz Edytor Power Query

Aby otworzyć Edytor Power Query, wybierz pozycję Przekształć dane na karcie Narzędzia główne Power BI Desktop.

Bez połączeń danych Edytor Power Query jest wyświetlany jako puste okienko gotowe na dane. Po załadowaniu zapytania edytor przedstawia pięć odrębnych składników. Numery w poniższej tabeli odpowiadają ponumerowanym objaśnieniom na zrzucie ekranu.

Zrzut ekranu nowego Edytora Power Query w programie Power BI Desktop, z każdym elementem obrysowanym i ponumerowanym.

# Składnik Opis
1 Wstążka Nawigacja na wstążce, która udostępnia wiele kart do dodawania przekształceń, wybierania opcji dla zapytania i korzystania z różnych przycisków wstążki w celu wykonywania różnych zadań.
2 Okienko zapytań Widok wszystkich dostępnych zapytań.
3 Bieżący widok Główny widok roboczy, który domyślnie wyświetla podgląd danych dla zapytania. Możesz również włączyć widok diagramu wraz z podglądem danych. Widok schematu i podgląd danych można przełączać przy zachowaniu widoku diagramu.
4 Ustawienia zapytania Widok aktualnie wybranego zapytania z odpowiednimi informacjami, takimi jak nazwa zapytania, kroki zapytania i różne wskaźniki.
5 Pasek stanu Pasek przedstawiający ważne informacje o zapytaniu, takie jak czas wykonywania, łączna liczba kolumn i wiersze oraz stan przetwarzania. Ten pasek zawiera również przyciski zmiany bieżącego widoku.

Każdy z tych składników jest opisany w poniższych sekcjach. Pełny przewodnik po interfejsie użytkownika Power Query można znaleźć w temacie Use Power Query to transform data (Używanie Power Query do przekształcania danych).

Wstążka

Wstążka jest składnikiem, w którym znajduje się większość przekształceń i akcji, które można wykonać w Edytor Power Query. Polecenia są pogrupowane na kartach Narzędzia główne, Przekształć, Dodaj kolumnę, Widok, Narzędzia i Pomoc. Każda karta zawiera określone przyciski i opcje, które zapewniają łatwy dostęp do przekształceń i akcji, które mogą być potrzebne.

Karta Narzędzia główne zawiera typowe zadania zapytań, w tym polecenia Pobierz dane używane do nawiązywania połączenia z danymi i rozpoczynania procesu tworzenia zapytań. Aby uzyskać więcej informacji na temat dostępnych źródeł danych, zobacz Źródła danych w programie Power BI Desktop. Aby uzyskać więcej informacji na temat używania łączników, zobacz Uzyskiwanie przeglądu danych.

Karta Przekształć zapewnia dostęp do typowych zadań przekształcania danych, takich jak dodawanie lub usuwanie kolumn, zmienianie typów danych i dzielenie kolumn. Karta Dodawanie kolumny zawiera więcej zadań skojarzonych z dodawaniem kolumny, formatowaniem danych kolumn i dodawaniem kolumn niestandardowych. Karta Widok steruje wyświetlanymi okienkami i widokami, a następnie otwiera Edytor zaawansowany.

Interfejs Power Query jest responsywny i dostosowuje się do rozdzielczości ekranu. Jeśli chcesz kompaktować wersję wstążki, wybierz przycisk zwijania w prawym dolnym rogu wstążki. Aby wrócić do standardowej wstążki, wybierz ikonę rozwijania w tym samym rogu.

Wiele zadań dostępnych na wstążce jest również dostępnych, klikając prawym przyciskiem myszy kolumnę lub inne dane w bieżącym widoku. Przekształcenia są często dostępne w więcej niż jednym miejscu, więc możesz korzystać z preferowanego środowiska.

Aby uzyskać więcej informacji na temat przekształcania danych, w tym przykładów, zobacz Samouczek: kształtowanie i łączenie danych w programie Power BI Desktop.

Okienko zapytań

W okienku Zapytania są wyświetlane wszystkie dostępne zapytania. Po wybraniu zapytania jego dane są wyświetlane w bieżącym widoku, w którym można kształtować i przekształcać dane zgodnie z potrzebami.

Wybierz ikonę w prawym górnym rogu okienka Zapytania , aby zwinąć okienko, a następnie wybierz ją ponownie, aby rozwinąć okienko. Podobne ikony w interfejsie umożliwiają zwinięcie lub rozwinięcie innych widoków i sekcji, dzięki czemu możesz skupić się na widoku, który jest dla Ciebie najważniejszy.

Aby uzyskać więcej informacji, zobacz okienko Zapytania.

Bieżący widok

Bieżący widok to główny widok roboczy. Domyślnie wyświetla podgląd danych dla wybranego zapytania. W tym obszarze wykonujesz większość pracy związanej z zapytaniami. Wybierz nagłówek kolumny lub kliknij go prawym przyciskiem myszy, aby wyświetlić przekształcenia dostępne dla tej kolumny. Wiele z tych elementów jest takich samych jak przyciski na kartach wstążki.

Po wybraniu przekształcenia zapytanie stosuje ten krok do danych. Zapisuje również krok w ramach samego zapytania. Okienko Ustawienia zapytania rejestruje kroki w kolejności sekwencyjnej, zgodnie z opisem w dalszej części tego artykułu.

Możesz również włączyć narzędzia profilowania danych, aby lepiej zrozumieć dane, w tym dystrybucję wartości i jakość kolumn. Włączaj i wyłączaj te narzędzia na karcie Widok według własnych potrzeb. Aby uzyskać więcej informacji, zobacz Korzystanie z narzędzi profilowania danych.

Przełączanie między widokami

Oprócz zwijanych okienek i sekcji można również przełączać wyświetlane widoki. Przejdź do karty Widok na wstążce, gdzie znajdują się grupy Podgląd i Układ , które kontrolują wygląd interfejsu.

Zrzut ekranu karty Widok w nowym Edytorze Power Query, pokazujący grupy Podgląd i Układ.

Po prawej stronie paska stanu znajdują się również ikony diagramu, danych i widoków schematu. Użyj tych ikon, aby zmienić widok między widokami lub włączyć i wyłączyć wybrany widok.

Wypróbuj te opcje, aby znaleźć widok i układ, z którym najlepiej pracujesz.

Widok schematu

Widok schematu oferuje szybki i prosty sposób interakcji tylko ze składnikami schematu dla tabeli, takimi jak nazwy kolumn i typy danych. Użyj widoku schematu, jeśli chcesz wykonywać akcje związane ze schematem, takie jak usuwanie kolumn, zmienianie nazw kolumn, zmienianie typów danych kolumn, zmienianie kolejności kolumn lub duplikowanie kolumn.

Zrzut ekranu przedstawiający widok schematu w nowym Edytor Power Query z kolumnami Nazwa, Typ i Klucz dla wybranego zapytania.

Gdy widok schematu jest aktywny, na wstążce zostanie wyświetlona karta Narzędzia schematu z akcjami, które mają zastosowanie do kolumn.

Aby uzyskać więcej informacji, zobacz Korzystanie z widoku schematu.

Widok diagramu

Widok diagramu ułatwia wizualizowanie struktury zapytania i sposobu interakcji z innymi zapytaniami w projekcie. Każdy krok w zapytaniu ma odrębną ikonę, która ułatwia rozpoznanie użytej transformacji, a wiersze łączą kroki w celu zilustrowania zależności.

Po włączeniu podglądu danych i widoku diagramu widok diagramu pojawi się w górnej części podglądu danych. Po włączeniu widoku diagramu wybierz znak plus, aby wyszukać nową transformację, która ma zostać dodana do zapytania.

Zrzut ekranu przedstawiający widok diagramu pokazany powyżej podglądu danych w nowym Edytor Power Query.

Aby uzyskać więcej informacji, zobacz Widok diagramu.

Okienko Ustawienia zapytania

Okienko Ustawienia zapytania zawiera informacje o aktualnie wybranym zapytaniu, takie jak nazwa zapytania, jego kroki i różne wskaźniki. Każde przekształcenie zastosowane do zapytania jest zapisywane jako krok w sekcji Zastosowane kroki .

Jeśli chcesz sprawdzić, jak Twoje zapytanie zmienia się na kolejnych etapach, wybierz etap, aby wyświetlić podgląd tego, do jakiej postaci zapytanie zostaje rozwinięte na tym etapie.

Ważne jest, aby wiedzieć, że dane bazowe nie są zmieniane. Zamiast tego Edytor Power Query dostosowuje i kształtuje widok danych.

Możesz zmienić nazwę kroków, usunąć kroki lub zmienić kolejność kroków zgodnie z potrzebami. W tym celu kliknij prawym przyciskiem myszy krok w sekcji Zastosowane kroki i wybierz z wyświetlonego menu. Wybierz pozycję Właściwości , aby zmienić nazwę kroku lub dodać do niego opis. Wszystkie kroki zapytania są wykonywane w kolejności ich wyświetlania.

Aby uzyskać więcej informacji, zobacz Using the Applied Steps list (Korzystanie z listy Zastosowane kroki).

Pasek stanu

Pasek stanu jest wyświetlany w dolnej części edytora i zawiera ważne informacje o zapytaniu, takie jak czas wykonywania, łączna liczba kolumn i wiersze oraz stan przetwarzania. Po prawej stronie paska stanu znajdują się również ikony, których można użyć do zmiany bieżącego widoku.

Zrzut ekranu przedstawiający pasek stanu w nowym Edytor Power Query, przedstawiający stan przetwarzania, kolumny i liczby wierszy oraz ikony widoku.

Pasek formuły

Na pasku formuły jest wyświetlane wyrażenie języka formuły Power Query M dla wybranego kroku. Wyrażenie można edytować bezpośrednio na pasku formuły, aby dostosować pojedynczy krok lub użyć Edytor zaawansowany do pracy z pełnym skryptem zapytania.

Uzyskaj pomoc

Karta Pomoc w Edytorze Power Query zawiera linki do informacji o usłudze Power BI. Aby uzyskać dostęp do tych samych opcji pomocy, wybierz pozycjęPomocdotycząca plików>.

Edytor zaawansowany

Edytor zaawansowany pozwala zobaczyć kod, który Edytor Power Query tworzy przy każdym kroku. Umożliwia również tworzenie własnego kodu w języku formuł Power Query M. Aby uruchomić edytor zaawansowany, wybierz pozycję Widok na wstążce, a następnie wybierz pozycję Edytor zaawansowany. Zostanie wyświetlone okno z wyświetlonym kodem wygenerowanym dla wybranego zapytania.
Zrzut ekranu programu Power BI Desktop przedstawiający okno dialogowe Edytor zaawansowany.

Kod można edytować bezpośrednio w oknie Edytor zaawansowany. Aby zamknąć okno, wybierz przycisk Gotowe lub Anuluj .

Edytor zaawansowany jest dostępna zarówno w nowym, jak i starszym środowisku. Powyższy zrzut ekranu przedstawia starszy interfejs. Niektóre elementy sterujące i opcje wyświetlania w Edytor zaawansowany różnią się w nowej wersji. Aby uzyskać więcej informacji, zobacz Nowe środowisko Power Query — znane ograniczenia i sposoby ich obejścia.

Zapisywanie pracy

Gdy zapytanie jest ustawione zgodnie z twoimi oczekiwaniami, wybierz pozycję Zamknij i zastosuj z menu Plik Edytora Power Query. Ta akcja powoduje zastosowanie zmian i zamknięcie edytora.
Zrzut ekranu programu Power BI Desktop przedstawiający opcję Zamknij i Zastosuj na karcie Plik.

W miarę postępu program Power BI Desktop udostępnia okno dialogowe umożliwiające wyświetlenie jego stanu.
Zrzut ekranu programu Power BI Desktop przedstawiający okno dialogowe potwierdzenia zmian zapytania zastosowanych.

Gdy wszystko będzie gotowe, program Power BI Desktop może zapisać swoją pracę w postaci pliku pbix .

Aby zapisać swoją pracę, wybierz Plik>Zapisz (lub Plik>Zapisz jako), jak pokazano na poniższym obrazie. Zrzut ekranu programu Power BI Desktop przedstawiający kartę Plik Edytora Power Query. Wyróżniono opcje 'Zapisz' i 'Zapisz jako'.

W programie Power BI Desktop można wykonywać różne czynności. Aby uzyskać więcej informacji na temat jej możliwości, zapoznaj się z następującymi zasobami: