Rozwiązywanie problemów z wdrażaniem podczas ponownego uruchamiania lub zmieniania rozmiaru istniejącej maszyny wirtualnej z systemem Windows na platformie Azure

Podczas próby uruchomienia zatrzymanej maszyny wirtualnej platformy Azure lub zmiany rozmiaru istniejącej maszyny wirtualnej platformy Azure typowym błędem jest błąd alokacji. Ten błąd powoduje, że klaster lub region nie ma dostępnych zasobów lub nie może obsłużyć żądanego rozmiaru maszyny wirtualnej.

Jeśli problem z platformą Azure nie został rozwiązany w tym artykule, odwiedź fora platformy Azure w witrynach MSDN i Stack Overflow. Możesz opublikować swój problem na tych forach lub opublikować na @AzureSupport w serwisie Twitter. Możesz również przesłać żądanie pomoc techniczna platformy Azure. Aby przesłać wniosek o pomoc techniczną, na stronie pomoc techniczna platformy Azure wybierz pozycję Uzyskaj pomoc techniczną.

Zbieranie dzienników aktywności

Aby rozpocząć rozwiązywanie problemów, zbierz dzienniki aktywności, aby zidentyfikować błąd skojarzony z problemem. Poniższe linki zawierają szczegółowe informacje na temat procesu:

Wyświetlanie operacji wdrażania

Wyświetlanie dzienników aktywności w celu zarządzania zasobami platformy Azure

Problem: Błąd podczas uruchamiania zatrzymanej maszyny wirtualnej

Próbujesz uruchomić zatrzymaną maszynę wirtualną, ale otrzymasz błąd alokacji.

Przyczyna

Żądanie uruchomienia zatrzymanej maszyny wirtualnej wymaga podjęcia próby w oryginalnym klastrze hostującym usługę w chmurze. Jednak klaster nie ma wolnego miejsca do spełnienia żądania.

Rozwiązanie

  • Zatrzymaj wszystkie maszyny wirtualne w zestawie dostępności, a następnie uruchom ponownie każdą maszynę wirtualną.

    1. Kliknij pozycję Grupy>zasobów grupy> zasobówZasoby>zestaw> dostępności Virtual Machines>zatrzymaj maszyny> wirtualnejZatrzymaj.
    2. Po zatrzymaniu wszystkich maszyn wirtualnych wybierz każdą z zatrzymanych maszyn wirtualnych i kliknij przycisk Start.
  • Ponów próbę ponownego uruchomienia żądania w późniejszym czasie.

Problem: Błąd podczas zmiany rozmiaru istniejącej maszyny wirtualnej

Próbujesz zmienić rozmiar istniejącej maszyny wirtualnej, ale zostanie wyświetlony błąd alokacji.

Przyczyna

Żądanie zmiany rozmiaru maszyny wirtualnej należy podjąć w oryginalnym klastrze hostującym usługę w chmurze. Klaster nie obsługuje jednak żądanego rozmiaru maszyny wirtualnej.

Rozwiązanie

  • Ponów próbę żądania przy użyciu mniejszego rozmiaru maszyny wirtualnej.

  • Jeśli nie można zmienić rozmiaru żądanej maszyny wirtualnej:

    1. Zatrzymaj wszystkie maszyny wirtualne w zestawie dostępności.

      • Kliknij pozycję Grupy>zasobów grupy> zasobówZasoby>zestaw> dostępności Virtual Machines>zatrzymaj maszyny> wirtualnejZatrzymaj.
    2. Po zatrzymaniu wszystkich maszyn wirtualnych zmień rozmiar żądanej maszyny wirtualnej na większy rozmiar.

    3. Wybierz maszynę wirtualną o zmienionym rozmiarze i kliknij przycisk Start, a następnie uruchom każdą z zatrzymanych maszyn wirtualnych.

Błąd podczas zatrzymywania, uruchamiania, ponownego uruchamiania lub ponownego wdrażania istniejącej maszyny wirtualnej

Podczas próby zatrzymania, uruchomienia, ponownego uruchomienia lub ponownego wdrożenia istniejącej maszyny wirtualnej proces zakończy się niepowodzeniem i zostanie wyświetlony komunikat "Wystąpił nieoczekiwany błąd podczas przetwarzania profilu sieciowego maszyny wirtualnej. Spróbuj ponownie później" komunikat o błędzie. W przypadku wystąpienia tego błędu maszyna wirtualna jest umieszczana w stanie niepowodzenia.

Przyczyna

Ten problem występuje, jeśli wystąpił problem podczas przydzielania lub aktualizowania zasobów sieciowych.

Rozwiązanie

Spróbuj ponownie zastosować stan maszyny wirtualnej. Ta operacja ponownie uruchamia aprowizację maszyny wirtualnej i pomaga rozwiązać problem z błędem stanu maszyny wirtualnej występującym w przypadku niepowodzenia aprowizacji maszyny wirtualnej po uruchomieniu poprzedniej akcji maszyny wirtualnej.

  1. Przejdź do maszyny wirtualnej, która jest zablokowana w stanie niepowodzenia.
  2. W obszarze Pomoc wybierz pozycję Ponownie wdróż i ponownie zaaplikuj.
  3. Wybierz opcję Ponownie aplikuj .

Następne kroki

Jeśli podczas tworzenia nowej maszyny wirtualnej z systemem Windows na platformie Azure wystąpią problemy z wdrażaniem, zobacz Rozwiązywanie problemów z wdrażaniem podczas tworzenia nowej maszyny wirtualnej z systemem Windows na platformie Azure.

Skontaktuj się z nami, aby uzyskać pomoc

Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii platformy Azure.