Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Dotyczy: ✔️ maszyny wirtualne z systemem Windows
Ten artykuł zawiera kroki rozwiązywania problemów, w których system operacyjny gościa napotyka problem i próbuje ponownie uruchomić maszynę wirtualną platformy Azure. Ponadto wyświetlany zostanie następujący komunikat o błędzie:
Nie obsłużyno wyjątku wątku systemowego.
Symptomy
Gdy używasz diagnostyki rozruchu do wyświetlenia zrzutu ekranu danych wyjściowych maszyny wirtualnej, zauważysz, że system Windows musi ponownie uruchomić się po powrocie kodu zatrzymania "WYJĄTEK WĄTKU SYSTEMOWEGO NIE OBSŁUŻONO" lub "0x0000007E" kodu błędu.
Przyczyna
Przyczyną tego problemu nie można ustalić, dopóki plik zrzutu pamięci nie zostanie przeanalizowany. Kontynuuj zbieranie pliku zrzutu pamięci.
Rozwiązanie
Napiwek
Jeśli masz najnowszą kopię zapasową maszyny wirtualnej, możesz spróbować przywrócić maszynę wirtualną z kopii zapasowej , aby rozwiązać problem z ponownym uruchomieniem.
Aby rozwiązać ten problem, zbierz plik zrzutu pamięci dla zdarzenia i wyślij plik do pomoc techniczna firmy Microsoft. Aby zebrać plik zrzutu, postępuj zgodnie z instrukcjami w następnych sekcjach.
Część 1. Dołączanie dysku systemu operacyjnego do maszyny wirtualnej odzyskiwania
Utwórz kopię zapasową migawki dysku systemu operacyjnego maszyny wirtualnej, której dotyczy problem. Aby uzyskać więcej informacji, zobacz Tworzenie migawki wirtualnego dysku twardego.
Dołącz dysk systemu operacyjnego do maszyny wirtualnej odzyskiwania.
Użyj protokołu RDP (Remote Desktop Protocol), aby połączyć się zdalnie z maszyną wirtualną odzyskiwania.
Jeśli dysk systemu operacyjnego maszyny wirtualnej, której dotyczy problem, jest szyfrowany, wyłącz szyfrowanie przed przejściem do następnego kroku. Aby uzyskać więcej informacji, zobacz Odszyfrowywanie zaszyfrowanego dysku systemu operacyjnego.
Część 2. Lokalizowanie pliku zrzutu i przesyłanie biletu pomocy technicznej
Na maszynie wirtualnej odzyskiwania przejdź do folderu systemu Windows na dołączonym dysku systemu operacyjnego. Jeśli na przykład litera dysku przypisana do dołączonego dysku systemu operacyjnego to F, przejdź do folderu F:\Windows.
Znajdź plik Memory.dmp, a następnie prześlij bilet pomocy technicznej i dołącz plik zrzutu.
Uwaga 16.
Jeśli masz problemy z lokalizowaniem pliku Memory.dmp , możesz zamiast tego spróbować użyć wywołań przerwania niemaskowalnego (NMI) w konsoli szeregowej. Skorzystaj z tych wskazówek, aby wygenerować plik zrzutu awaryjnego przy użyciu wywołań NMI.
Następne kroki
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.